apt+http format does not work

Bug #132070 reported by Marsolin on 2007-08-12
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: apturl

Clicking an apt+http link results in apturl opening and closing without any notification. I had to open KSysGuard in order to even tell if apturl loaded at all.

Marsolin (chadm) wrote :

This no launches apturl successfully, creates the appropriate file in /etc/apt/sources.list.d, then does an update before saying the package can't be found. Using either Synaptic or Adept manually doesn't work either.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please tell me what apt+http:// link you clicked that caused the issue?

Thanks,
 Michael

Changed in apturl:
status: New → Incomplete
wolfger (wolfger) wrote :

5 months without a response. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in apturl:
status: Incomplete → Invalid
Fernando Muñoz (fmunozs) wrote :

I'm sorry to comment on this old bug, but I am trying a simple apt+http://foobar on firefox address bar, and I get an error message that says:

An error occurred while loading or saving configuration information for firefox. Some of your configuration settings may not work properly.

Bad key or directory name: "/desktop/gnome/url-handlers/apt+http/enabled": `+' is an invalid character in key/directory names

Which makes me think that apt+http doesn't work at all. I'm using hardy.

wolfger (wolfger) wrote :

Fernando, thanks for resurrecting this bug. I have just confirmed the same behavior exists on Intrepid as well. I'm not sure this is an apturl bug, though. I think it may belong to Firefox. I'll re-open this against both groups.

Changed in apturl:
status: Invalid → Confirmed
Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug (starting with a completely new user profile)?

This will help us to find and resolve the problem.

Changed in firefox-3.0:
status: New → Incomplete
Endolith (endolith) wrote :

Why is it apt+ in the first place when the others are apt:? That doesn't even look like a protocol. Is it even supposed to work as a link in Firefox?

Fernando Muñoz (fmunozs) wrote :

Chris:

1. Type apt+http://foobar on firefox address bar
2. You'll get an error message:

An error occurred while loading or saving configuration information for firefox. Some of your configuration settings may not work properly.
Bad key or directory name: "/desktop/gnome/url-handlers/apt+http/enabled": `+' is an invalid character in key/directory names

Endolith: I think that's the problem, the '+ is an invalid character' message makes me think so.

Endolith (endolith) wrote :

It does seem to be the intended behavior:

Parser.py

101 # check for schemas of the form: apt+http://
102 if schema.startswith("apt+"):
103 apt_url.repo_url = schema[len("apt+"):] + ":" + package.split("?",1)[0]

I'm not sure it *should* be the intended behavior, but it is.

Endolith (endolith) wrote :

"Which makes me think that apt+http doesn't work at all."

Does it work on the command line?

    apturl apt+http://launchpad.net/~mvo/ppa?package=2vcard

    Installs 2vcard from the indicated PPA (if the user confirms), and afterwards
    asks if the PPA should be removed again or it should remain enabled.

    Warning: This is currently disabled because of security concerns.

Fernando Muñoz (fmunozs) wrote :

The problem is that the + is not allowed on Gconf 'directories' names, so it won't be added to the url handlers, and won't work when clicking an apt+http link, which is the intended use (I believe), it seems to work from the command line though. It will be necessary to change the +.

Antono Vasiljev (antono) wrote :

I think it possible to change apt+http:// to apturl:// for quick fix this problem.

apturl://launchpad.net/~mvo/ppa?package=2vcard

apturl:// schema will make GConf happy about key name and i think it looks good.

This really nice feature blocks ubuntu users and developers from one click sharing their PPA and bug is 2 years old.

I can provide patch if nobody cares about apturl.

Antono Vasiljev (antono) wrote :

In previous comment i should write "This really simple bug" instead "really nice feature".

Endolith (endolith) wrote :

Actually, when I enter

    apturl apt+http://launchpad.net/~mvo/ppa?package=2vcard

on the command line, it installs the package. It doesn't work in Fish shell, but it works in bash. I don't think it's actually installing a repository, though...

wolfger (wolfger) wrote :

I have tried to replicate this bug in 11.10, and it seems now that Firefox handles apt+http: without errors (prompting me to select AptURL to handle it). Marking the Firefox portion of this bug invalid.

Changed in firefox-3.0 (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers