apturl-gtk crashed with AttributeError in __init__(): 'InstallBackendAptdaemon' object has no attribute 'connect'

Bug #1200775 reported by Anonymous on 2013-07-12
166
This bug affects 37 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
High
Iain Lane
update-manager (Ubuntu)
High
Unassigned

Bug Description

using ubuntu 13.10 'saucy salimander' 64bit but everything keeps crashing i was mislead into thinking ubuntu was a sound linu distro but having nothing but issues will NOT be using any longer or again

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: apturl 0.5.2ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-2.11-generic 3.10.0
Uname: Linux 3.10.0-2-generic x86_64
ApportVersion: 2.10.2-0ubuntu4
Architecture: amd64
Date: Fri Jul 12 22:03:49 2013
ExecutablePath: /usr/bin/apturl-gtk
InstallationDate: Installed on 2013-07-12 (0 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130626)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
ProcCmdline: /usr/bin/python3 /usr/bin/apturl-gtk apt:samba,libpam-smbpass
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/apturl-gtk', 'apt:samba,libpam-smbpass']
SourcePackage: apturl
Title: apturl-gtk crashed with AttributeError in __init__(): 'InstallBackendAptdaemon' object has no attribute 'connect'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Anonymous (tef-y2k) wrote :
tags: removed: need-duplicate-check
Changed in apturl (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apturl (Ubuntu):
status: New → Confirmed
Christopher Townsend (townsend) wrote :

Changing to Public as there is no user sensitive data attached to this bug.

I also hit this issue by trying to enable the Sharing Service from within Nautilus.

information type: Private → Public
Bradley Popoff (bg-popoff-h) wrote :

This crash happened with I enabled sharing of a folder.

Thomas (t.c) wrote :

I got the crash too, but have not enabled folder sharing, only desktop sharing (vino).

What I see, that in firefox apt urls dont work. But I have url handler definied like this:

network.protocol-handler.app.apt = /usr/bin/apturl

in about config.

Possible the crash come from a try to open the apt-url. But I got it displayed after a new login to the desktop.

Jakub Orlowski (jakub-o) wrote :

it says the name of the shared folder is too long, unfortunately it cannot be changed prior to clicking the share box.
and to the author, please be aware what a alpha and beta is and stop talking bs.

Jakub Orlowski (jakub-o) wrote :

ok i take the "too long back, the problem remains anyway...

It is the first time I try "apturl" on this computer ( i386/686, 32 bits )since I have lost the possibility to access
" ubuntu software-center ", about 2 weeks ago, just after one update.
I can't install any .deb, unless the " synaptics ) ones.
Sure I have done somme mistakes .What can I do ?
Note : My second computer ( i86_64 ) works perfectly with " software-center ".
Excuse my scolar English.

Leo (leillo1975) wrote :

I have this error when I try to share a folder.

Danny Houtworm (houtworm) wrote :

i have this problem when i open a package that i looked for using the gnome shell
 its some extension wich allows you to look for packages available to install
software center wont start this way its not really a big deal for me since i can open it manually
if i open it manually i can install everything i desire no problem no bug

tmsbrdrs (tmsbrdrs) wrote :

the gnome-shell extension mentioned is appsearch, it uses apturl to install packages without opening ubuntu software center.
I'm having the same issues with installing packages this way. I've also run into similar problems using ubuntu software center, though the majority of packages I've installed through usc have worked properly. Currently using Ubuntu Gnome 13.10, updated fully.

hey guys.after crash in login i had a wpa problem in the same time and a linksys open connection in wifi.i opened the bluetooth plugins after renabling network it didnt load.whats going on? sharing activities totally disabled.

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py", line 71, in Load
    self.__load_plugin(self.__classes[name])
  File "/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py", line 171, in __load_plugin
    inst._load(self.user_data)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/AppletPlugin.py", line 73, in _load
    self.on_manager_state_changed(applet.Manager != None)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/Networking.py", line 45, in on_manager_state_changed
    self.update_status()
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/Networking.py", line 69, in update_status
    self.set_nap(self.Config.props.nap_enable or False)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/Networking.py", line 87, in set_nap
    s.Register("nap", "pan1")
  File "/usr/lib/python2.7/dist-packages/blueman/bluez/utils.py", line 28, in warp
    raise errors.parse_dbus_error(exception)
DBusAlreadyExistsError: Already Exists

Changed in apturl (Ubuntu):
importance: Medium → High
Changed in update-manager (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Confirmed, "apturl apt:<name>", stopped working in saucy. It's start in v 0.189 and seems to be due to https://code.launchpad.net/~dylanmccall/update-manager/dialogs-refactor/+merge/164673

Dylan, Dmitrijs ... could you guys have a look to the issue?

Changed in update-manager (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)

Crashes on trying to load the software centre.

Guy Stone (stoneguy3) wrote :

Same use case as Townsend

is there any chance after manually adding some ppas to software repository and then after deleting it from software center, not to be totally deleted and stored back? i think i saw tht in some case and deleted it again but days had passed.

jbld (umberto-baldini) wrote :

Same behaviour on 13.10 amd 64, 3.11.0-11-generic on gnome-flashback DE, no wpa problems like post #12 ( but... uh... i use a wire to connect ) and no software center issues as in post #14.

Michael Vogt (mvo) wrote :

I pushed a quick fix into the attached branch, but given the churn in update-manager its probably better to completely separate the InstallBackendAptdaemon.py from re-using update-managers code.

Iain Lane (laney) on 2013-10-09
Changed in update-manager (Ubuntu):
assignee: Dmitrijs Ledkovs (xnox) → Iain Lane (laney)
assignee: Iain Lane (laney) → nobody
status: Confirmed → Invalid
Changed in apturl (Ubuntu):
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.5.2ubuntu2

---------------
apturl (0.5.2ubuntu2) saucy; urgency=low

  * adjust backend to reuse the bits from update-manager (LP: #1200775)
 -- Michael Vogt <email address hidden> Tue, 08 Oct 2013 20:14:22 +0200

Changed in apturl (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers