apturl-gtk crashed with TypeError in _on_finished(): 5 parameters needed for signal action-done; 3 given

Bug #1103024 reported by Jan Minařík
136
This bug affects 30 people
Affects Status Importance Assigned to Milestone
apturl
Fix Released
Undecided
Unassigned
apturl (Ubuntu)
High
Martin Pitt
Raring
High
Martin Pitt
nautilus-share (Ubuntu)
High
Unassigned
Raring
High
Unassigned

Bug Description

try to install samba, but it crashes

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: apturl 0.5.1ubuntu6
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic i686
ApportVersion: 2.8-0ubuntu2
Architecture: i386
CasperVersion: 1.330
Date: Tue Jan 22 15:58:07 2013
ExecutablePath: /usr/bin/apturl-gtk
InterpreterPath: /usr/bin/python3.3
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130120)
MarkForUpload: True
ProcCmdline: /usr/bin/python3 /usr/bin/apturl-gtk apt:samba,libpam-smbpass
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/apturl-gtk', 'apt:samba,libpam-smbpass']
SourcePackage: apturl
Title: apturl-gtk crashed with TypeError in _on_finished(): 5 parameters needed for signal action-done; 3 given
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python3/dist-packages/AptUrl/gtk/backend/InstallBackendAptdaemon.py", line 82, in _on_finished
     True, dialog._transaction.exit == EXIT_SUCCESS)
 TypeError: 5 parameters needed for signal action-done; 3 given
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Jan Minařík (minoscz) wrote :
tags: removed: need-duplicate-check
Changed in apturl (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apturl (Ubuntu):
status: New → Confirmed
Barry Warsaw (barry)
information type: Private → Public
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1103024

tags: added: package-qa-testing
Revision history for this message
Carla Sella (carla-sella) wrote :

I was installing SAMBA to share a folder and even if the crash occurred after closing and re-opening the sharing window I could share folder all the same.

Revision history for this message
MAJED DUDIN (mdudin) wrote :

also noticed invalid UTF-8 in place of time

Changed in apturl (Ubuntu):
importance: Medium → High
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Why are you using apt-url-gtk in the first place?

xdg-open apt://samba opens software-centre to install those packages.

Revision history for this message
Brian Murray (brian-murray) wrote :

How did you go about installing samba? Were you clicking a link on a web page? If so what web page?

Changed in apturl (Ubuntu Raring):
status: Confirmed → Incomplete
Revision history for this message
noname2 (noname2-deactivatedaccount) wrote :

for me its happpening whe i try to use nautius user share for the first time. it then asks wheter i want to install samba to use the file shareing.

Revision history for this message
Brian Murray (brian-murray) wrote :

I was able to recreate this by choosing to share a folder in nautilus and following along to install packages.

Revision history for this message
Brian Murray (brian-murray) wrote :

Looks like this functionality exists in nautilus-share and 03_use_apturl.patch.

Changed in nautilus-share (Ubuntu Raring):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Martin Pitt (pitti) wrote :

Trivially reproducible with "apturl apt:pmount" (or any other uninstalled package).

Changed in apturl (Ubuntu Raring):
assignee: nobody → Martin Pitt (pitti)
status: Incomplete → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

nautilus-share just calls apturl, closing task.

Changed in nautilus-share (Ubuntu Raring):
status: Triaged → Won't Fix
status: Won't Fix → Invalid
Changed in nautilus-share (Ubuntu):
status: Triaged → Invalid
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr r130.

Changed in apturl:
status: New → Fix Released
Changed in apturl (Ubuntu Raring):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.5.2ubuntu1

---------------
apturl (0.5.2ubuntu1) raring; urgency=low

  * AptUrl/gtk/backend/__init__.py: Drop "action-done" signal definition;
    update-manager's GTK backend already defines it with different arguments,
    so this is ineffective and confusing.
  * AptUrl/gtk/GtkUI.py, _on_backend_done(): Add additional error signal
    arguments, as defined by update-manager's backend.
  * AptUrl/gtk/backend/InstallBackend{Aptdaemon,Synaptic}.py: Call action-done
    signal with error arguments. (LP: #1103024)
  * data/apturl-gtk.ui: Drop obsolete "has_separator" property. Fixes a
    warning.
 -- Martin Pitt <email address hidden> Tue, 09 Apr 2013 13:23:37 +0200

Changed in apturl (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers