Internal error in the solver (multi-arch: foreign packages not considered to solve other-arch dependencies)

Bug #968412 reported by Vladimir Kolesnikov on 2012-03-29
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
aptitude (Ubuntu)
Undecided
Unassigned

Bug Description

The following packages have unmet dependencies:
  python-uno: Depends: libreofficeu-core (= 1:3.5.1-1ubuntu2) which is a virtual package.
Internal error: the solver Install(glib-networking-services 2.31.22-1 <glib-networking 2.32.0-1 -> {glib-networking-services 2.31.22-1 glib-networking-services 2.31.22-1 glib-networking-services 2.32.0-1 glib-networking-services 2.32.0-1}>) of a supposedly unresolved dependency is already installed in step 2902
Internal error: the solver Install(gvfs-daemons 1.11.5-1ubuntu1 <gvfs 1.12.0-0ubuntu1 -> {gvfs-daemons 1.11.5-1ubuntu1 gvfs-daemons 1.11.5-1ubuntu1 gvfs-daemons 1.12.0-0ubuntu1 gvfs-daemons 1.12.0-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 2907
Internal error: the solver Install(flashplugin-installer 11.1.102.63ubuntu2 <flashplugin-downloader 11.2.202.228ubuntu1 -> {flashplugin-installer 11.1.102.63ubuntu2 flashplugin-installer 11.2.202.228ubuntu1 flashplugin-installer 11.2.202.228ubuntu1}>) of a supposedly unresolved dependency is already installed in step 3004
Internal error: the solver Install(ghostscript 9.05~dfsg-0ubuntu3 <gs-cjk-resource 1.20100103-3 -> {ghostscript 9.05~dfsg-0ubuntu3 ghostscript 9.05~dfsg-0ubuntu3}>) of a supposedly unresolved dependency is already installed in step 3014
Internal error: the solver Install(ghostscript 9.05~dfsg-0ubuntu3 <ghostscript-x 9.05~dfsg-0ubuntu3 -> {ghostscript 9.05~dfsg-0ubuntu3 ghostscript 9.05~dfsg-0ubuntu3}>) of a supposedly unresolved dependency is already installed in step 3014
Internal error: the solver Install(flashplugin-installer 11.1.102.63ubuntu2 <flashplugin-downloader 11.2.202.228ubuntu1 -> {flashplugin-installer 11.1.102.63ubuntu2 flashplugin-installer 11.2.202.228ubuntu1 flashplugin-installer 11.2.202.228ubuntu1}>) of a supposedly unresolved dependency is already installed in step 3569

The full session transcript will be attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: aptitude 0.6.5-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Thu Mar 29 18:51:51 2012
ProcEnviron:
 LANGUAGE=en
 TERM=xterm
 SHELL=/bin/bash
 LANG=ru_UA.UTF-8
SourcePackage: aptitude
UpgradeStatus: Upgraded to precise on 2012-03-18 (10 days ago)

Related branches

Vladimir Kolesnikov (sjinks) wrote :
Vladimir Kolesnikov (sjinks) wrote :

Full session transcript

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptitude (Ubuntu):
status: New → Confirmed
Vladimir Kolesnikov (sjinks) wrote :

Output of dpkg -l in case it can help.

Daniel Hartwig (wigs) wrote :

Looks like this might be a multi-arch issue: #651748 (bugs.d.o), which is fixed in 0.6.6. Please confirm whether this is resolved once that version reaches Ubuntu.

Vladimir Kolesnikov (sjinks) wrote :

I am afraid it is not fixed

The following packages have unmet dependencies:
 libreoffice-kde : Depends: libreoffice-core (= 1:3.5.1-1ubuntu2) but 1:3.5.1-1ubuntu1 is installed.
Internal error: the solver Install(ghostscript:i386 9.05~dfsg-0ubuntu4 <gs-cjk-resource:amd64 1.20100103-3 -> {ghostscript:amd64 9.05~dfsg-0ubuntu4 ghostscript:i386 9.05~dfsg-0ubuntu4}>) of a supposedly unresolved dependency is already installed in step 2486
Internal error: the solver Install(ghostscript:i386 9.05~dfsg-0ubuntu4 <ghostscript-x:amd64 9.05~dfsg-0ubuntu4 -> {ghostscript:amd64 9.05~dfsg-0ubuntu4 ghostscript:i386 9.05~dfsg-0ubuntu4}>) of a supposedly unresolved dependency is already installed in step 2486
Internal error: the solver Install(bamfdaemon:i386 0.2.114-0ubuntu1 <libbamf3-0:amd64 0.2.114-0ubuntu1 -> {bamfdaemon:amd64 0.2.114-0ubuntu1 bamfdaemon:i386 0.2.114-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 2512
Internal error: the solver Install(bamfdaemon:i386 0.2.114-0ubuntu1 <libbamf0:amd64 0.2.114-0ubuntu1 -> {bamfdaemon:amd64 0.2.114-0ubuntu1 bamfdaemon:i386 0.2.114-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 2512

$ LC_ALL=C apt-cache policy aptitude
aptitude:
  Installed: 0.6.6-1ubuntu1
  Candidate: 0.6.6-1ubuntu1
  Version table:
 *** 0.6.6-1ubuntu1 0
        500 http://ua.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Vladimir Kolesnikov (sjinks) wrote :
Kevin Funk (kfunk) wrote :

Bump. Is this being discussed?

I cannot make use of ppa-purge (which apparently uses aptitude internally) right now as it tries to uninstall the whole system.

Daniel Hartwig (wigs) wrote :

A patch has been submitted against Bug #831768 which, in my testing, resolves this issue also.

Please test that patch if you are affected by this bug and report whether or not it works.

Daniel Hartwig (wigs) on 2012-08-09
summary: - Internal error in the solver
+ Internal error in the solver (multi-arch: foreign packages not
+ considered to solve other-arch dependencies)
Daniel Hartwig (wigs) wrote :

Marking as fixed based on my comment #9. See also bug #831768.

Changed in aptitude (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers