Forget new packages doesn't save its action

Bug #845136 reported by Francis J. Lacoste on 2011-09-08
394
This bug affects 96 people
Affects Status Importance Assigned to Milestone
aptitude
Fix Released
Unknown
Baltix
Undecided
Unassigned
aptitude (Ubuntu)
Medium
Unassigned
Nominated for Oneiric by Rolf Leggewie

Bug Description

Since I've upgraded to Oneiric, the "Forget new packages" menu options doesn't save its change.

I'll do 'f' (or use the menu, doesn't matter) once, and the 'New Packages' section will be removed.

But if I quit and reopen, or simply do an upgrade, when it comes back to the main screen. The 'New Packages' section is back, like if I never used the option in the first place.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: aptitude 0.6.4-1ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Thu Sep 8 16:31:29 2011
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: aptitude
UpgradeStatus: Upgraded to oneiric on 2011-09-08 (0 days ago)

NOTE: Apparently, this ticket does not affect i386 systems (Rolf Leggewie)

Related branches

Francis J. Lacoste (flacoste) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptitude (Ubuntu):
status: New → Confirmed

After an upgrade from Natty to Oneiric I am also affected.

I discovered two additional things:
1. Many or all packages appear twice. For an installed package the twin entry appears not to be installed.
2. After starting aptitude sometimes shows "New Packages (39593)", and sometimes "New Packages (19858)", while the numbers of (already seen) not installed packages changes vice versa. The number of installed packages is also changing by about factor 2.

Compared to an Oneiric installation lacking the problems, there was a file /etc/dpkg/dpkg.cfg.d/multiarch on the affected system, that contained one line: "foreign-architecture i386". After removing it, everything seems to be fine.

tags: added: multiarch
Gary Lyons (gllyons) wrote :

I found if i remove the file /etc/dpkg/dpkg.cfg.d/multiarch then aptitude insits on removing

   flashplugin-installer [11.0.1.152ubuntu1 (now, oneiric)]
    nspluginwrapper [1.4.4-0ubuntu3 (now, oneiric)]

because of unavailable dependencies. specifically I see

      --- flashplugin-downloader (>= 11.0.1.152ubuntu1) (UNAVAILABLE)

Dirk Heinrichs (dirk-heinrichs) wrote :

Did you try the 64bit one?

sudo apt-add-repository ppa:sevenmachines/flash
sudo apt-get update
sudo apt-get install flashplugin64-installer

Gary Lyons (gllyons) wrote :

That ppa is marked as depreciated. The flash in 11.10 appears to already be 64bit. It is just that the flashplugin-downloades program is 32 bit and flash depends on it.

Dirk Heinrichs (dirk-heinrichs) wrote :

Yes, recognised it today, too. It's in the Canonical partner repository, now. And it seems it doesn't need the downloader anymore.

The double packages are not duplicates, the packages have different sizes.
Unfortunately, aptitude does not show any other attribute that differs, so I have no idea what exactly is happening there; it could well be a multiarch issue. I took a handful of samples and it seemed that script-only packages were there only once, but that could be an accident.

I disabled the multiarch file by renaming it to .multiarch.
I got a lot of updates, plus it wanted to remove flashplugin-installer and nspluginwrapper, which didn't come unexpected.

However, adobe-flashplugin, while installing cleanly, will not make Youtube work again.
Installing flashplugin-installer would fail because it wanted flashplugin-downloader and nspluginwrapper.
I had to go to Adobe's page, which in turn sent me to Canonical's "partner" repository. Installing now, hopefully it will work...

... well, it doesn't. No error messages that I can see.
Despite having the Applications > Other > Adobe Flash Player application in the menu (that's probably adobe-flash-properties-gtk).
And despite Ubuntu Software Center telling me it's all installed and configured.

It's reporting it has version adobe-flashplugin 11.0.1.152-0oneiric1 installed.

mightymouse2045 (eagleeyes426) wrote :

I have the same problem - removing the multiarch file then breaks aptitude and requires to remove the 2 packages mentioned above.

I didn't do that because of the Joachim Durchholz's problems reinstalling and getting flash working again. But it is annoying having 2 packages listed and it is also causing dependency problems with other apps.

I noticed a few in libsensors4 and lmsensors were listed as being upgradeable but required manual intervention to get them upgraded.

Also and after removing the multiarch an rrd package? was then saying it was ready for an upgrade which I couldn't do because of the 2 flash packages being broken and once i put the multiarch file back it was saying that it was the latest version?!?!

At one point today I had 88 packages that were saying they needed to be removed after doing the upgrades that came out today, then after closing aptitude and opening it a few times the 88 apps were fixed? and no longer required being removed... or did I accidentally remove them coz I'm a noob with aptitude I DUNNO NOW! Shizen! It's freaking me out - do I continue forward configuring my system and installing apps I need only to get further and further into crap with the software databbase and have to do a full system rebuild yet again (the 3rd this freakin week!)

Seems this is pointing to some serious issues - but I hope they are able to be resolved without screwing up my system!

Rolf Leggewie (r0lf) wrote :

multiarch was a pretty intrusive change, but one that was necessary and should pay dividends in the future. As with most intrusive changes, there's breakage. That's why it was done in oneiric, to be ready for precise.

FWIW, I don't see this on a fresh install of precise. But I also have no file /etc/dpkg/dpkg.cfg.d/multiarch. Can somebody please do "dpkg -S /etc/dpkg/dpkg.cfg.d/multiarch" so we know which package provides that file?

Gary Lyons (gllyons) wrote :

It is part of dpkg

This bug and 831768 are killing me. Removing the multi arch appeared to work for a few days but now cups won't update because of an error like this

 libkrb5support0:amd64 1.9.1+dfsg-1ubuntu1.1 cannot be configured because libkrb5support0:i386 is in a different version

I have been a long time user of Debian and hen Ubuntu and one of the reasons for it is aptitude. If Ubuntu is no longer going to support aptitude maybe it is time to switch back to Debian.

Rolf Leggewie (r0lf) wrote :

Gary, thank you for the information. I'm not speaking for Ubuntu officially. As far as I'm aware aptitude still receives the full support of being included in main. I've not heard of anybody attempting to change that.

http://packages.ubuntu.com/oneiric/i386/dpkg/filelist
http://packages.ubuntu.com/precise/i386/dpkg/filelist

Neither of the two lists /etc/dpkg/dpkg.cfg.d/multiarch, so either the file has been dropped recently or it's being created by one of the maintainer scripts.

Rolf Leggewie (r0lf) wrote :

For what it's worth, a quick glance of the current oneiric source didn't reveal anything in the maintainer scripts to create said file, either. So, I have no idea where it's coming from. I did not have it on a fresh install of precise. That's all I can say.

Gary Lyons (gllyons) wrote :

the file does exist in precise. It is a pfiel that exists in amd64 installs not 1386. See the following package list.

http://packages.ubuntu.com/precise/amd64/dpkg/filelist

Rolf Leggewie (r0lf) wrote :

I see. Thank you for pointing that out. Could be a bug in dpkg as well, then...

I still install all my systems as i386 so I guess there's not much I can do here.

description: updated
tags: added: precise
Rolf Leggewie (r0lf) wrote :

I think this should be eventually fixed during the precise dev-cycle. Setting milestone.

Changed in aptitude (Ubuntu):
importance: Undecided → Medium
milestone: none → precise-alpha-2
status: Confirmed → Triaged
Rolf Leggewie (r0lf) wrote :

multiarch allows to install packages that are foreign to the native host arch. The duplicate packages you see are probably arch i386 and amd64 binary packages. Apparently, apt-get shows this information but aptitude does not which is filed as bug 817181. Feel free to let us know you are affected by this lack of information via https://bugs.launchpad.net/ubuntu/+source/aptitude/+bug/817181/+affectsmetoo

I can confirm that removing/renaming the multiarch file will cause lots of breakage. I got lots of problems with various libraries, mostly kerberos-related stuff.
Deleting these packages would have deinstalled half of Ubuntu, so I force-deleted them (leaving their dependencies installed), then reinstalled them. At that point, I'd get the conflict with the i386 versions of the packages that was mentioned above, and would be unable to configure them (rendering them essentially nonfunctional I guess).

Restoring the multiarch file would then delete a huge list of :i386 packages, configure the packages, and restore everything to working order - including the proprietary Flash plugin that had been broken since the multiarch experiment.
So I guess I'll live with the "Forget New Packages" problem and hope it's really just cosmetic - removing multiarch was definitely one of the worst experiments I ever tried on my system.

post-factum (post-factum) wrote :

I confirm this bug.

[pf@spock]:[~][1]% aptitude search "~N" | wc -l
19928
[pf@spock]:[~][0]% sudo aptitude forget-new
[sudo] password for pf:
[pf@spock]:[~][0]% aptitude search "~N" | wc -l
19903
[pf@spock]:[~][0]% sudo aptitude forget-new
[pf@spock]:[~][0]% aptitude search "~N" | wc -l
19903
[pf@spock]:[~][0]% cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
[pf@spock]:[~][0]% uname -a
Linux spock 3.0.0-14-server #23-Ubuntu SMP Mon Nov 21 20:49:05 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Martin Pitt (pitti) on 2012-02-06
Changed in aptitude (Ubuntu):
milestone: precise-alpha-2 → ubuntu-12.04-beta-1
Martin Pitt (pitti) on 2012-03-02
Changed in aptitude (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Changed in aptitude:
status: Unknown → Fix Committed
Daniel Hartwig (wigs) wrote :

remove unneeded Baltix task

Changed in baltix:
status: New → Invalid
Stephan Springer (geryon) wrote :

Aptitude 0.6.6-1 has been released upstream, which should fix this bug.

Changed in aptitude:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2012-03-30
Changed in aptitude (Ubuntu):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Launchpad Janitor (janitor) wrote :
Download full text (4.0 KiB)

This bug was fixed in the package aptitude - 0.6.6-1ubuntu1

---------------
aptitude (0.6.6-1ubuntu1) precise; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - debian/05aptitude: Never autoremove kernels.
    - Drop aptitude-doc to Suggests.
    - 03_branding: Ubuntu branding.
    - 04_changelog: Take changelogs from changelogs.ubuntu.com.
    - 11_ubuntu_uses_sudo: Fix status line of 'Become root' menu entry to
      not refer to su.
    - 12_point_manpage_to_doc_package: Point Finnish manpage to the correct
      place for further info.
    - 14_html2text_preferred: Switch back to html2text in favor of elinks,
      since html2text is in main and elinks isn't.
    - no-google-mock: Don't use google-mock as it and libgtest-dev are in
      universe.

aptitude (0.6.6-1) unstable; urgency=low

  * New upstream release.

    - Basic multi-arch support. See NEWS for details.

      + add search terms ?architecture and ?multiarch;
      + add grouping policy 'architecture';

      (Closes: #659079, #661744)
      (LP: #454941, #845136, #884945, #904486)

    - Apply patch from Ubuntu to fix build -D_FORTIFY_SOURCE=2 errors.
      Thanks to Colin Watson and Michael Vogt (Closes: #497539)

    - Remove GTK+ menu entry for minesweeper. (Closes: #552522)

    - Hack to prevent debug messages dumping to the screen (Closes: #651748)

    - Fix '?action(upgrade)' and others (were finding kept
      packages instead). Thanks to 'Rogier' for the patch (Closes: #603862)

    - List update errors are reported. (Closes: #451137)

    - List update now runs APT::Update hooks. (Closes: #476399)

    - Actually silence progress messages with '-q2'. (Closes: #141719)

    - Fix various locking issues:

      + '[auto]clean' locks /var/cache/apt/archives;
      + 'update' locks /var/lib/apt/lists; (Closes: #653479)

    - Fix 'priority' cost level in resolver. The values should
      have been negated but were not. Thanks to Modestas Vainius
      for this one. (Closes: #608786)

    - Fix some help and prompt strings which wrongly included
      localized names for commands such as 'why'. (Closes: #486615)

    - Change ordering of top-level sections to match the order
      in aptitude::Sections::Top-Sections. The default order
      is now: main, contrib, non-free. (Closes: #181997)

    - Improve error messages when parsing grouping policies to
      use the user-visible names, rather than the internal
      names. (Closes: #231595)

    - Change default width of %D, %I, %o, and %Z. Thanks to
      Michał Kułach for this one. (Closes: #599209) (LP: #741417)

    - Change default width of %V, %v to 14. This greatly increases the
      number of versions which will display completely. (Closes: #624542)

    - 'versions' now groups it's results by 'package:arch' instead of
      'package'.

    - Cleared up grouping, sorting policy error messages.
      (Closes: #231595)

    - Minor correction to the user's manual. (Closes: #365485)

    - Translation updates:

      + Brazilian Portuguese (Closes: #483964)
      + Hungarian (Closes: #592468)
      + Polish (Closes: #659803)
      + Russian (Closes: #662624)

  * No longer suppl...

Read more...

Changed in aptitude (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.