aptitude does not honour --download-only

Bug #216292 reported by Chris J on 2008-04-12
4
Affects Status Importance Assigned to Milestone
aptitude (Debian)
Confirmed
Unknown
aptitude (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: aptitude

The man page for aptitude claims:

-d, --download-only : Download packages to the package cache as necessary, but do not install or remove anything.

Every time I start aptitude (0.4.9-2ubuntu5) with either form of the option, once the download is complete it proceeds to install the downloaded packages.

Steps to reproduce:
* [sudo] aptitude -d [or --download-only]
* Select packages to install
* 'g' to review changes
* 'g' to start download

Expected result: packages are downloaded, return to selection screen
Actual result: packages are downloaded, installation takes place

Artem Popov (artfwo) wrote :

Hi, Chris!
From the aptitude man-page:

 -d, --download-only
           Download packages to the package cache as necessary, but do not
           install or remove anything. By default, the package cache is stored
           in /var/cache/apt/archives.

           This corresponds to the configuration option
           Aptitude::CmdLine::Download-Only.

As you can see, this option is for command-line operation (CmdLine), so it will only work when you install your packages from command-line, by running e.g. sudo aptitude -d install somepackage.

I suggest marking the bug as Invalid, as it does not look like a bug after all.

Chris J (chriscf) wrote :

Nonsense - the same option should produce the same behaviour no matter how the program is started.

Changed in aptitude:
status: Unknown → New

Thanks for taking the time to report this. Though I can follow your arguments (also on the Debian tracker) I think this is not a bug, as it is clear by the aptitude man page, that "-d" is directly connected to a command line option. The man pages describes "COMMAND-LINE ACTIONS" first, directly followed by the following text:

"The following options may be used to modify the behavior of the actions described above"

So the command line options described (like -d) are meant for using with the actions described above.

Thanks again for taking the time to investigate this. Maybe an upstream ticket would help updating man page and help text. (And: Please consider using a polite language when responding to people :) )

Changed in aptitude:
status: New → Incomplete
status: Incomplete → Invalid
Chris J (chriscf) wrote :

Not invalid. Please don't take that jobsworth attitude with me. There is no good reason why the option should be restricted only to command-line actions. That something stupid is documented doesn't make it any less stupid.

Changed in aptitude:
status: Invalid → Confirmed
Colin Watson (cjwatson) wrote :

This seems like a perfectly reasonable request and should be forwarded to the Debian maintainer (i.e. the upstream author). I don't know why everyone seems to be looking for reasons to close it.

Colin Watson (cjwatson) wrote :

Indeed, this bug is already associated with a Debian bug, where the upstream author has described a strategy for fixing the bug (in among some essentially irrelevant dispute about the bug's severity). Therefore it is completely wrong to close it in Ubuntu.

Changed in aptitude:
importance: Undecided → Wishlist
status: Confirmed → Triaged

Thanks for pointing this out and sorry for the misinterpretation.

Changed in aptitude (Debian):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.