aptitude fails to load package cache when repos aren't found

Bug #1746102 reported by pbhj on 2018-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
aptitude (Ubuntu)
Undecided
Unassigned

Bug Description

I had a repo with an error in `apt` such that the update's output would end:

    Reading package lists... Done
    N: Ignoring file 'plexmediaserver.list.broken' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
    E: The repository 'http://ppa.launchpad.net/transmissionbt/ppa/ubuntu artful Release' does not have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

When running an update by pressing `u` from within `aptitude` I found that the program would get to "Loading Cache" and wouldn't complete the process. The program was not hung, it could be cancelled, but the updated package list will not display.

Without the error -- by fixing the transmissionbt line within the file in `/etc/apt/sources.list.d/relevant-file.list` to point to zesty in this case -- aptitude can now complete the update and create the package list.

AFAIAA the way apt reports failing repos has changed; presumably this is related to the error?

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: aptitude 0.8.3-1ubuntu4
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Jan 29 21:33:11 2018
SourcePackage: aptitude
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.logrotate.d.aptitude: [modified]
mtime.conffile..etc.logrotate.d.aptitude: 2016-05-18T00:01:52.280557

pbhj (pbhj) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers