aptitude cannot display changelog : origin of $package is unknown

Bug #1583226 reported by Thomas on 2016-05-18
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
aptitude (Ubuntu)
Medium
Michael Hudson-Doyle

Bug Description

After upgrading to Yakkety and changed sources.list, aptitude is unable to retrieve packages changelogs.
It states an error message :

root@server:~$ aptitude changelog ubuntu-desktop
E: Cannot display changelog: Origin of ubuntu-desktop version 1.362 is unknown (maybe not an official Debian package; if it is, try to "update" package lists)

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: aptitude 0.8-1ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu4
Architecture: amd64
Date: Wed May 18 17:28:58 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-01-27 (477 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: aptitude
UpgradeStatus: Upgraded to yakkety on 2015-11-16 (184 days ago)

Thomas (thomasl) wrote :
dino99 (9d9) wrote :

Confirm the issue here too on amd yakkety; while 'synaptic' have no problem to display that changelog

oem@u64:~$ sudo aptitude changelog ubuntu-desktop
[sudo] password for oem:
E: Cannot display changelog: Origin of ubuntu-desktop version 1.362 is unknown (maybe not an official Debian package; if it is, try to "update" package lists)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptitude (Ubuntu):
status: New → Confirmed
PÁLFALVI Tamás (pt314) wrote :

This issue seems to have slipped through the cracks somehow. I came up with the attached patch that fixes the original issue mentioned above, as well as a segfault in the download path handling that was masked by the original problem.

The attachment "debdiff against aptitude 0.8.3-1ubuntu1" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in aptitude (Ubuntu):
importance: Undecided → Medium
tags: added: regression-release
PÁLFALVI Tamás (pt314) wrote :

Made a mistake in the previous patch. It should only affect logging, as far as I can tell, but I shouldn't break that either. Fixed the error, made a new debdiff - I'm sorry I wasn't more careful the first time around.

Michael Hudson-Doyle (mwhudson) wrote :

Thanks for the report, and for the patches! Instead of taking your debdiff as-is, I've merged your changes into the debian/patches/04_changelog file. Uploaded to zesty.

Changed in aptitude (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptitude - 0.8.3-1ubuntu4

---------------
aptitude (0.8.3-1ubuntu4) zesty; urgency=medium

  * No-change rebuild for libxapian30

 -- Iain Lane <email address hidden> Wed, 02 Nov 2016 11:48:55 +0000

Changed in aptitude (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers