Automatically-installed packages are being marked as manually installed

Bug #1479315 reported by Shahar Or on 2015-07-29

This bug report was converted into a question: question #269779: Automatically-installed packages are being marked as manually installed.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
aptitude (Ubuntu)
Undecided
Unassigned

Bug Description

Hi and thank you for the remarkable Aptitude.

I'm on the development version of Ubuntu and upgrade packages daily using aptitude.

Upon reviewing daily upgrades, I consistently discover that many packages which I am sure to have previously marked as automatically-installed, are now marked as manually installed.

What could be the cause of this, please?

dino99 (9d9) wrote :

a question rather than a bug

Changed in aptitude (Ubuntu):
status: New → Invalid
Shahar Or (mightyiam) wrote :

Aptitude may be the cause of this. I'm not using any other package manager.

Here is a screen shot. In it, you can see several libraries, which I have previously marked as automatically installed.

And they are now marked manually installed.

Changed in aptitude (Ubuntu):
status: Invalid → New
dino99 (9d9) wrote :
Shahar Or (mightyiam) wrote :

@9d9, I don't thing that this a duplicate of that, because it is not only kernels.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments