aptitude crashes when "New Categorical Browser" is selected from menu

Bug #1082198 reported by Paul White on 2012-11-22
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
aptitude
Fix Released
Unknown
aptitude (Debian)
Fix Released
Unknown
aptitude (Ubuntu)
High
Unassigned

Bug Description

Everytime "New Categorical Browser" is selected from the menu aptitude crashes.

All other options from the "View" menu seem to work correctly.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: aptitude 0.6.8.1-2ubuntu1
ProcVersionSignature: Ubuntu 3.7.0-3.9-generic 3.7.0-rc6
Uname: Linux 3.7.0-3-generic x86_64
ApportVersion: 2.6.2-0ubuntu5
Architecture: amd64
Date: Thu Nov 22 23:36:10 2012
InstallationDate: Installed on 2012-11-10 (12 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=screen-256color
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: aptitude
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Paul White (paulw2u) wrote :
Axel Beckert (xtaran) on 2012-11-23
Changed in aptitude (Ubuntu):
status: New → Confirmed
Changed in aptitude:
status: Unknown → Confirmed
Changed in aptitude (Debian):
status: Unknown → Confirmed
Paul White (paulw2u) on 2014-03-15
tags: added: saucy trusty
removed: raring

It prevents the package (or a dependent one) from functioning correctly at all.

Changed in aptitude (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High

Hi,

Alberto Salvia Novella wrote:
> It prevents the package (or a dependent one) from functioning correctly
> at all.
>
> ** Changed in: aptitude (Ubuntu)
> Importance: Undecided => High

I disagree on both.

The Categorical Browser is a historic feature which is is bound to be
removed from Aptitude and whose functionality has been superseeded by
the Debtags Browser for quite a while now.

See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717317#16 and
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717317#16 for
reference.

So It's useless to invest time to fix anything in there, except maybe
patching out the menu entry if you really want users not to run into
this issue (which only appears on multi-arch systems btw., see
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686124#10 for
reference).

  Regards, Axel
--
 ,''`. | Axel Beckert <email address hidden>, http://people.debian.org/~abe/
: :' : | Debian Developer, ftp.ch.debian.org Admin
`. `' | 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D89 9593 0EDE
  `- | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5

talat (mahmoodtc) on 2014-11-11
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in aptitude (Ubuntu):
status: Confirmed → Fix Released
Axel Beckert (xtaran) wrote :

Why should that bug be fixed?

It is surely neither fixed upstream nor in Debian and https://launchpad.net/ubuntu/+source/aptitude/+changelog does not mention any fix.

And I can easily reproduce this issue in a downloaded 14.10 live CD booted in kvm. And since vivid has no newer aptitude version than utopic, I can't imagine a single reason why that bug should be fixed in vivid.

tags: added: vivid
Axel Beckert (xtaran) on 2014-11-11
tags: added: utopic
Paul White (paulw2u) on 2014-11-11
tags: removed: saucy
Changed in hundredpapercuts:
status: Fix Released → Confirmed
Changed in aptitude (Ubuntu):
status: Fix Released → Confirmed
Changed in aptitude:
status: Confirmed → Fix Committed
Changed in aptitude (Debian):
status: Confirmed → Fix Committed
Changed in aptitude:
status: Fix Committed → Fix Released
Changed in aptitude (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptitude - 0.7-1ubuntu1

---------------
aptitude (0.7-1ubuntu1) wily; urgency=medium

  * Merge with Debian; remaining changes:
    - Drop aptitude-doc to Suggests.
    - 03_branding: Ubuntu branding.
    - 04_changelog: Take changelogs from changelogs.ubuntu.com.
    - 14_html2text_preferred: Switch back to html2text in favor of elinks,
      since html2text is in main and elinks isn't. Convert all files to utf-8
      encoding as it is better then ascii for iso-8859-1 (English docs).

aptitude (0.7-1) unstable; urgency=medium

  [ Manuel A. Fernandez Montecelo ]
  * New upstream release.
    - Changes in the versioning scheme and changelog (to follow loosely
      the Semantic Version specification)
    - Feature removal: The content-wise outdated and
      not-multiarch-compatible categorical browser has been removed. The
      Debtags browser has replaced most of its functionality already. Local
      package groups are no more available, though. The removal discussion
      has taken place in #686646. (Closes: #686124, #686142, #686646 as
      well as LP: #1082198).
    - Changes to allow to compile with C++11 compatibilty mode (prompted by
      changes in the toolchain in Debian) (Closes: #777778)
    - Fix reported installed size change when installing/deinstalling
      packages which are bigger than 2 GiB (int type size 32 bits). Thanks
      Benny Baumann and Jason Rhinelander for the report and info, and Sven
      Joachim for the patch. (Closes: #759769)
    - Changes in automake files to be able to use current automake
      versions.
    - Documentation:
      - Previously missing trigger-related package states are now
        documented. (Closes: #770073, #771305, #771704)
      - Minesweeper: Fixed save/load keybindings in help.
        (Closes: #736934)
    - Translation updates:
      - Czech by Miroslav Kure (Closes: #758226)
      - Russian by Yuri Kozlov (Closes: #760812)
      - German man page translation by Mario Blättermann and
        Jens Seidel (Closes: #762340)
      - Catalan by Orestes Mas (Closes: #771618)
      - French documentation translation by Cédric Boutillier
        (Closes: #773807)
      - Italian documentation translation by Beatrice Torracca
        (Closes: #776706)
      - Dutch by Frans Spiesschaert (Closes: #778425)

  [ Axel Beckert ]
  * Apply wrap-and-sort.
  * No more install files related to the categorical browser.
  * Update Vcs-Browser header to use cgit and HTTPS.
  * Declare compliance with Debian Policy 3.9.6. (No changes needed.)
  * debian/rules:
    + Remove override_dh_builddeb: xz compression is default nowadays.
    + Remove obsolete x from [ "x$var" != "x" ] comparisons.
  * Add myself to Uploaders.
  * Cherry-pick 3593bdcb, 2a5a8b25, and 4b24b358 from upstream to cope
    with Boost 1.58 which has been uploaded to unstable during the
    libstdc++6 transition, but after the 0.7 upstream release.
  * Temporarily bump g++ dependency from 4:3.2.2-0 to 4:5.2 for the
    gcc-5/libstdc++6 transition.
  * Add build-dependency on automake.

 -- Matthias Klose <email address hidden> Wed, 05 Aug 2015 21:29:36 +0200

Changed in aptitude (Ubuntu):
status: Confirmed → Fix Released
Paul White (paulw2u) on 2016-03-25
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.