Locale warnings in apticron mails

Bug #807228 reported by Tuomas Jormola on 2011-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apticron (Ubuntu)
Undecided
Unassigned

Bug Description

23:45:02)(tj@andika)(~)$ lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04
(23:45:04)(tj@andika)(~)$ apt-cache policy apticron
apticron:
  Installed: 1.1.45
  Candidate: 1.1.45
  Version table:
 *** 1.1.45 0
        500 http://fi.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages
        100 /var/lib/dpkg/status

I get mails from apticron that goes like this, very annoying:

apticron report [Thu, 07 Jul 2011 00:46:51 +0300]
========================================================================

apticron has detected that some packages need upgrading on:

        andika.home.local.domain
        [ 10.10.0.5 ]

The following packages are currently pending an upgrade:

sh: warning: setlocale: LC_ALL: cannot change locale (en)
sh: warning: setlocale: LC_ALL: cannot change locale (en)
sh: warning: setlocale: LC_ALL: cannot change locale (en)
        apt 0.8.13.2ubuntu4
...

This is fixed in Debian http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624288
Fix involves changing only one character in the script. Please apply for natty, thanks.

I have de same problem. :(

Same here on Ubuntu 12.04 with apticron 1.1.45
Still no fix ?

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers