apticron generates corrupt messages

Bug #290386 reported by J. Pablo Fernández on 2008-10-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apticron (Ubuntu)
Undecided
Unassigned

Bug Description

apticron generates corrupt messages according to Courier MTA which is very strict in checking the messages against the standards. Here's how I've got the message (with names and ip changes) so you can have a better idea of what's going on:

Delivered-To: <email address hidden>
Return-Path: <email address hidden>
Received: from host01 ([::ffff:10.0.0.1]) (TLS:
        TLSv1/SSLv3,256bits,AES256-SHA) by host02.example.com with esmtp; Tue, 28
        Oct 2008 11:42:27 +0000 id 0007C026.4906FAA3.000041B9
Received: from localhost (localhost [127.0.0.1]) (uid 0) by host01 with
        local; Tue, 28 Oct 2008 07:42:26 -0400 id 00011EE2.4906FAA2.000063DC
To: <email address hidden>
Subject: Debian package updates on host01
From: root <email address hidden>
Message-ID: <courier.4906FAA2.000063DC@host01>
Date: Tue, 28 Oct 2008 07:42:26 -0400
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="=_boundary-0001-25564"
X-Evolution-Source: pop://pupeno%40pupeno.com;<email address hidden>/

This is a MIME-formatted message. If you see this text it means that your
E-mail software does not support MIME-formatted messages.

--=_boundary-0001-25564
Content-Type: text/plain; format=flowed; charset=iso-8859-1
Content-Transfer-Encoding: quoted-printable
Comment: The following content can be customized provided that:
Comment: 1) These MIME headers are preserved (you may change the charset
Comment: or drop format=flowed).
Comment: 2) This content is manually quoted-printable encoded, it MUST NOT
Comment: contain 8-bit text.
Comment: 'host01' below is replaced by server name.

                              CORRUPTED MESSAGE

This is the Courier Mail Server 0.58 on host01.

I received the following message for delivery to your address. This message
contains several internal formatting errors. This is often caused by
viruses that attempt to infect remote systems. Instead of blocking
this message, I converted it to a safe, text-only attachment that can be
safely read with a text editor.

This sometimes also happens when the sender's mail software has a bug
that creates improperly-formatted messages. Although these kinds of
formatting errors may often be ignored by other mail servers, this
server detects and intercepts improperly-coded messages in order to
prevent viruses from taking advantage of bugs in E-mail programs:

-----------------------------------------------------------------------------
This message contains improperly-formatted binary content, or attachment.

See <URL:ftp://ftp.isi.edu/in-notes/rfc2045.txt> for more information.
-----------------------------------------------------------------------------

--=_boundary-0001-25564
Content-Type: text/plain; charset=iso-8859-1
X-Original-Content-Type: message/rfc822
Content-Disposition: attachment; filename="message.txt"
Content-Transfer-Encoding: 8bit

Received: from localhost (localhost [127.0.0.1])
  (uid 0)
  by host01 with local; Tue, 28 Oct 2008 07:42:26 -0400
  id 00011EE2.4906FAA2.000063DC
To: <email address hidden>
Subject: Debian package updates on host01
From: root <email address hidden>
Message-ID: <courier.4906FAA2.000063DC@host01>
Date: Tue, 28 Oct 2008 07:42:26 -0400

apticron report [Tue, 28 Oct 2008 07:42:25 -0400]
========================================================================

apticron has detected that some packages need upgrading on:

        host01.example.com
        [ 127.0.0.1 10.0.0.1 ]

The following packages are currently pending an upgrade:

        tzdata 2008h-0ubuntu0.8.04.1
        xkb-data 1.1~cvs.20080104.1-1ubuntu8

========================================================================

Package Details:

Reading changelogs...
--- Changes for tzdata ---
tzdata (2008h-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * Add argentina-no-dst.diff: Some Argentinian provinces do not have daylight
    saving this year. Thanks to Mariano Absatz for the patch! (Slightly
    simplified by upstream, will go into 2008i soon). (LP: #278419)

 -- Martin Pitt <email address hidden> Tue, 21 Oct 2008 12:01:00 +0200

--- Changes for xkeyboard-config (xkb-data) ---
xkeyboard-config (1.1~cvs.20080104.1-1ubuntu8) hardy-proposed; urgency=low

  * Added af_syntax_errors.diff patch to fix syntax errors in Afghan
    layout file. (Closes LP: #260647)

 -- Adam Spain <email address hidden> Fri, 17 Oct 2008 14:02:06 +0100

xkeyboard-config (1.1~cvs.20080104.1-1ubuntu7) hardy-proposed; urgency=low

  [ Daniel Gimpelevich ]
  * debian/patches/us-mac.diff:
     + Fix for the USA - Macintosh layout. (Closes: #246834)

 -- Артём Попов <email address hidden> Wed, 09 Jul 2008 17:05:45 +0700

========================================================================

You can perform the upgrade by issuing the command:

        aptitude dist-upgrade

as root on host01.example.com

It is recommended that you simulate the upgrade first to confirm that
the actions that would be taken are reasonable. The upgrade may be
simulated by issuing the command:

        aptitude -s -y dist-upgrade

--
apticron

--=_boundary-0001-25564--

Ian Weisser (ian-weisser) wrote :

Thanks for your bug report.
I've added this bug to the 'anacron' package.

Ian Weisser (ian-weisser) wrote :

Correction: Apticron package, of course.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers