apticron calls apt-listchanges with incorrect arguments

Bug #1671922 reported by Ben Coleman on 2017-03-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apticron (Debian)
Fix Released
Unknown
apticron (Ubuntu)
Undecided
Unassigned

Bug Description

After updating to 16.10, apticron report emails no longer show Package Details, instead showing the usage message from apt-listchanges. E.g.:

apticron report [Thu, 09 Mar 2017 19:09:15 -0500]
========================================================================

apticron has detected that some packages need upgrading on:

 dos3.benshome.net
 [ 104.131.218.115 10.128.254.248 2001:470:1f07:3f3::1 ]
 [ 2001:470:1f06:3f3::2 104.131.218.115 2001:470:1f07:3f3::1 ]

The following packages are currently pending an upgrade:

 libarchive13 3.2.1-2ubuntu0.1

========================================================================

Package Details:

Usage: apt-listchanges [options] {--apt | filename.deb ...}

Looks like perhaps apt-listchanges has had a change in argument format, and apticron hasn't been changed to accomodate it?

Ben Coleman (oloryn) wrote :

This problem still exists in 17.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apticron (Ubuntu):
status: New → Confirmed
Ben Coleman (oloryn) wrote :

OK, I dug into this a bit. I added the line

print("apt-listchanges arguments: ", str(sys.argv))

as the first line of main in apt-listchanges. Next time apticron was called, it produced this:

---
apticron report [Tue, 27 Jun 2017 23:14:42 -0400]
========================================================================

apticron has detected that some packages need upgrading on:

 morannon.ln.benshome.net
 [ 172.17.113.244 ]

The following packages are currently pending an upgrade:

 bsdutils 1:2.29-1ubuntu2.1
 grub-legacy-ec2 0.7.9-153-g16a7302f-0ubuntu1~17.04.1
 libblkid1 2.29-1ubuntu2.1
 libfdisk1 2.29-1ubuntu2.1
 libmount1 2.29-1ubuntu2.1
 libnss-resolve 232-21ubuntu5
 libpam-systemd 232-21ubuntu5
 libsmartcols1 2.29-1ubuntu2.1
 libsystemd0 232-21ubuntu5
 libudev1 232-21ubuntu5
 libuuid1 2.29-1ubuntu2.1
 mount 2.29-1ubuntu2.1
 nplan 0.23~17.04.1
 systemd 232-21ubuntu5
 systemd-sysv 232-21ubuntu5
 udev 232-21ubuntu5
 util-linux 2.29-1ubuntu2.1
 uuid-runtime 2.29-1ubuntu2.1

========================================================================

Package Details:

Usage: apt-listchanges [options] {--apt | filename.deb ...}
apt-listchanges arguments: ['/usr/bin/apt-listchanges', '--which=both', '--headers', '-f', 'text']
---

The problem appears to be that there are no .deb files provided (as all of the other arguments look valid). The execution of apt-listchanges is in line 225 of /usr/sbin/aptcron (on 17.10):

/usr/bin/apt-listchanges --which=both --headers -f text $DEBS

It would appear that $DEBS at this point is empty, rather than containing pathnames for the .debs to be listed. This would seem to point to a problem in lines 194 - 213, where DEBS is set.

Ben Coleman (oloryn) wrote :
Ben Coleman (oloryn) wrote :

Tied that last link to the Debian bug, linked above. That includes a patch, or since apticron seems to have fixed this in 1.1.59, 1.1.61 (which is in artful) could be backported.

Changed in apticron (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.