update-manager crashed with Depends in _run_in_dialog(): libx264-120 but it is not installed

Bug #975320 reported by Eelbuntu on 2012-04-06
190
This bug affects 29 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

I think it has something to do with trying to install flash plugins from firefox

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.10
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Fri Apr 6 19:03:21 2012
ExecutablePath: /usr/bin/update-manager
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/update-manager
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with Depends in _run_in_dialog(): libx264-120 but it is not installed
UpgradeStatus: Upgraded to precise on 2012-04-06 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Eelbuntu (eelcoaartsen) wrote :
tags: removed: need-duplicate-check
Brian Murray (brian-murray) wrote :

It looks like the crash is aptdaemon.

visibility: private → public
affects: update-manager (Ubuntu) → aptdaemon (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

I have no strong opinion if aptdaemon should raise a exception or just set the transaction error state, I slightly prefer the later though.

Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
tags: added: bugpattern-written
Tomislav (tzcrnko) wrote :

I installing upgrade for frostwire data

Torgny (torgny-bjers) wrote :

I encountered this when I had force-installed a package with unmet dependencies (system76-driver) on a clean 12.04 LTS that does not have the old gnome2 packages that would remain after a distribution upgrade. The system refused to install the driver's requirements because they would conflict and that's when the crash occurred.

Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
Jaydip Guha (guha-jaydip) wrote :

In 12.10 todays update has removed i386 packages. While trying to reinstall crossover which depends on some i386 stuff. The package list got broken and system fails to update any further, need help.

Brian Murray (brian-murray) wrote :
Changed in aptdaemon (Ubuntu):
status: Fix Released → Triaged
Changed in aptdaemon (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-12.04.2
Matthew Paul Thomas (mpt) wrote :

Today this bug is the most frequent recorded error for Ubuntu users overall (via its private duplicate bug 979278). Philip Alring Rützou Aakast is not subscribed to this bug report and has never reported or fixed any bugs, so I believe he marked this as fixed by mistake.

Changed in aptdaemon (Ubuntu):
status: Triaged → Confirmed
Michael Vogt (mvo) wrote :

This seems to be the catch-all bucket for errors of the type:
"""
TransactionFailed: Transaction failed: None
 The following packages have unmet dependencies:
"""

The most recent errors from errors.ubuntu.com looks like this:
"""
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 473, in _inline_callbacks
    result = gen.throw(result.type, result.value, result.traceback)
  File "/usr/lib/python2.7/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 54, in commit
    yield self._run_in_dialog(trans, self.INSTALL)
  File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 473, in _inline_callbacks
    result = gen.throw(result.type, result.value, result.traceback)
  File "/usr/lib/python2.7/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 75, in _run_in_dialog
    yield dia.run()
TransactionFailed: Transaction failed: None
 The following packages have unmet dependencies:

language-pack-kde-en: Depends: language-pack-kde-en-base (>= 1:12.04+20120801) but 1:12.04+20120508 is installed
libknewstuff2-4: Depends: libkdecore5 (= 4:4.8.5-0ubuntu0.1) but 4:4.8.3-0ubuntu0.1 is installed
...
""""

A quick sample of a dozen or so show me: "language-pack-kde-en:". Also interessting is that its happening mostly on 12.04:
"""
1:0.156.14.11 (12.04)
1851 instances
"""

Now that is puzzling as https://launchpad.net/ubuntu/+source/language-pack-kde-en-base shows that version 1:12.04+20120801 is there and that hasn't changed in a long time.

Michael Vogt (mvo) wrote :

A common theme I see in a lot of the recent reports is: " /home/oem ", LANGUAGE=en_IN:en and the version reference to 4:4.8.3-0ubuntu0.1 is a version in precise-updates that is no longer in the archive. But there are also counter examples, so this might be a red herring.

The full error log:
"""
language-pack-kde-en: Depends: language-pack-kde-en-base (>= 1:12.04+20120801) but 1:12.04+20120508 is installed
libknewstuff2-4: Depends: libkdecore5 (= 4:4.8.5-0ubuntu0.1) but 4:4.8.3-0ubuntu0.1 is installed
                 Depends: libkdeui5 (= 4:4.8.5-0ubuntu0.1) but 4:4.8.3-0ubuntu0.1 is installed
                 Depends: libkio5 (= 4:4.8.5-0ubuntu0.1) but 4:4.8.3-0ubuntu0.1 is installed
libkprintutils4: Depends: libkdecore5 (= 4:4.8.5-0ubuntu0.1) but 4:4.8.3-0ubuntu0.1 is installed
                 Depends: libkdeui5 (= 4:4.8.5-0ubuntu0.1) but 4:4.8.3-0ubuntu0.1 is installed
                 Depends: libkparts4 (= 4:4.8.5-0ubuntu0.1) but 4:4.8.3-0ubuntu0.1 is installed
libqt4-help: Depends: libqt4-network (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
             Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
             Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
             Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
libqt4-scripttools: Depends: libqt4-script (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
                    Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
                    Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
libqt4-sql-mysql: Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
                  Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
libqt4-test: Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.1 is installed
"""

But that also has not changed in a while, according to https://launchpad.net/ubuntu/+source/qt4-x11 it got updated in 2012-11-08

Colin Watson (cjwatson) on 2013-02-13
Changed in aptdaemon (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers