<type 'exceptions.SystemError'>: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Bug #932581 reported by Joao M. Horta on 2012-02-15
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

TEST CASE:
- no simple way as this requires a system with broken dependencies on upgrade, so regression test is enough

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: aptdaemon 0.43+bzr769-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
Annotation: Search failed
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Wed Feb 15 08:08:19 2012
DesktopFile: /usr/share/aptdaemon/aptdaemon.desktop
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120112)
PackageArchitecture: all
SourcePackage: aptdaemon
Title: <type 'exceptions.SystemError'>: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
TransactionDepends: [[], [], [], [], [], [], []]
TransactionErrorCode: error-unknown
TransactionKwargs: {'filters': [u'unknown']}
TransactionLocale: pt_PT.UTF-8
TransactionOutput:

TransactionPackages: [[], [], [], [], [], []]
TransactionRole: role-pk-query
UpgradeStatus: Upgraded to precise on 2012-02-14 (0 days ago)

Related branches

Joao M. Horta (jhorta) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.43+bzr790-0ubuntu1

---------------
aptdaemon (0.43+bzr790-0ubuntu1) precise; urgency=low

  New upstream snapshot:
  * merged patch for LP: #959131 (CVE 2012-0944)
  * pkcompat: Don't crash if the system time went backwards during a
    transaction (Fixes LP: #940367)
  * worker: catch SystemErrors from python-apt when performing a system
    upgrade (fixes LP: #932581)
  * pkcompat: Don't crash if an unsupported locale is used for the
    transaction, fixes LP: #944553
  * Fix download progress information for translations of languages with
    an ISO 639 2T code (3 letters), e.g. Asturian (ast) - fixes LP: #966111
  * test: Add a test to ensure that every transaction is simulated
    before it gets queued.
 -- Michael Vogt <email address hidden> Mon, 02 Apr 2012 19:04:16 +0200

Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
visibility: private → public
Changed in aptdaemon (Ubuntu):
status: Fix Released → Fix Committed
Sebastian Heinlein (glatzor) wrote :

Sorry. The error can appear in two places and I only fixed one of them. The change is in trunk now.

Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
Michael Vogt (mvo) on 2012-06-14
description: updated
Changed in aptdaemon (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.45+bzr846-0ubuntu1

---------------
aptdaemon (0.45+bzr846-0ubuntu1) quantal; urgency=low

  * New upstream snapshot:
    - Python3 porting from lp:~aptdaemon-developers/aptdaemon/py3k
    - Fix package status enum description for an unknown status
      which resulted in a type mismatch in the gettext call
      (fixes LP: #900982)
    - Still report available blocked updates if the dependency system
      is broken (final partial fix to LP: #932581)
    - client: Use INT64 in signals where required (Fixes LP: #981124)
    - use lintian profiles instead of tags
  * debian/aptdaemon.install:
    - use the new lintian profiles instead of the tags
  * debian/patches/series:
    - drop patches, applied upstream
 -- Michael Vogt <email address hidden> Thu, 14 Jun 2012 12:27:44 +0200

Changed in aptdaemon (Ubuntu Quantal):
status: Fix Committed → Fix Released

Hello Joao, or anyone else affected,

Accepted aptdaemon into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in aptdaemon (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Michael Vogt (mvo) wrote :

I set this to "verification-done" on the grounds that I couldn't find any regressions even though I run this since its in -proposed plus I did a manual test in a VM and couldn't find any regressions there either.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.43+bzr805-0ubuntu2

---------------
aptdaemon (0.43+bzr805-0ubuntu2) precise-proposed; urgency=low

  * debian/patches:
    - Add fix-lp-971748: Fixes to the /proc/net based network monitor to
      not fail on systems without NetworkManager running (fixes LP: #971748))
    - Add fix-lp-932581: Fix GetUpdates on system with broken dependencies
      (fixes LP: #932581)
    - Add fix-lp-981124: Fix type mismatches in the client signals to not
      fail on very large packages (fixes LP: #981124)
    - Add fix-lp-900982: Fix return type of get_package_status_from_enum
      (fixes LP: #900982)
 -- Sebastian Heinlein <email address hidden> Tue, 12 Jun 2012 09:38:14 +0200

Changed in aptdaemon (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers