<type 'exceptions.NameError'>: global name 'trans' is not defined with aptd 0.41+bzr646-0ubuntu1

Bug #764422 reported by solidblue
958
This bug affects 110 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Medium
Robert Roth
Natty
Medium
Robert Roth

Bug Description

Binary package hint: aptdaemon

this error occured during installing a program after last upgradeing the system Natty Unity

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: aptdaemon 0.41+bzr646-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Annotation: Applying software changes failed
Architecture: i386
Date: Mon Apr 18 12:52:39 2011
DesktopFile: /usr/share/aptdaemon/aptdaemon.desktop
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
PackageArchitecture: all
SourcePackage: aptdaemon
Title: <type 'exceptions.NameError'>: global name 'trans' is not defined
TransactionDepends: [[], [], [], [], [], [], []]
TransactionErrorCode: error-unknown
TransactionKwargs: {}
TransactionLocale: en_US.UTF8
TransactionOutput:

TransactionPackages: [[dbus.String(u'rawstudio')], [], [], [], [], []]
TransactionRole: role-commit-packages
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
solidblue (ergunzer) wrote :
Robert Roth (evfool)
Changed in aptdaemon (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → Triaged
Michael Vogt (mvo)
Changed in aptdaemon (Ubuntu):
status: Triaged → In Progress
Robert Roth (evfool)
Changed in aptdaemon (Ubuntu Natty):
assignee: nobody → Robert Roth (evfool)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr646-0ubuntu2

---------------
aptdaemon (0.41+bzr646-0ubuntu2) natty; urgency=low

  * debian/patches/01_fix_locking.patch:
    - cherry pick from evfool, many thanks (LP: #764422)
  * debian/patches/02_fix_crash_on_dpkg_disappear.patch:
    - add (empty) mapping the apt progress message that is triggered
      when a empty package disappears
 -- Michael Vogt <email address hidden> Mon, 18 Apr 2011 13:48:38 +0200

Changed in aptdaemon (Ubuntu Natty):
status: In Progress → Fix Released
Revision history for this message
Presianbg (presianbg) wrote :

will it fix the problem in amd64 systems too ?

Revision history for this message
Presianbg (presianbg) wrote :

how to fix it :?

Revision history for this message
Robert Roth (evfool) wrote :

Please run update-manager to update the aptdaemon package to the latest version, which already contains the fix. You can also do this by using the command line, by executing the command "sudo apt-get update && sudo apt-get upgrade".

Revision history for this message
cfacquez (cfacquez) wrote :

It work's for me thanks!

Revision history for this message
ubuntique (sathya-vpramod) wrote : Re: [Bug 764422] Re: <type 'exceptions.NameError'>: global name 'trans' is not defined

Great! Thank you.

Sathya

http://mindmirror007.blogspot.com/p/home.html
On Apr 18, 2011 10:01 AM, "Robert Roth" <email address hidden> wrote:
> Please run update-manager to update the aptdaemon package to the latest
> version, which already contains the fix. You can also do this by using
> the command line, by executing the command "sudo apt-get update && sudo
> apt-get upgrade".
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (764644).
> https://bugs.launchpad.net/bugs/764422
>
> Title:
> <type 'exceptions.NameError'>: global name 'trans' is not defined
>
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
> Status in “aptdaemon” source package in Natty:
> Fix Released
>
> Bug description:
> Binary package hint: aptdaemon
>
> this error occured during installing a program after last upgradeing
> the system Natty Unity
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr646-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> Annotation: Applying software changes failed
> Architecture: i386
> Date: Mon Apr 18 12:52:39 2011
> DesktopFile: /usr/share/aptdaemon/aptdaemon.desktop
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
> PackageArchitecture: all
> SourcePackage: aptdaemon
> Title: <type 'exceptions.NameError'>: global name 'trans' is not defined
> TransactionDepends: [[], [], [], [], [], [], []]
> TransactionErrorCode: error-unknown
> TransactionKwargs: {}
> TransactionLocale: en_US.UTF8
> TransactionOutput:
>
> TransactionPackages: [[dbus.String(u'rawstudio')], [], [], [], [], []]
> TransactionRole: role-commit-packages
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/764422/+subscribe

Revision history for this message
David Z. Chen (d-zhekai-chen) wrote :

I used update-manager, but when it was installing the update, the same error occurred. I do not know if the update succeeded, but update-manager now says that everything is up to date. Running apt-get update and apt-get upgrade on the command line does not produce any new packages to install. I am not too familiar with how dpkg works, but is there a way to do a "deep" check of package versions and make sure everything is consistent?

Revision history for this message
Hadrien Titeux (hadware) wrote :
Download full text (3.8 KiB)

I ran the update-manager, it says everything is up to date, but the problem
persists.... how can i help you finding the source of the probem?

On Mon, Apr 18, 2011 at 4:06 PM, ubuntique <email address hidden>wrote:

> Great! Thank you.
>
> Sathya
>
> http://mindmirror007.blogspot.com/p/home.html
> On Apr 18, 2011 10:01 AM, "Robert Roth" <email address hidden> wrote:
> > Please run update-manager to update the aptdaemon package to the latest
> > version, which already contains the fix. You can also do this by using
> > the command line, by executing the command "sudo apt-get update && sudo
> > apt-get upgrade".
> >
> > --
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug (764644).
> > https://bugs.launchpad.net/bugs/764422
> >
> > Title:
> > <type 'exceptions.NameError'>: global name 'trans' is not defined
> >
> > Status in “aptdaemon” package in Ubuntu:
> > Fix Released
> > Status in “aptdaemon” source package in Natty:
> > Fix Released
> >
> > Bug description:
> > Binary package hint: aptdaemon
> >
> > this error occured during installing a program after last upgradeing
> > the system Natty Unity
> >
> > ProblemType: Crash
> > DistroRelease: Ubuntu 11.04
> > Package: aptdaemon 0.41+bzr646-0ubuntu1
> > ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> > Uname: Linux 2.6.38-8-generic i686
> > Annotation: Applying software changes failed
> > Architecture: i386
> > Date: Mon Apr 18 12:52:39 2011
> > DesktopFile: /usr/share/aptdaemon/aptdaemon.desktop
> > ExecutablePath: /usr/sbin/aptd
> > InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
> > PackageArchitecture: all
> > SourcePackage: aptdaemon
> > Title: <type 'exceptions.NameError'>: global name 'trans' is not defined
> > TransactionDepends: [[], [], [], [], [], [], []]
> > TransactionErrorCode: error-unknown
> > TransactionKwargs: {}
> > TransactionLocale: en_US.UTF8
> > TransactionOutput:
> >
> > TransactionPackages: [[dbus.String(u'rawstudio')], [], [], [], [], []]
> > TransactionRole: role-commit-packages
> > UpgradeStatus: No upgrade log present (probably fresh install)
> >
> > To unsubscribe from this bug, go to:
> >
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/764422/+subscribe
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (764603).
> https://bugs.launchpad.net/bugs/764422
>
> Title:
> <type 'exceptions.NameError'>: global name 'trans' is not defined
>
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
> Status in “aptdaemon” source package in Natty:
> Fix Released
>
> Bug description:
> Binary package hint: aptdaemon
>
> this error occured during installing a program after last upgradeing
> the system Natty Unity
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr646-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> Annotation: Applying software changes failed
> Architecture: i386
> Date: Mon Apr 18 12:52:39 2011
> DesktopFile: /usr/share/aptdaemon/aptdaemon.desktop
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 11...

Read more...

Revision history for this message
Hans Joachim Desserud (hjd) wrote : Re: <type 'exceptions.NameError'>: global name 'trans' is not defined

A lot of people have a similar issue with 0.41+bzr646-0ubuntu2. I'm not sure if it's the exact same, but the stack trace is pretty similar. See bug 764883 for details.

Revision history for this message
Robert Roth (evfool) wrote :

It's very strange, as the error message is still about trans not being defined, but the problematic line 0.41+bzr646-0ubuntu2 is written as "self.transaction.term_attached = False" which should not have anything to do with trans. Seems to run the older version, but getting the source from the newer version.

Revision history for this message
michael da cova (michael-dacova) wrote : Re: [Bug 764422] Re: <type 'exceptions.NameError'>: global name 'trans' is not defined

On 18/04/11 21:59, Robert Roth wrote:
> It's very strange, as the error message is still about trans not being
> defined, but the problematic line 0.41+bzr646-0ubuntu2 is written as
> "self.transaction.term_attached = False" which should not have anything
> to do with trans. Seems to run the older version, but getting the source
> from the newer version.
>
tried using update manager no crashes this time

Robert Roth (evfool)
summary: - <type 'exceptions.NameError'>: global name 'trans' is not defined
+ <type 'exceptions.NameError'>: global name 'trans' is not defined with
+ aptd 0.41+bzr646-0ubuntu1
Revision history for this message
William Joyce (temp2010-joyce-family) wrote :

Updated this morning but still getting the same error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers