Ubuntu

Unkown exception with broken encoding

Reported by Digger on 2011-04-15
518
This bug affects 68 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Unassigned
Natty
Undecided
Unassigned
Oneiric
High
Unassigned
python-defer (Ubuntu)
High
Unassigned
Natty
Undecided
Unassigned
Oneiric
High
Unassigned

Bug Description

Binary package hint: aptdaemon

-.-

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: aptdaemon 0.41+bzr641-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Apr 15 01:48:49 2011
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/aptd
ProcEnviron:

PythonArgs: ['/usr/sbin/aptd']
SourcePackage: aptdaemon
Title: aptd crashed with UnicodeEncodeError in get_dbus_message(): 'ascii' codec can't encode character u'\xe1' in position 154: ordinal not in range(128)
UpgradeStatus: Upgraded to natty on 2011-04-15 (0 days ago)
UserGroups:

Digger (digger-jhs) wrote :
tags: removed: need-duplicate-check
Michael Vogt (mvo) on 2011-04-15
visibility: private → public
tags: added: bugpattern-needed
Sebastian Heinlein (glatzor) wrote :

Could you please append the file /var/log/syslog ?

Changed in aptdaemon (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
importance: Medium → High
summary: - aptd crashed with UnicodeEncodeError in get_dbus_message(): 'ascii'
- codec can't encode character u'\xe1' in position 154: ordinal not in
- range(128)
+ Unkown Exception with broken encoding
summary: - Unkown Exception with broken encoding
+ Unkown exception with broken encoding
  • syslog Edit (137.6 KiB, application/octet-stream; name=syslog)

2011/4/18 Sebastian Heinlein <email address hidden>:
> Could you please append the file /var/log/syslog ?
>
> ** Changed in: aptdaemon (Ubuntu)
>       Status: New => Incomplete
>
> ** Changed in: aptdaemon (Ubuntu)
>   Importance: Undecided => Medium
>
> ** Changed in: aptdaemon (Ubuntu)
>   Importance: Medium => High
>
> ** Summary changed:
>
> - aptd crashed with UnicodeEncodeError in get_dbus_message(): 'ascii' codec can't encode character u'\xe1' in position 154: ordinal not in range(128)
> + Unkown Exception with broken encoding
>
> ** Summary changed:
>
> - Unkown Exception with broken encoding
> + Unkown exception with broken encoding
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (762041).
> https://bugs.launchpad.net/bugs/761386
>
> Title:
>  Unkown exception with broken encoding
>
> Status in “aptdaemon” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  Binary package hint: aptdaemon
>
>  -.-
>
>  ProblemType: Crash
>  DistroRelease: Ubuntu 11.04
>  Package: aptdaemon 0.41+bzr641-0ubuntu1
>  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic x86_64
>  NonfreeKernelModules: nvidia
>  Architecture: amd64
>  Date: Fri Apr 15 01:48:49 2011
>  ExecutablePath: /usr/sbin/aptd
>  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
>  InterpreterPath: /usr/bin/python2.7
>  PackageArchitecture: all
>  ProcCmdline: /usr/bin/python /usr/sbin/aptd
>  ProcEnviron:
>
>  PythonArgs: ['/usr/sbin/aptd']
>  SourcePackage: aptdaemon
>  Title: aptd crashed with UnicodeEncodeError in get_dbus_message(): 'ascii' codec can't encode character u'\xe1' in position 154: ordinal not in range(128)
>  UpgradeStatus: Upgraded to natty on 2011-04-15 (0 days ago)
>  UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/761386/+subscribe
>
>

Akism (agmichali) wrote :
  • syslog Edit (601.6 KiB, application/octet-stream; name=syslog)
Download full text (3.5 KiB)

here is the file syslog

________________________________
From: Balazs Pere <email address hidden>
To: <email address hidden>
Sent: Monday, April 18, 2011 11:47 AM
Subject: Re: [Bug 761386] Re: aptd crashed with UnicodeEncodeError in get_dbus_message(): 'ascii' codec can't encode character u'\xe1' in position 154: ordinal not in range(128)

2011/4/18 Sebastian Heinlein <email address hidden>:
> Could you please append the file /var/log/syslog ?
>
> ** Changed in: aptdaemon (Ubuntu)
>       Status: New => Incomplete
>
> ** Changed in: aptdaemon (Ubuntu)
>   Importance: Undecided => Medium
>
> ** Changed in: aptdaemon (Ubuntu)
>   Importance: Medium => High
>
> ** Summary changed:
>
> - aptd crashed with UnicodeEncodeError in get_dbus_message(): 'ascii' codec can't encode character u'\xe1' in position 154: ordinal not in range(128)
> + Unkown Exception with broken encoding
>
> ** Summary changed:
>
> - Unkown Exception with broken encoding
> + Unkown exception with broken encoding
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (762041).
> https://bugs.launchpad.net/bugs/761386
>
> Title:
>  Unkown exception with broken encoding
>
> Status in “aptdaemon” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  Binary package hint: aptdaemon
>
>  -.-
>
>  ProblemType: Crash
>  DistroRelease: Ubuntu 11.04
>  Package: aptdaemon 0.41+bzr641-0ubuntu1
>  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic x86_64
>  NonfreeKernelModules: nvidia
>  Architecture: amd64
>  Date: Fri Apr 15 01:48:49 2011
>  ExecutablePath: /usr/sbin/aptd
>  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
>  InterpreterPath: /usr/bin/python2.7
>  PackageArchitecture: all
>  ProcCmdline: /usr/bin/python /usr/sbin/aptd
>  ProcEnviron:
>
>  PythonArgs: ['/usr/sbin/aptd']
>  SourcePackage: aptdaemon
>  Title: aptd crashed with UnicodeEncodeError in get_dbus_message(): 'ascii' codec can't encode character u'\xe1' in position 154: ordinal not in range(128)
>  UpgradeStatus: Upgraded to natty on 2011-04-15 (0 days ago)
>  UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/761386/+subscribe
>
>

** Attachment added: "syslog"
  https://bugs.launchpad.net/bugs/761386/+attachment/2058762/+files/syslog

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (762979).
https://bugs.launchpad.net/bugs/761386

Title:
  Unkown exception with broken encoding

Status in “aptdaemon” package in Ubuntu:
  Incomplete

Bug description:
  Binary package hint: aptdaemon

  -.-

  ProblemType: Crash
  DistroRelease: Ubuntu 11.04
  Package: aptdaemon 0.41+bzr641-0ubuntu1
  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
  Uname: Linux 2.6.38-8-generic x86_64
  NonfreeKernelModules: nvidia
  Architecture: amd64
  Date: Fri Apr 15 01:48:49 2011
  ExecutablePath: /usr/sbin/aptd
  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
  InterpreterPath: /usr/bin/python2.7
  PackageArchitecture: all
  ProcCmdline: /usr/bin/python /usr/sbin/aptd
  ProcEnviron:

  Py...

Read more...

Changed in aptdaemon (Ubuntu):
status: Incomplete → Fix Committed
Changed in python-defer (Ubuntu):
status: New → In Progress
importance: Undecided → High

Accepted aptdaemon into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in aptdaemon (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Michael, could you provide a test case for this SRU bug? It's been pending verification for nearly a month; I could switch to a non-ascii locale for testing, but I don't know how to trigger the dbus exceptions that are required in order to trigger the problem.

Hey,

Thanks for the e-mail. That problem is old, I am still using ubuntu
11.04 beta 2. Today I am reinstalling. I think it will be solved.

Greeting,
Ernst

Steve Langasek schreef op vr 27-05-2011 om 21:47 [+0000]:
> Michael, could you provide a test case for this SRU bug? It's been
> pending verification for nearly a month; I could switch to a non-ascii
> locale for testing, but I don't know how to trigger the dbus exceptions
> that are required in order to trigger the problem.
>

Martin Pitt (pitti) wrote :

Please see https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/781874/comments/11 for the current status of this, this needs a new upload to natty-proposed. Also, this needs to be fixed in oneiric first.

Changed in aptdaemon (Ubuntu Natty):
status: Fix Committed → Triaged
tags: removed: verification-needed
Wobbo (wobbo) wrote :

Hey,

Ubuntu 11.04 has about bik 10+ problems, whit Ubuntu 10.04 and 10.10
didn't had any problems. So I don't know whits one of the 1000 problems
this e-mail is about.

Please except my apology about this message, all do I am using Ubuntu
sins Ubuntu 5.04, but I am thinking to start using another. Especially
that you are not using the new Gnome and calling the normal Ubuntu
“classic”. That one was for netbooks, right?

Greeting,
Ernst Lanser

Launchpad Bug Tracker schreef op di 03-05-2011 om 06:22 [+0000]:
> ** Branch linked: lp:ubuntu/natty-proposed/aptdaemon
>

Changed in python-defer (Ubuntu Natty):
status: New → Confirmed
Changed in python-defer (Ubuntu Oneiric):
status: In Progress → Invalid
Changed in python-defer (Ubuntu Natty):
status: Confirmed → Invalid
tags: removed: bugpattern-needed
tags: added: bugpattern-written
tags: added: rls-mgr-o-tracking

Hello Digger, or anyone else affected,

Accepted aptdaemon into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in aptdaemon (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

The change from the natty SRU is included in oneiric; so either it's fixed, or it's not and the natty SRU should be marked 'verification-failed' as well.

Changed in aptdaemon (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr661-0ubuntu0.1

---------------
aptdaemon (0.41+bzr661-0ubuntu0.1) natty-proposed; urgency=low

  [ Michael Vogt ]
  * new bzr bugfix snapshot from the upstream branch
  * drop debian/patches/fix_lp_781874.patch,
    drop debian/patches/01_fix_locking.patch
    drop debian/patches/03_do_not_close_invalid_fd.patch
    drop/debian/patches/04_check_if_apport_enabled.patch:
    - this is included in the upstream bzr branch now
  * debian/patches/02_fix_crash_on_dpkg_disappear.patch:
    - use empty string when dpkg notices a disappearing package,
      this avoids string break

  [ Sebastian Heinlein ]
  * fix bug when canceling a transaction (LP: #781874)
  * fix FD leak (LP: #742935)
  * fix crash when dbus exceptions have unicode messages (LP: #761386)
  * add (empty) mapping the apt progress message that is triggered
    when a empty package disappears

  [ Gabor Kelemen ]
  * Add missing files to POTFILES.in, fixes LP: #786500

  [ Brian Murray ]
  * aptdaemon/crash.py:
    - title attachments Traceback to be consistent with apport
  * aptdaemon/crash.py:
    - only create crash reports if apport is enabled
 -- Michael Vogt <email address hidden> Tue, 19 Apr 2011 08:52:09 +0200

Changed in aptdaemon (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.