aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Bug #724735 reported by Rupp V.I. on 2011-02-25
This bug affects 316 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: aptdaemon

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: aptdaemon 0.41+bzr586-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Date: Fri Feb 25 12:39:07 2011
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/aptd
ProcEnviron:

PythonArgs: ['/usr/sbin/aptd']
SourcePackage: aptdaemon
Title: aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
UserGroups:

Related branches

Rupp V.I. (sibkras) wrote :

This crash has the same stack trace characteristics as bug #707490. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
tags: added: bugpattern-needed
tags: added: iso-testing
visibility: private → public
Aleh (aleh-ski) wrote :

There is no panel at start!

Lars Ljung (larslj) wrote :

The status_details property needs to be set to an unicode string, not to the utf-8 string returned by ngettext().

Lars Ljung (larslj) on 2011-03-06
Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Lars Ljung (larslj) wrote :

Oops, my previous patch didn't work very well with an empty environment. This one should be better. And it also solves bug #729247.

tags: added: patch
Robert Roth (evfool) on 2011-03-11
Changed in aptdaemon (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Makar (gif-inoe) on 2011-03-13
Changed in aptdaemon (Ubuntu):
assignee: nobody → Makar (gif-inoe)
Makar (gif-inoe) wrote :

guys i can't apply the patch

----------------------------------------------------
sudo patch -p0 < aptdaemon_unicode_fix3.diff
patching file aptdaemon/core.py
Hunk #1 FAILED at 69.
Hunk #2 FAILED at 1098.
2 out of 2 hunks FAILED -- saving rejects to file aptdaemon/core.py.rej
----------------------------------------------------

Changed in aptdaemon (Ubuntu):
assignee: Makar (gif-inoe) → nobody
gthomas (gt-launchpad) wrote :

applying the patch aptdaemon_unicode_fix3.diff manually solves the problem!

Artuom (artem501) wrote :

I have the same problem as Makar. The patch aptdaemon_unicode_fix3.diff doesn't work.

Artuom (artem501) wrote :

Thanks. The patch is OK. (It was my incorrect usage )

dORSY (dorsyka) wrote :

As of today, aptdaemon still crashes for me. Hope patch will be accepted and used in the package.

And for me eather... hope so too =)
--
Have a nice day =)
Князь Георг

----- Оригинальное письмо -----
От: "dORSY" <email address hidden>
Кому: <email address hidden>
Отправлено: 22.03.2011 10:00:43
Тема: [Bug 724735] Re: aptd crashed with UnicodeDecodeError in
 _set_status_details(): 'ascii' codec can't decode byte 0xd0 in
 position 0: ordinal not in range(128)

> As of today, aptdaemon still crashes for me. Hope patch
> will be accepted
> and used in the package.
>
> --
> You received this bug notification because you are a
> direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/724735
>
> Title:
> aptd crashed with UnicodeDecodeError in
> _set_status_details(): 'ascii'
> codec can't decode byte 0xd0 in position 0: ordinal not in
> range(128)
>
> Status in “aptdaemon” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: aptdaemon
>
> Slomalos' bliat'
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr586-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic
> 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> Architecture: amd64
> Date: Fri Feb 25 12:39:07 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" -
> Release amd64 (20101007.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with UnicodeDecodeError in
> _set_status_details(): 'ascii' codec can't decode byte
> 0xd0 in position 0: ordinal not in range(128)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/
> 724735/+subscribe
>
>

Basile (basilio) wrote :

Makar, are you cd /usr/share/pyshared before patching?

Patch works for me

Dmitriy (celatus) wrote :

Patch doesn't work for me :(

yanbiao98765 said "thanks for the messages" and promised answer someday.

Dmitry Shachnev (mitya57) wrote :

It's similar to bug 707490, but I have just caught it on aptdaemon 0.41+bzr604-0ubuntu1 on Xubuntu 11.04 trying to install Chromium via SC.

description: updated
tags: removed: amd64
Андрей (pante59) on 2011-03-31
Changed in aptdaemon (Ubuntu):
status: Triaged → Confirmed
status: Confirmed → Incomplete
status: Incomplete → Confirmed
yanbiao98765 (yanbiao98765) wrote :

您好!感谢您给我来邮件,谢谢!有空我会回复!

Robert Roth (evfool) on 2011-03-31
Changed in aptdaemon (Ubuntu):
status: Confirmed → Triaged
Андрей (pante59) on 2011-03-31
Changed in aptdaemon (Ubuntu):
assignee: nobody → Андрей (pante59)
assignee: Андрей (pante59) → nobody
kvasomsk (kvas-omsk) wrote :

Same bug at i386 architecture.

Atrishankov (atrishankov) wrote :

Я применил патч. Но не помогло. Кривая 11.04 откатываюсь на 10.10. И меню окон УБогое, яблонизм какой-то.

Я проклинаю тот день когда решился переключиться на development branch:)
Причиной был слет windows manager (не стартовал при запуске сессии), это
было не прикольно, когда отображались только содержимые окон... пока не
нашел тот бубен, которые это вылечил.
А теперь еще и шрифт ubuntu изменился, стал как times new roman,. и все меню
такие убогие...

--
Best wishes,
Sergey Gusev

St Artem (strahovartem) wrote :

В целом я доволен Ubuntu, многие функции сделаны более естетично и
производительно, ошибки в новои версии после нескольких обновлении
пропали. Я перешел на Ubuntu после слета семерки. Когда привыкаешь к
системе видишь преимущества по сравнению с Windows.

2011/4/1, Sergey Gusev <email address hidden>:
> Я проклинаю тот день когда решился переключиться на development branch:)
> Причиной был слет windows manager (не стартовал при запуске сессии), это
> было не прикольно, когда отображались только содержимые окон... пока не
> нашел тот бубен, которые это вылечил.
> А теперь еще и шрифт ubuntu изменился, стал как times new roman,. и все меню
> такие убогие...
>
> --
> Best wishes,
> Sergey Gusev
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (744453).
> https://bugs.launchpad.net/bugs/724735
>
> Title:
> aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii'
> codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
>
> Status in "aptdaemon" package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: aptdaemon
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr586-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> Architecture: amd64
> Date: Fri Feb 25 12:39:07 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with UnicodeDecodeError in _set_status_details():
> 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in
> range(128)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/724735/+subscribe
>

Michael Vogt (mvo) on 2011-04-01
Changed in aptdaemon (Ubuntu):
status: Triaged → In Progress
MAKAPOH (makapoh) wrote :

Один по китайски пишет, другие по русски.. ништяк ))) помощь разработчикам :)

Use English in your posts, please. If you want speak other languages, you can ask your local community (a.e. Ubuntu.ru, etc.).

Если русский хотябы из общего фона не выбивается, то то что yanbaohuy
пишет, вообще глаза режет...

On Mon, Apr 4, 2011 at 10:09 AM, MAKAPOH <email address hidden> wrote:
> Один по китайски пишет, другие по русски.. ништяк ))) помощь
> разработчикам :)
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (734977).
> https://bugs.launchpad.net/bugs/724735
>

Sergey Gusev (sagusev) wrote :

Sorry for english, but really I have nothing to add to the problem... It crashes at each login, and crashes at every attempt to install a program thru Application Center.

Кстати, беру свои слова обратно про шрифт Ubuntu... Проблема в механизме antailising, который очень своеобразно работает на шрифте Ubuntu на разных размерах.

Rupp V.I. (sibkras) wrote :

Стараемсо )))

2011/4/4 MAKAPOH <email address hidden>

> Один по китайски пишет, другие по русски.. ништяк ))) помощь
> разработчикам :)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/724735
>
> Title:
> aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii'
> codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
>
> Status in "aptdaemon" package in Ubuntu:
> In Progress
>
> Bug description:
> Binary package hint: aptdaemon
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr586-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> Architecture: amd64
> Date: Fri Feb 25 12:39:07 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with UnicodeDecodeError in _set_status_details():
> 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in
> range(128)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/724735/+subscribe
>

--
*С уважением, ведущий инженер центра спутниковой связи г.Красноярск
"Орбита",*
*Рупп Виталий Иванович. т/ф.+7 (391) 202-04-00,т/м +7-902-929-92-16.*

Rion (rion4ik) wrote :

the patch works fine.

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Committed

如果你不希望得到关于新的评论通知,请在此页面右侧Unsubscribe按钮: https://bugs.launchpad.net/bugs/724735

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr614-0ubuntu1

---------------
aptdaemon (0.41+bzr614-0ubuntu1) natty; urgency=low

  * New bzr bugfix snapshot:
    - fix i18n crash (LP: #724735)
    - Allow to specify package names with an architecture
      (for multiarch)
    - Client: Exit the transaction processing if there has been an
      error
    - Make the run method of the GTK2 progress dialog deferable
      (LP: #626798)
  * debian/patches/01_relax_lintian_checks.patch:
    - add lp:~mvo/aptdaemon/relax-lintian-checks as distro patch
      until upstream (LP: #712377)
 -- Michael Vogt <email address hidden> Tue, 05 Apr 2011 16:31:37 +0200

Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
Eugene Horohorin (genixoid) wrote :

Dear Russian commentators, please, use translit ;)

I have the same problem on 11.04

dm13dv1b (demcsik-marton) wrote :

It's perfect. Just copy the diff file to /usr/share/pyshared
and run: sudo patch -p0 < aptdaemon_unicode_fix3.diff

Eugene Horohorin (genixoid) wrote :

Today update fixed this problem

yanbiao98765 (yanbiao98765) wrote :

您好!感谢您给我来邮件,谢谢!有空我会回复!

Konstantin (dr.dtyger) wrote :

It seems, that latest update on 07-Apr-2011 solved the problem.
Ubuntu 11.04

Konstantin (dr.dtyger) wrote :

Chinese brother is writing as a good mail answer robot :-)))

yanbiao98765 (yanbiao98765) wrote :

您好!感谢您给我来邮件,谢谢!有空我会回复!

Konstantin (dr.dtyger) wrote :

Я смотрю тебе и с русским не очень...
I see you are not perfect in russian language too...

On Thu, Apr 7, 2011 at 10:07 PM, nico242 <email address hidden> wrote:
> мне плохо с английиким
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (734977).
> https://bugs.launchpad.net/bugs/724735
>
> Title:
> aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii'
> codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
>
> Status in "aptdaemon" package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: aptdaemon
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr586-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> Architecture: amd64
> Date: Fri Feb 25 12:39:07 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/724735/+subscribe
>

Balazs Pere (perebal-sze) wrote :

aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii' codec can't decode byte 0xc3 in position 22: ordinal not in range(128)

I got this bug report after updating ubuntu, so my system is up to date. (of course Natty)

Mikael Nordfeldth (mmn) wrote :

I got this with 2.6.38-8 at least, and latest updates per 2011-04-19 13:30

Sergey Morozik (morozsm) wrote :

aptdaemon 0.41+bzr646-0ubuntu2

Problem is still exists.

Sebastian Heinlein (glatzor) wrote :

Moroz: Could you please copy and paste the details from the error dialog?

Changed in aptdaemon (Ubuntu):
status: Fix Released → In Progress
Eugene Crosser (crosser) wrote :

I think the problem has stopped happening to me a few days back.

aptdaemon:
  Installed: 0.41+bzr646-0ubuntu2

eixmg (ei-xmg) wrote :

problem repeats systematically :(

yanbiao98765 (yanbiao98765) wrote :

您好!感谢您给我来邮件,谢谢!有空我会回复!

Sebastian Heinlein (glatzor) wrote :

the bug was fixed with revno 615 which is in Oneiric

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Released
yanbiao98765 (yanbiao98765) wrote :

您好!感谢您给我来邮件,谢谢!有空我会回复!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers