[NO MORE COMMENTS PLEASE] Cannot install local deb package from Software Center

Bug #702217 reported by Salih EMIN on 2011-01-13
904
This bug affects 124 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
Invalid
Undecided
Unassigned
aptdaemon (Fluxbuntu)
Invalid
Undecided
Unassigned
aptdaemon (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: aptdaemon

I installed the latest updates (5 minutes ago) and then tried to install an app from a package. As expected, Ubuntu Sof Cent opened up and then I pressed install. But unfortunately a message poped up saying :

----------------------------------
"An unhandlable error occured

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks. Please report this error at http://launchpad.net/aptdaemon/+filebug and retry.

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 884, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 987, in _simulate_helper
    trans.packages[PKGS_INSTALL] = [deb.pkgname]
TypeError: 'dbus.Struct' object does not support item assignment
"
-----------------------------------

Also when I tried to run apport-cli through terminal to check if there is a report I got this:
$ apport-cli

*** aptd closed unexpectedly on 2011-01-13 at 05:22:52.

If you were not doing anything confidential (entering passwords or other
private information), you can help to improve the application by reporting
the problem.

What would you like to do? Your options are:
  R: Report Problem...
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (R/I/C):R

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
.
*** Error: Invalid problem report

This problem report is damaged and cannot be processed.

IOError(13, 'Permission denied')
Press any key to continue...^C
----------------------------------------------

===================================

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: aptdaemon 0.40+bzr541-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Thu Jan 13 05:16:22 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101213)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: aptdaemon

Related branches

Salih EMIN (salih-emin) wrote :
description: updated
Robert Roth (evfool) on 2011-01-28
Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) wrote :

Changing the summary from what I've concluded from the duplicate list, and setting this as a metabug, as this will occur to everyone who is trying to install a local deb file from software center.

tags: added: metabug
removed: amd64 apport-bug
summary: - aptdaemon:An unhandlable error occured
+ Cannot install local deb package from Software Center

I have found an easy workaround for this problem, you can just run "sudo dpkg -i PATH-TO-DEB-FILE", but of course, replace the PATH-TO-DEB-FILE with the actual path of the deb file you would like to install (the full path appears in the bug you have reported)

Yeah I know how to install a .deb file manually,just repored this bug for the Ubuntu devs to be notified.

C de-Avillez (hggdh2) wrote :

Marking Triaged/High: easy to reproduce, and the amount of duplicates justifies High.

Changed in aptdaemon (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
William A Ellerbe (waellerbe) wrote :

@Robert Roth - Thank you for the suggestion of using "sudo dpkg -i PATH-TO-DEB-FILE" as a way to install VirtualBox 4.0 on my system. I tried it, and was able to install VirtualBox successfully. No I'm reviewing some tips from the VirtualBox forums to find solutions for the DKMS and vbxdrv errors that some of us are running into. Thanks again for sharing the tip kind sir.

Brian Murray (brian-murray) wrote :

Setting this to Fix Committed based off the comments in bug 712838 and the merge proposal linked to this bug.

Changed in aptdaemon (Ubuntu):
status: Triaged → Fix Committed
tags: added: bugpattern-written
William A Ellerbe (waellerbe) wrote :

Hello Developers,

I would like to share a tip that helped me install Google Chrome Beta 9 successfully. As of today 02/08/11 I performed a Clean Install of Ubuntu 11.04 Alpha 2, and I'm still running into the same error with the aptdaemon package. Instead of complaining about stuff that doesn't work, I wanted to offer a tip to help other folks install Google Chrome Beta 9 successfully. As you can see from Line 1, I used the "sudo dpkg -i PATH-TO-FILE" command, and discovered in Line 8 that the "libcurl3" package was not installed. In kind I would enter "sudo apt-get install libcurl3" into my terminal window, and the package installed successfully. After this process was complete, I issued the "sudo dpkg -i PATH-TO-FILE" command to install Google Chrome Beta 9 and IT WORKED. Thanks again for all that you're doing to help users with the various bugs that are being reported.

1) william@william-Aspire-5516:~/Downloads$ sudo dpkg -i google-chrome-beta_current_i386.deb
2) sudo] password for william:
3) (Reading database ... 139663 files and directories currently installed.)
4) Preparing to replace google-chrome-beta 9.0.597.84-r72991 (using google-chrome-beta_current_i386.deb) ...
5) Unpacking replacement google-chrome-beta ...
6) dpkg: dependency problems prevent configuration of google-chrome-beta:
7) google-chrome-beta depends on libcurl3; however:

8) Package libcurl3 is not installed. ## I HAD TO INSTALL THE "libcurl3" PACKAGE

9) dpkg: error processing google-chrome-beta (--install):
10) dependency problems - leaving unconfigured
11) Processing triggers for man-db ...
12) Processing triggers for bamfdaemon ...
13) Rebuilding /usr/share/applications/bamf.index...
14) Processing triggers for desktop-file-utils ...
15) Processing triggers for python-gmenu ...
16) Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
17) Processing triggers for python-support ...
18) Errors were encountered while processing:
19) google-chrome-beta
20) william@william-Aspire-5516:~/Downloads$

Russell Hart (russellhart1) wrote :

William A Ellerbe:
That libcurl13 issue is specific to the package you were installing.
Unless installing libcurl13 then allows you to install local deb files using the software centre it is irrelevant to this bug report.

The, sudo dpkg -i PATH-TO-FILE, command is already a known work around.

P Cantwall (p-cantwell) wrote :

Thanks for the workaround to help me install google-chrome-stable_current_amd64.deb into today's Natty. libcurl3 was already installed for me, but I've been adding bits and pieces all evening. Thanks for the comments!

Eakan Gopalakrishnan (eakangk) wrote :

i had reported Bug 720468 and was asked to test a new kernel on my machine. But unfortunately when i tries installing the new one, the installer crashed.
I'll try again and post an update.

Eakan Gopalakrishnan (eakangk) wrote :

tried again. but no luck. there seems to be a programming error it seems..

Eakan Gopalakrishnan (eakangk) wrote :

now i'm going to try installing from backend..install successful..

Download full text (3.3 KiB)

Hi
will the bigfoot network killer2100 network card driver will be add it to
ubuntu and repository for sun java.

PC911
Charles Raimbault
4698672911

On Tue, Feb 22, 2011 at 5:48 PM, Eakan Gopalakrishnan <
<email address hidden>> wrote:

> i had reported Bug 720468 and was asked to test a new kernel on my machine.
> But unfortunately when i tries installing the new one, the installer
> crashed.
> I'll try again and post an update.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (713748).
> https://bugs.launchpad.net/bugs/702217
>
> Title:
> Cannot install local deb package from Software Center
>
> Status in Ubuntu Software Center:
> New
> Status in “aptdaemon” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: aptdaemon
>
> I installed the latest updates (5 minutes ago) and then tried to
> install an app from a package. As expected, Ubuntu Sof Cent opened up
> and then I pressed install. But unfortunately a message poped up
> saying :
>
> ----------------------------------
> "An unhandlable error occured
>
> There seems to be a programming error in aptdaemon, the software that
> allows you to install/remove software and to perform other package
> management related tasks. Please report this error at
> http://launchpad.net/aptdaemon/+filebug and retry.
>
> Traceback (most recent call last):
> File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 884,
> in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 987,
> in _simulate_helper
> trans.packages[PKGS_INSTALL] = [deb.pkgname]
> TypeError: 'dbus.Struct' object does not support item assignment
> "
> -----------------------------------
>
> Also when I tried to run apport-cli through terminal to check if there is
> a report I got this:
> $ apport-cli
>
> *** aptd closed unexpectedly on 2011-01-13 at 05:22:52.
>
> If you were not doing anything confidential (entering passwords or other
> private information), you can help to improve the application by reporting
> the problem.
>
> What would you like to do? Your options are:
> R: Report Problem...
> I: Cancel and ignore future crashes of this program version
> C: Cancel
> Please choose (R/I/C):R
>
> *** Collecting problem information
>
> The collected information can be sent to the developers to improve the
> application. This might take a few minutes.
> .
> *** Error: Invalid problem report
>
> This problem report is damaged and cannot be processed.
>
> IOError(13, 'Permission denied')
> Press any key to continue...^C
> ----------------------------------------------
>
>
> ===================================
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.40+bzr541-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
> Uname: Linux 2.6.37-12-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Thu Jan 13 05:16:22 2011
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101213)
> PackageArchitecture: all
> ProcEnviron:
> LANGUA...

Read more...

Hi
Sorry I only want the best for Ubuntu getting better driver and os for plug
and play is my concern
On Feb 24, 2011 12:46 AM, "Sebastian Heinlein" <email address hidden>
wrote:
> Please only comment on this error.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (713748).
> https://bugs.launchpad.net/bugs/702217
>
> Title:
> Cannot install local deb package from Software Center
>
> Status in Ubuntu Software Center:
> New
> Status in “aptdaemon” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: aptdaemon
>
> I installed the latest updates (5 minutes ago) and then tried to
> install an app from a package. As expected, Ubuntu Sof Cent opened up
> and then I pressed install. But unfortunately a message poped up
> saying :
>
> ----------------------------------
> "An unhandlable error occured
>
> There seems to be a programming error in aptdaemon, the software that
> allows you to install/remove software and to perform other package
> management related tasks. Please report this error at
> http://launchpad.net/aptdaemon/+filebug and retry.
>
> Traceback (most recent call last):
> File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 884,
in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 987,
in _simulate_helper
> trans.packages[PKGS_INSTALL] = [deb.pkgname]
> TypeError: 'dbus.Struct' object does not support item assignment
> "
> -----------------------------------
>
> Also when I tried to run apport-cli through terminal to check if there is
a report I got this:
> $ apport-cli
>
> *** aptd closed unexpectedly on 2011-01-13 at 05:22:52.
>
> If you were not doing anything confidential (entering passwords or other
> private information), you can help to improve the application by reporting
> the problem.
>
> What would you like to do? Your options are:
> R: Report Problem...
> I: Cancel and ignore future crashes of this program version
> C: Cancel
> Please choose (R/I/C):R
>
> *** Collecting problem information
>
> The collected information can be sent to the developers to improve the
> application. This might take a few minutes.
> .
> *** Error: Invalid problem report
>
> This problem report is damaged and cannot be processed.
>
> IOError(13, 'Permission denied')
> Press any key to continue...^C
> ----------------------------------------------
>
>
> ===================================
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.40+bzr541-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
> Uname: Linux 2.6.37-12-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Thu Jan 13 05:16:22 2011
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101213)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> LC_MESSAGES=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: aptdaemon
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/software-center/+bug/702217/+subscribe

And I only want to keep the bugs organized :)

Doug McMahon (mc3man) wrote :

Slightly confusing bug - 'fix committed' and in the linked dupe a 'fix released'
In any event it is not fixed as of aptdaemon ...bzr586
While it is possible to install a local <whatever>.deb w/ SC, it must be in the apt-cache, otherwise the install will fail as noted in the various bug reports

GrahamT (graham-travis) wrote :

Got the bug with 26 Feb nightly, installing ubuntu-tweaks under Virtualbox 3.1.6

antibushido (l337dperry) wrote :

i got this when trying to install pcrx.deb but i installed it manually on ubuntu 11.04

vmc (vmclark) wrote :

Regarding post#8, I tried :
sudo apt-get install libcurl3
[sudo] password for vmc:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libcurl3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libcurl3' has no installation candidate

Trying to find out what it is:
$ apt-cache showpkg libcurl3
Package: libcurl3
Versions:

Reverse Depends:
  google-chrome-stable,libcurl3
Dependencies:
Provides:
Reverse Provides:

And yet Ubuntu Software Center shows it installed?!

Doug McMahon (mc3man) on 2011-03-04
Changed in aptdaemon (Ubuntu):
status: Fix Committed → Confirmed
stoja (stojabreak) wrote :

Using " GDEBI " temporal installer fix this " problem " :)

Changed in aptdaemon (Fluxbuntu):
status: New → Invalid
davidz12 (dvanderzande) wrote :

I can't install .deb files in Alpha 3, I thought it was fixed?

Me neither. Temporarily you can use gdebi (previous graphical installer) or
dpkg in command line. Both work just fine.
04-03-2011 14:16 użytkownik "davidz12" <email address hidden> napisał:
> I can't install .deb files in Alpha 3, I thought it was fixed?
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (712616).
> https://bugs.launchpad.net/bugs/702217
>
> Title:
> Cannot install local deb package from Software Center
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/software-center/+bug/702217/+subscribe

Ingo Gerth (igerth) wrote :

The behavior of this bug is now well known. Please do not add any comments of the fashion "I get this with this package too!", it will only unnecessarily spam the developers' inbox.

summary: - Cannot install local deb package from Software Center
+ [NO MORE COMMENTS PLEASE] Cannot install local deb package from Software
+ Center
Michael Vogt (mvo) on 2011-03-07
Changed in software-center:
status: New → Invalid
Changed in aptdaemon (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr595-0ubuntu1

---------------
aptdaemon (0.41+bzr595-0ubuntu1) natty; urgency=low

  * New upstream bzr snapshot:
    - fix installing local debs (LP: #702217)
 -- Michael Vogt <email address hidden> Tue, 08 Mar 2011 08:52:55 +0100

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Released
Mauricio Pretto (pretto) wrote :

working here !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers