aptd crashed with SIGSEGV in pkgDepCache::ActionGroup::release()

Bug #691134 reported by Salih EMIN on 2010-12-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Medium
Unassigned
python-apt (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: aptdaemon

Using Software Center, I tried to install 2 programs : Zenmap and VLC. After Znmap was installed apport reported that "apt" has crashed and I checked that vlc was not installed. After the message I tried to install separately the VLC from the already opened Software Center and everything went OK and after a seconds VLC is now installed, I must note that Zenmap was not visible in the Applications --> Internet --> Zenmap as it should be as reported in Software Center. I went to check Zenmap with "Menu Editor" (check the attached screenshot) to see if it was [v] ticked to be visible and it was but it is not visible in the menu.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: aptdaemon 0.40+bzr529-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-9.23-generic 2.6.37-rc5
Uname: Linux 2.6.37-9-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CrashCounter: 1
Date: Thu Dec 16 17:22:21 2010
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101213)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/aptd
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0x7f23e8405dc6 <_ZN11pkgDepCache11ActionGroup7releaseEv+22>: cmpb $0x0,0x8(%rdi)
 PC (0x7f23e8405dc6) ok
 source "$0x0" ok
 destination "0x8(%rdi)" (0xae0000004c) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: aptdaemon
StacktraceTop:
 pkgDepCache::ActionGroup::release() () from /usr/lib/libapt-pkg.so.4.10
 ?? () from /usr/lib/python2.7/dist-packages/apt_pkg.so
 PyObject_CallFunctionObjArgs ()
 PyEval_EvalFrameEx ()
 PyEval_EvalFrameEx ()
Title: aptd crashed with SIGSEGV in pkgDepCache::ActionGroup::release()
UserGroups:

Related branches

Salih EMIN (salih-emin) wrote :
Salih EMIN (salih-emin) wrote :

Attaching the mentioned screenshot

visibility: private → public

StacktraceTop:
 pkgDepCache::ActionGroup::release (
 PkgActionGroupExit (Self=<value optimized out>,
 PyObject_CallFunctionObjArgs (callable=0x1ef7950)
 ?? ()
 ?? ()

Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in python-apt (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

I looked into this today and it appears to be a problem with the new contextmanager actiongroup code in python-apt. Its nothing that aptdaemon is responsible for, so I mark the aptdaemon task invalid.

Changed in aptdaemon (Ubuntu):
status: Confirmed → Invalid
Changed in python-apt (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.7.100.1ubuntu2

---------------
python-apt (0.7.100.1ubuntu2) natty; urgency=low

  * python/depcache.cc:
    - when using the actiongroup as a contextmanager incref/decref
      on enter and leave. this should fix the instablity issues
      that aptdaemon runs into (LP: #691134)
   * debian/control:
     - really dropped python2.6 recommends
 -- Michael Vogt <email address hidden> Wed, 22 Dec 2010 11:03:07 +0100

Changed in python-apt (Ubuntu):
status: In Progress → Fix Released
Sebastian Heinlein (glatzor) wrote :

Cool!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers