aptdaemon dbus backend crash in self._transaction.run(defer=True)

Bug #619363 reported by GD on 2010-08-17
374
This bug affects 51 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Unassigned
software-center-aptdaemon-plugins (Ubuntu)
Undecided
luis vargas

Bug Description

Binary package hint: language-selector

1) What you expected to happen
Download English and Russian languages.

2) What happened instead
Nothing. After some time program crashed.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: language-selector 0.6.2
ProcVersionSignature: Ubuntu 2.6.35-15.21-generic 2.6.35.1
Uname: Linux 2.6.35-15-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Wed Aug 18 04:23:50 2010
ExecutablePath: /usr/bin/gnome-language-selector
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gnome-language-selector
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 LANGUAGE=en_US:en
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/gnome-language-selector']
SourcePackage: language-selector
Title: gnome-language-selector crashed with DBusException in _run()
UserGroups:

GD (gmarketer) wrote :
description: updated
tags: removed: need-duplicate-check
Martin Pitt (pitti) on 2011-03-18
summary: - gnome-language-selector crashed with DBusException in _run()
+ aptdaemon dbus backend crash in self._transaction.run(defer=True)
affects: language-selector (Ubuntu) → aptdaemon (Ubuntu)
visibility: private → public
tags: added: bugpattern-needed
Changed in aptdaemon (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
Joschi Poschi (joschiposchi) wrote :

Got this issue after upgrading to Precise Pangolin in a Virtual Box trying to get missing language packages.

Sebastian Heinlein (glatzor) wrote :

Raise priority because of the number of dups.

Changed in aptdaemon (Ubuntu):
importance: Undecided → High
Seba78 (teo78) wrote :

Present bug in precise-pangolin fresh install.
Bug presente en una instalación fresca de precise-pangolin. No me permite instalar soporte de idiomas en español.

SarahSlean (yoda4) wrote :

on 12.04 alpha1 , on virtual box ,i have this bug

psamuel (persaudsamuel) wrote :

No puedo instalar el paquete de idiomas en español

maninred (maninred) wrote :

the same on ubuntu12.04 64bit on 24.12.2011 upgrade.

Ramiro Queso (rqueso) wrote :

No es posible actualizar el idioma 28-12-2011 17:29

tags: removed: bugpattern-needed
tags: added: bugpattern-written
tags: added: precise
Marcos (marc-lledo) wrote :

Ubuntu 12.10 instalación limpia, al quitar el idioma ingles, salta el error.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center-aptdaemon-plugins (Ubuntu):
status: New → Confirmed
Changed in software-center-aptdaemon-plugins (Ubuntu):
assignee: nobody → Huynh Trung Tin (tinvuong51003405)
Changed in software-center-aptdaemon-plugins (Ubuntu):
assignee: Huynh Trung Tin (tinvuong51003405) → nobody
binukv (binu-thilak012) wrote :

i am using the ubuntu12.04 LTS. when i upating the available updates it was crashed, and still crashed.

todaioan (alan-ar06) on 2012-12-28
Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Committed
Changed in software-center-aptdaemon-plugins (Ubuntu):
status: Confirmed → Fix Released
Changed in aptdaemon (Ubuntu):
status: Fix Committed → Confirmed
Changed in software-center-aptdaemon-plugins (Ubuntu):
status: Fix Released → Confirmed
thomas (thomas13law) on 2013-08-17
Changed in aptdaemon (Ubuntu):
status: Confirmed → New
Changed in software-center-aptdaemon-plugins (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Changed in software-center-aptdaemon-plugins (Ubuntu):
status: New → Confirmed
Changed in aptdaemon (Ubuntu):
assignee: nobody → miadawn79@gmail.com (miadawn79)
Changed in software-center-aptdaemon-plugins (Ubuntu):
assignee: nobody → miadawn79@gmail.com (miadawn79)
Changed in software-center-aptdaemon-plugins (Ubuntu):
assignee: nobody → luis vargas (elgets61999)
mahdi (mnusrat) on 2017-11-07
Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Committed
Changed in software-center-aptdaemon-plugins (Ubuntu):
status: Confirmed → Fix Released
Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.