Scrolled windows in update-manager are too small to read

Bug #1690541 reported by Hrunting on 2017-05-13
292
This bug affects 59 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Brian Murray
Artful
High
Brian Murray

Bug Description

[Impact]
When you expand the details window and packages are being prepared and configured the Vte terminal is only one line high so can't see what is going on at all.

[Test Case]
1) Install artful w/o updates
2) Run update-manager
3) Expand the details window after packages have downloaded (if you the Vte terminal is more than one line high then close the detail and open it again)

With the version of the package from -proposed the details window will be many lines high and you will see stuff.

[Regression Potential]
Little as we are just setting vexpand and hexpand to True for the widget.

Original Description
--------------------
In update-manager, scrolled windows do not expand properly. Many times, the display will only be one line. I see it on the download progress view, the install details (terminal-like) view, and would-you-like-to-keep-or-replace config differences view. In each one, the details window does not expand to the full height of the window. If the expansion hasn't been done at all, the view will only be one line high, but in the download progress view, it can sometimes be half-height.

Prior reports (https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1623856) indicate that it has been fixed, but that is not the case, and in the prior "fixed" report, the maintainer asked that a new bug be created.

It is very difficult to get screenshots because the window only appears for a short time, but I have attached one such screenshot below.

Versions:
Ubuntu: Zesty
update-manager: 1:17.04.3
aptdaemon: 1.1.1+bzr982-0ubuntu17

Hrunting (ubuntu-hrunting) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Changed in update-manager (Ubuntu):
status: New → Confirmed
anatoly techtonik (techtonik) wrote :

I wonder if Canonical invests into regression tests for user interfaces.

tags: added: zesty
spike speigel (frail-knight) wrote :

Here's another pic. Zesty 17.10 with proposed updates enabled.

spike speigel (frail-knight) wrote :

Forgive me, I meant 17.04

Adolfo Jayme (fitojb) on 2017-06-30
Changed in update-manager (Ubuntu):
importance: Undecided → High
spike speigel (frail-knight) wrote :

Here's another screenshot from today's updating. It appears the issue is intermittent and variable in inner window size. Sometimes it shows one line, sometimes more, bit still doesn't use the entire window space.

James Stevenson (ja7es) wrote :

Here is another screenshot showing that the problem is still happening.

Emanuel Angelo (emansije) wrote :

Spike, I haven't tested that in a while, but what I recall is that if you expand the details while in the downloading phase, it then expands to a few more lines in the installation phase. Can anyone confirm that? I'll test it and report back, next time I use the updater.

Emanuel Angelo (emansije) wrote :

I've just confirmed what I stated before, but with a small correction: When expanding the details' area while in the download phase, it uses all the available space, not only a few more lines, and that remains the case during the installation phase. Then, if you happen to close the details' area and open it again, it shows only one line and you can never recover the space, no matter what you do afterwards.

Brian Murray (brian-murray) wrote :

I was able to recreate this bug using the steps in comment #10, after closing the details' area during the download phase and reopening it I saw only one line of the transaction.

Brian Murray (brian-murray) wrote :

When performing another update, after the first one where I closed the details, the size was stuck at one line for only the download phase.

Brian Murray (brian-murray) wrote :

Actually, to be clear it is not the download but installing details that are now stuck at one line.

tags: added: id-597a0a32ed7a7da4a899a20b
PJSingh5000 (pjsingh5000) wrote :

Confirming problem as described in comment #10.

Hrunting (ubuntu-hrunting) wrote :

This problem persists in Ubuntu 17.10 (Artful Aardvark).

tags: added: artful
drunckoder (drunckoder) wrote :

Confirming persistence in Ubuntu 17.10 (Artful Aardvark).

Andy Smith (grifferz) wrote :

Example of this in 17.10 while kernel packages are being updated and trying to see "Details"

Jarno Suni (jarnos) wrote :

Does this occur also when Software Updater is just presenting available updates? Can it show more than 2 rows for details then?

Beren (berencamlost) wrote :

Presenting available updates works as intended. It is the embedded terminal window during applying updates that is broken.

This broken behavior has been present since at least 17.04 alpha/beta, and is present in 17.10 and 18.04. I haven't tried 16.10 but this was working in 16.04.

I have only tested this on Ubuntu Mate, so I don't know if software-updater behaves differently on other flavours.

Cubic PPA (cubic-wizard) wrote :

Also present on "standard" Ubuntu 17.10 using GNOME Shell 3.26.2.

Fredrik Jacobsson (fredrik-o) wrote :

Ahh, yes, the resize output area bug, I remember seeing this some months (a year?) ago. Can't just remember where. Pity you can't browse to see which bugs you have marked as affect you too.

The bug show itself when the program tries to add more visual space vertically. The other way around, resizing down, and resizing horizontally still works.

an screenshot during downloading

and during installing (but there is nothing new)
screenshots are from Ubuntu 17.10.1

Fredrik Jacobsson (fredrik-o) wrote :

Workaround to get some terminal output:

Disable automatic downloads of updated files. The key here is that you need to show details on progress during the download phase as the bug affects the download progress window too, otherwise you'll get the "one-liner".

This bug show itself when:
displaying the download progress area
displaying the terminal output
showing the changes to a configuration file
when doing a Dist upgrade

here the post i made in "ask question" area, with some further description.
https://answers.launchpad.net/ubuntu/+question/663622

clel (clel) wrote :

Also adding an (older) screenshot of the problem. It still exists.

I am not sure, but I think this only happens on upgraded installation, not on new Ubuntu installs. Can someone confirm this?

Unfortunately it seems that Ubuntu does not have much manpower to get such easy but annoying issues fixed fast.

Andy Smith (grifferz) wrote :

No, it still happens for me on a clean install of 17.10.

Changed in aptdaemon (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Brian Murray (brian-murray)
tags: added: id-5a95f346db833635da0cf63b
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.1.1+bzr982-0ubuntu19

---------------
aptdaemon (1.1.1+bzr982-0ubuntu19) bionic; urgency=medium

  * d/p/lp1690541-details-open-twice.patch: Indicate that the AptTerminal
    widget would like extra space so we can see more terminal output.
    (LP: #1690541)

 -- Brian Murray <email address hidden> Tue, 27 Feb 2018 16:21:11 -0800

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Released
Changed in update-manager (Ubuntu):
status: Confirmed → Invalid
Changed in update-manager (Ubuntu Artful):
status: New → Invalid
description: updated
Changed in aptdaemon (Ubuntu Artful):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)

Hello Hrunting, or anyone else affected,

Accepted aptdaemon into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/aptdaemon/1.1.1+bzr982-0ubuntu17.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in aptdaemon (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Brian Murray (brian-murray) wrote :

I installed the version of aptdaemon from -proposed for Artful and confirm that it fixes the bug.

bdmurray@clean-artful-amd64:~$ sudo apt-get install aptdaemon
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  python3-aptdaemon python3-aptdaemon.gtk3widgets
The following packages will be upgraded:
  aptdaemon python3-aptdaemon python3-aptdaemon.gtk3widgets
3 upgraded, 0 newly installed, 0 to remove and 162 not upgraded.
Need to get 105 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://192.168.10.7/ubuntu artful-proposed/main amd64 python3-aptdaemon.gtk3widgets all 1.1.1+bzr982-0ubuntu17.1 [13.9 kB]
Get:2 http://192.168.10.7/ubuntu artful-proposed/main amd64 aptdaemon all 1.1.1+bzr982-0ubuntu17.1 [13.5 kB]
Get:3 http://192.168.10.7/ubuntu artful-proposed/main amd64 python3-aptdaemon all 1.1.1+bzr982-0ubuntu17.1 [77.1 kB]
Fetched 105 kB in 0s (0 B/s)

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
no longer affects: update-manager (Ubuntu)
no longer affects: update-manager (Ubuntu Artful)
Changed in aptdaemon (Ubuntu):
importance: Undecided → High
Changed in aptdaemon (Ubuntu Artful):
importance: Undecided → High
Beren (berencamlost) wrote :

I can confirm that aptdaemon from artful-proposed fixes the issue.

aptdaemon 1.1.1+bzr982-0ubuntu17.1

Fredrik Jacobsson (fredrik-o) wrote :

Hello!

The resize bug is only partially fixed. Download progress display doesn't expand to show more than 5 files. see attached screenshot.

Dan Allen (h-dan) wrote :

The fix solves the issue on my test system. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.1.1+bzr982-0ubuntu17.1

---------------
aptdaemon (1.1.1+bzr982-0ubuntu17.1) artful; urgency=medium

  * d/p/lp1689668-config-file-window.patch: Ensure that the dialog to resolve
    config conflicts is large enough to provide useful information.
    (LP: #1689668)
  * d/p/lp1690541-details-open-twice.patch: Indicate that the AptTerminal
    widget would like extra space so we can see more terminal output.
    (LP: #1690541)

 -- Brian Murray <email address hidden> Tue, 27 Feb 2018 08:43:10 -0800

Changed in aptdaemon (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for aptdaemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Jiri Sluka (sluj) wrote :

I confirm fredrik-o response: The bug is fixed partially only. Any of my computers have the same problem with updated aptdaemon package. The download progress display field is expandable to limited size only (5 lines). If window is larger than 5 lines then a blank space is displayed below download progress field.
Second problem is:
Virtual PC's in VMware cannot display more then 1 line of black field showing packet installations after update download. It is absolutely unusable, I cannot see what packet is installed just now.

From my point of view the bug is not fixed or is fixed for some platforms only (not on my computers).

clel (clel) wrote :

Hm, I also was wondering, why the response of fredrik-o got ignored. And if this is true, didn't they test it themselves in the first place before releasing the fix?

I will keep an eye onto this and will see whether it is the same on my machines.

Dan Allen (h-dan) wrote :

The details section on my system is a black text based panel that was originally just a single line (as shown in comment #1). This is now fixed and fills the window correctly so all the text can be seen.

It doesn't look like the screen shot shown in comment #32. Perhaps this is a different issue?

Dennis L. (dennis2society) wrote :

I can confirm that the embedded installation progress terminal frame now expands as expected. For the last three runs of update-manager (that took long enough to be able to open the detailed view) the terminal has the correct size.
However the download progress does not. It now shows five lines for downloading packages but when expanding the entire window the download progress frame does not expand together with the window (in vertical direction) but stays at the five lines size.

Brian Murray (brian-murray) wrote :

On what release it is observed that package downloads only displays five packages? I was unable to recreate this on Bionic or Xenial.

Dennis L. (dennis2society) wrote :

I'm on 17.10 and will try my best to make a screenshot on the next update-manager run with enough packages to be installed so that the download dialog is visible for long enough.

Dennis L. (dennis2society) wrote :

Thanks to a larger package download I could make screenshots of the downloading progress.
The first one shows the default window size, the second one shows the same window after resizing the window vertically (increased size).
The download list remains at a constant vertical size even with a larger window.

clel (clel) wrote :

Now I also got the chance to get to the download window. I have exactly the same issue with the list not properly expanding. Screenshots are attached.

I am on 17.10 as well (upgraded).

clel (clel) wrote :
clel (clel) wrote :

same issue here...
ubuntu 18.04 LTS update software screenshot.
the shot is just from today (2018-05-21)

Brian Murray (brian-murray) wrote :

@beta-tester - While what you are seeing is a bug it is not the same bug as this one (details box is only one line high) please open a new bug report about update-manager.

@Brian Murray (brian-murray)
the issue i (and others) showed in screenshots were a follow up of the main issue...
i thought it is the right place to put my screenshot here as well.

ok, opened a new report...
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1772486

To post a comment you must log in.