ListUpdate reports a cancelled download as a failed one

Bug #162441 reported by Michael Vogt on 2007-11-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
aptdaemon (Ubuntu)
Low
Michael Vogt
Hardy
Low
Unassigned

Bug Description

Binary package hint: update-manager

If a download is cancelt in the release-upgrader it should *not* display a failed to download dialog, but just exit.

If a download of a prerequist is cancled it should stop instead of restarting without prerequists.

Michael Vogt (mvo) on 2007-11-13
Changed in update-manager:
milestone: none → ubuntu-8.04
status: New → Confirmed
Steve Langasek (vorlon) on 2008-03-25
Changed in update-manager:
importance: Undecided → Medium
Colin Watson (cjwatson) on 2008-04-02
Changed in update-manager:
assignee: nobody → mvo
Michael Vogt (mvo) on 2008-04-17
Changed in update-manager:
importance: Medium → Low
Michael Vogt (mvo) on 2008-04-24
Changed in update-manager:
milestone: ubuntu-8.04 → ubuntu-8.04.1
Steve Langasek (vorlon) on 2008-06-07
Changed in update-manager:
importance: Undecided → Low
status: New → Confirmed
milestone: ubuntu-8.04.1 → none
Robert Roth (evfool) on 2011-08-08
Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
Robert Roth (evfool) on 2011-09-05
affects: update-manager (Ubuntu) → aptdaemon (Ubuntu)
summary: - improve download cancel handling
+ ListUpdate reports a cancelled download as a failed one
Changed in aptdaemon (Ubuntu):
status: Triaged → Fix Committed
Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
Changed in aptdaemon (Ubuntu Hardy):
status: Confirmed → Won't Fix
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu Hardy):
status: New → Confirmed
Changed in apt (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

Hardy has seen the end of its life and is no longer receiving any updates. Marking the Hardy task for this ticket as "Won't Fix".

Changed in apt (Ubuntu Hardy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers