Needs to be ported to packagekit 1

Bug #1496292 reported by errors.ubuntu.com bug bridge on 2015-09-16
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Mathieu Trudel-Lapierre
click (Ubuntu)
High
Timo Jyrinki
packagekit (Ubuntu)
High
Unassigned
ubuntu-touch-meta (Ubuntu)
High
Timo Jyrinki
unity8-desktop-session (Ubuntu)
High
Timo Jyrinki

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding aptdaemon. This problem was most recently seen with version 1.1.1+bzr982-0ubuntu8, the problem page at https://errors.ubuntu.com/problem/0cbdb94861b90a2bf18c183fb3031ed81f6bb5a7 contains more details.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issue is likely there with newer packagekit, there was a newer/incompatible version in wily-proposed for a while (it got deleted since)

Changed in aptdaemon (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.1.1+bzr982-0ubuntu10

---------------
aptdaemon (1.1.1+bzr982-0ubuntu10) wily; urgency=medium

  * debian/control: let python(3)-aptdaemon Depends on
      gir1.2-packagekitglib-1.0 (<< 0.9) (restrict the version because
      0.9 is incompatible, also that version was uploaded to
      wily-proposed and deleted but some users got it installed, that
      way apt knows there is a conflict to resolve) (lp: #1496292)
  * debian/patches/key_value_typo.patch:
    - remove trailing "," causing a TypeError, thanks Justin McPherson

 -- Sebastien Bacher <email address hidden> Tue, 29 Sep 2015 16:40:25 +0200

Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
Changed in aptdaemon (Ubuntu):
status: Fix Released → New
tags: added: block-proposed
summary: - /usr/sbin/aptd:AttributeError:/usr/sbin/aptd@39:main:__init__:__init__
+ Needs to be ported to packagekit 1
Changed in packagekit (Ubuntu):
importance: Undecided → High
Michael Vogt (mvo) wrote :

I think there is just some stale data in the code:
=== modified file 'aptdaemon/worker/pkworker.py'
--- aptdaemon/worker/pkworker.py 2014-06-26 07:13:49 +0000
+++ aptdaemon/worker/pkworker.py 2016-05-20 07:02:12 +0000
@@ -172,8 +172,6 @@
                                         pk.RoleEnum.GET_UPDATE_DETAIL,
                                         pk.RoleEnum.GET_PACKAGES,
                                         pk.RoleEnum.GET_DETAILS,
- pk.RoleEnum.GET_DEPENDS,
- pk.RoleEnum.GET_REQUIRES,
                                         pk.RoleEnum.SEARCH_NAME,
                                         pk.RoleEnum.SEARCH_DETAILS,
                                         pk.RoleEnum.SEARCH_GROUP,

is probably enough.

Michael Vogt (mvo) wrote :

There is one more reference where removed pk enums are used, attached is the patch.

tags: added: patch
dino99 (9d9) wrote :

Yakkety (proposed) now has been updated to packagekit 1.1.1-1ubuntu1
But there are some conflicts when trying to upgrade:

 sudo apt-get install gir1.2-packagekitglib-1.0
[sudo] password for oem:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED
  aptdaemon apturl language-selector-gnome nautilus-share python3-aptdaemon
  python3-aptdaemon.gtk3widgets python3-aptdaemon.pkcompat sessioninstaller
  software-properties-gtk system-config-printer-gnome
The following packages will be upgraded:
  gir1.2-packagekitglib-1.0
1 to upgrade, 0 to newly install, 10 to remove and 1 not to upgrade.
Need to get 21.5 kB of archives.
After this operation, 3,412 kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

tags: added: yakkety
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Changed in apturl (Ubuntu):
status: New → Confirmed
Changed in nautilus-share (Ubuntu):
status: New → Confirmed
Changed in packagekit (Ubuntu):
status: New → Confirmed
Changed in language-selector (Ubuntu):
status: New → Confirmed
Changed in sessioninstaller (Ubuntu):
status: New → Confirmed
Changed in software-properties (Ubuntu):
status: New → Confirmed
Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Matthias Klumpp (ximion) wrote :

FWIW, just making Aptdaemon stop to pretend to be PackageKit and then adjust the dependent packages to not require the compat layer explicitly should also do the job.
(we did that at Debian, and right now, only one package still explicitly depends on Aptd (but that one is using Aptd-specific API)

no longer affects: language-selector (Ubuntu)
Amr Ibrahim (amribrahim1987) wrote :

I thought the plan would be to drop aptdaemon completely and port everything else to use packagekit. Debian already removed aptdaemon from unstable.

dino99 (9d9) on 2016-06-04
tags: added: xenial
removed: vivid
Changed in apturl (Ubuntu):
importance: Undecided → High
Changed in nautilus-share (Ubuntu):
importance: Undecided → High
Changed in sessioninstaller (Ubuntu):
importance: Undecided → High
Changed in system-config-printer (Ubuntu):
importance: Undecided → High
Changed in software-properties (Ubuntu):
importance: Undecided → High
dino99 (9d9) wrote :

aptdaemon (1.1.1+bzr982-0ubuntu15) yakkety; urgency=medium

  * debian/patches/drop_pkcompat.patch: don't call on pkcompat's PackageKit
    implementation. Instead, expect PackageKit to be DBus-activated so we can
    work correctly with PackageKit 1.1.1. (LP: #1496292)
  * debian/patches/pk1.1.1-compat.patch: remove API that is no longer there
    in PackageKit 1.1.1: GET_DEPENDS and GET_REQUIRES.
  * debian/control:
    - drop python3-aptdaemon.pkcompat binary package.
    - aptdaemon Breaks/Replaces python3-aptdaemon.pkcompat for transition.
    - Depends on gir1.2-packagekitglib-1.0 (>= 1.1.1) now, to enforce using
      PackageKit 1.1; which drops GET_DEPENDS and GET_REQUIRES.

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 06 Jun 2016 20:22:54 -0400

but system-config-printer is told to be removed due to python3-aptdaemon.pkcompat

dino99 (9d9) wrote :

Python3-aptdaemon.pkcompat nedds to be manually purged, accept system-config-printer to be purged too (for that first step).
Then aptdaemon* packages can be upgraded. Finally system-config-printer can be reinstalled (with some new dependencies).

The packages conflicts reported into comment #6 are now gone on yakkety.

tags: removed: yakkety
no longer affects: nautilus-share (Ubuntu)
no longer affects: apturl (Ubuntu)
no longer affects: software-properties (Ubuntu)
no longer affects: system-config-printer (Ubuntu)
no longer affects: sessioninstaller (Ubuntu)
Martin Pitt (pitti) wrote :

https://launchpad.net/ubuntu/+source/aptdaemon/1.1.1+bzr982-0ubuntu15 in yakkety-proposed says that it fixes this issue. However, it won't promote as long as this bug has "block-proposed", do we still need this even after this fix?

Changed in aptdaemon (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

I think it should be fine to unblock...

The only remaining unknown is whether the new packagekit might break click, snap or other such other software provider.

Sebastien Bacher (seb128) wrote :

the click backend is going to stop working but that was an understood and accepted regression, the touch team doesn't plan to base device on yakkety and was fine with that

tags: removed: block-proposed
Matthias Klumpp (ximion) wrote :

According to the proposed-updates Britney report, aptd and PK are still blocked (contact #ubuntu-release when update is needed).

Matthias Klumpp (ximion) wrote :

Obviously I don't mean proposed-updates, but proposed for Yakkety.

Sebastien Bacher (seb128) wrote :

the archive is frozen for alpha1 this week, otherwise there are some packages that need to be rebuilt to pick the packagekit soname which I planned to look at this week

Sebastien Bacher (seb128) wrote :

(well if anybody wants to work on that please do, I just noticed and I'm going to try a look tomorrow if that's still required)

Sebastien Bacher (seb128) wrote :

I've uploaded a few but somebody is going to have to upload click to drop the packagekit backend binary ... Ted do you think you could get that one done?

Changed in click (Ubuntu):
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

All of packagekit's rdepends that depended on the old soname have been rebuilt except packagekit-plugin-click. But to remove it, you'll also need to update its rdepends:

$ reverse-depends packagekit-plugin-click
Reverse-Depends
===============
* ubuntu-touch [amd64 arm64 armhf i386]
* unity8-desktop-session

Simon Quigley (tsimonq2) wrote :

This bug blocks the installation of the lubuntu-qt-desktop package, and we would like to have LXQt images spun up soon, so this is a high priority bug for the Lubuntu team.

Timo Jyrinki (timo-jyrinki) wrote :

Decision was made yesterday: https://irclogs.ubuntu.com/2016/08/08/%23ubuntu-release.html#t16:15

And now we can drop the packagekit-plugin-click which was the remaining blocker.

There is a silo for this at https://requests.ci-train.ubuntu.com/#/ticket/1775

Changed in ubuntu-touch-meta (Ubuntu):
importance: Undecided → High
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in unity8-desktop-session (Ubuntu):
importance: Undecided → High
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in ubuntu-touch-meta (Ubuntu):
status: New → In Progress
Changed in unity8-desktop-session (Ubuntu):
status: New → In Progress
Changed in click (Ubuntu):
assignee: Ted Gould (ted) → Timo Jyrinki (timo-jyrinki)
status: New → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

This in yakkety-proposed now, removing another blocker for transitions.

Remaining known blocker is WebP transition if you want to help: https://people.canonical.com/~ubuntu-archive/transitions/html/auto-libwebp.html

Changed in click (Ubuntu):
status: In Progress → Fix Committed
Changed in unity8-desktop-session (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-touch-meta (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8-desktop-session - 1.0.13+16.10.20160809-0ubuntu1

---------------
unity8-desktop-session (1.0.13+16.10.20160809-0ubuntu1) yakkety; urgency=medium

  * Drop dependency on packagekit-plugin-click. (LP: #1496292)

 -- Timo Jyrinki <email address hidden> Tue, 09 Aug 2016 11:22:18 +0000

Changed in unity8-desktop-session (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-touch-meta - 1.279

---------------
ubuntu-touch-meta (1.279) yakkety; urgency=medium

  * Refreshed dependencies
  * Removed packagekit-plugin-click from touch (LP: #1496292)

 -- Timo Jyrinki <email address hidden> Tue, 09 Aug 2016 14:44:42 +0300

Changed in ubuntu-touch-meta (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click - 0.4.44+16.10.20160811.1-0ubuntu1

---------------
click (0.4.44+16.10.20160811.1-0ubuntu1) yakkety; urgency=medium

  [ Colin Watson ]
  * Handle new policy URL in debsig-verify 0.15. (LP: #1608281)

 -- Timo Jyrinki <email address hidden> Thu, 11 Aug 2016 10:50:58 +0000

Changed in click (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.1.1+bzr982-0ubuntu15

---------------
aptdaemon (1.1.1+bzr982-0ubuntu15) yakkety; urgency=medium

  * debian/patches/drop_pkcompat.patch: don't call on pkcompat's PackageKit
    implementation. Instead, expect PackageKit to be DBus-activated so we can
    work correctly with PackageKit 1.1.1. (LP: #1496292)
  * debian/patches/pk1.1.1-compat.patch: remove API that is no longer there
    in PackageKit 1.1.1: GET_DEPENDS and GET_REQUIRES.
  * debian/control:
    - drop python3-aptdaemon.pkcompat binary package.
    - aptdaemon Breaks/Replaces python3-aptdaemon.pkcompat for transition.
    - Depends on gir1.2-packagekitglib-1.0 (>= 1.1.1) now, to enforce using
      PackageKit 1.1; which drops GET_DEPENDS and GET_REQUIRES.

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 06 Jun 2016 20:22:54 -0400

Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
Changed in packagekit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers