aptd crashed with AttributeError in __init__(): type object 'PkRoleEnum' has no attribute 'GET_DEPENDS'

Bug #1494891 reported by Роман on 2015-09-11
136
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Undecided
Unassigned
aptdaemon (Ubuntu)
Medium
Unassigned

Bug Description

no

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: aptdaemon 1.1.1+bzr982-0ubuntu8
ProcVersionSignature: Ubuntu 4.2.0-10.10-generic 4.2.0
Uname: Linux 4.2.0-10-generic x86_64
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
Date: Fri Sep 11 21:43:01 2015
ExecutablePath: /usr/sbin/aptd
InstallationDate: Installed on 2015-08-31 (10 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150826.1)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/sbin/aptd
ProcEnviron: LANG=C.UTF-8
PythonArgs: ['/usr/sbin/aptd']
SourcePackage: aptdaemon
Title: aptd crashed with AttributeError in __init__(): type object 'PkRoleEnum' has no attribute 'GET_DEPENDS'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Роман (sintespr) wrote :
tags: removed: need-duplicate-check
Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
Роман (sintespr) wrote :

no

information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed

Got it here!

Can't wait to finally upgrade to 16.04 ... Is there anyway to avoid this kind of errors ? Shouldn't it be tested before releasing it to the users?

Sebastien Bacher (seb128) wrote :

that was due to a packagekit update to 0.9.5, proposed migration blocked the version and it got deleted now, the bug is invalidated by that though it's going to be an issue again next time we try to update packagekit so maybe we should keep it as an action item to make it compatible with the new version

Changed in aptdaemon (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Flashrom (m-schult) wrote :

i dont hate the taskbar on the left side

Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
N1ck 7h0m4d4k15 (nicktux) wrote :

@kapil08dubey-w

are you sure this got "Fix Released" in Ubuntu ?
I just got an apport crash indicating this exact same problem with aptd.

Fresh install of 15.10 and recently full updated (on 20150927).

tags: added: regression-retracer
Chrescht (sekateur) wrote :

Am I supposed to understand any of the previous comments?

I am getting this bug every time I boot my pc.

Hi Chrescht,

Thanks for informing me.
Since Ubuntu was downloaded on my computer I had to put in a password
for a master password as well and all of a sudden the system don't allow
me to change it.

Who can create both passwords for me to go normally or help me to
discard Aptdaemon program please.

I will appreciate your help.

Regards,
Eddie Losper

On 13/12/2015 02:02, Chrescht wrote:
> Am I supposed to understand any of the previous comments?
>
> I am getting this bug every time I boot my pc.

> You received this bug notification because you are subscribed to
> Aptdaemon.
> https://bugs.launchpad.net/bugs/1494891
>
> Title:
> aptd crashed with AttributeError in __init__(): type object
> 'PkRoleEnum' has no attribute 'GET_DEPENDS'
>
> Status in Aptdaemon:
> New
> Status in aptdaemon package in Ubuntu:
> Fix Released
>
> Bug description:
> no
>
> ProblemType: Crash
> DistroRelease: Ubuntu 15.10
> Package: aptdaemon 1.1.1+bzr982-0ubuntu8
> ProcVersionSignature: Ubuntu 4.2.0-10.10-generic 4.2.0
> Uname: Linux 4.2.0-10-generic x86_64
> ApportVersion: 2.18.1-0ubuntu1
> Architecture: amd64
> Date: Fri Sep 11 21:43:01 2015
> ExecutablePath: /usr/sbin/aptd
> InstallationDate: Installed on 2015-08-31 (10 days ago)
> InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150826.1)
> InterpreterPath: /usr/bin/python3.4
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python3 /usr/sbin/aptd
> ProcEnviron: LANG=C.UTF-8
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with AttributeError in __init__(): type object 'PkRoleEnum' has no attribute 'GET_DEPENDS'
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups:
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aptdaemon/+bug/1494891/+subscriptions
>
>

Chrescht (sekateur) wrote :

Still getting the apport error every time I log in.
The system is fully updated (15.10).

Eddie Losper (losper-eddie) wrote :

On 23/01/2016 21:17, Chrescht wrote:
> Still getting the apport error every time I log in.
> The system is fully updated (15.10).
>
Hi Chrescht,

I fully deleted the program from my computer and don't have any problem
anymore.
Then I deleted Password as well as the other kind of password which gave
me the most trouble.
Then I reset just a normal password.
My problem be something of the past.

The only problem I have got now is when I print a message, it print the
following detail as well.
I have to get help to let it print normal:

*From - Fri Jan 22 16:23:53 2016 **
**X-Account-Key: account1 **
**X-UIDL: GmailId152680a1b8f0911e **
**X-Mozilla-Status: 0011 **
**X-Mozilla-Status2: 00000000 **
**X-Mozilla-Keys: **
**Delivered-To: **<email address hidden>****
**Received: by 10.107.56.67 with SMTP id f64csp665058ioa; **
** Thu, 21 Jan 2016 22:33:58 -0800 (PST) **
**X-Received: by 10.194.184.112 with SMTP id
et16mr1297121wjc.124.1453444438682; **
** Thu, 21 Jan 2016 22:33:58 -0800 (PST) **
**Return-Path: **<email address hidden>****
**Received: from as6.telkomsa.net (as.telkomsa.net. [196.25.211.37]) **
** by mx.google.com with ESMTP id
13si2614081wmo.15.2016.01.21.22.33.57 **
** for **<email address hidden>**; **
** Thu, 21 Jan 2016 22:33:58 -0800 (PST) **
**Received-SPF: pass (google.com: domain of
**<email address hidden>**designates 196.25.211.37 as permitted sender)
client-ip=196.25.211.37; **
**Authentication-Results: mx.google.com; **
** spf=pass (google.com: domain of
**<email address hidden>**designates 196.25.211.37 as permitted sender)
**<email address hidden>****
**Received: from unknown (HELO scorpius.telkomsa.net) ([192.168.111.56]) **
** by as6.telkomsa.net with ESMTP; 22 Jan 2016 08:33:57 +0200 **
**Received: from localhost (localhost.localdomain [127.0.0.1]) **
** by scorpius.telkomsa.net (Postfix) with ESMTP id 86816F805F **
** for **<email address hidden>**; Fri, 22 Jan 2016 08:33:57 +0200
(SAST) **
**X-Virus-Scanned: amavisd-new at scorpius.telkomsa.net **
**Received: from scorpius.telkomsa.net ([127.0.0.1]) **
** by localhost (scorpius.telkomsa.net [127.0.0.1]) (amavisd-new,
port 10024) **
** with ESMTP id LGXFUvLnh1ad for **<email address hidden>**; **
** Fri, 22 Jan 2016 08:33:57 +0200 (SAST) **
**Received: from mail4.telkomsa.net (zimbra4-vm1.lb2.telkomsa.net
[192.168.16.226]) **
** by scorpius.telkomsa.net (Postfix) with ESMTP id 7274AF8048 **
** for **<email address hidden>**; Fri, 22 Jan 2016 08:33:57 +0200
(SAST) **
**Date: Fri, 22 Jan 2016 08:33:57 +0200 (SAST) **
**From: **<email address hidden>****
**To: Eddie Losper **<email address hidden>****
**Message-ID:
**<email address hidden>****
**In-Reply-To: **<email address hidden>****
**Subject: Re: DONATION DEBIT ORDER FORM **
**MIME-Version: 1.0 **
**Content-Type: text/plain; charset=utf-8 **
**Content-Transfer-Encoding: 7bit **
**X-Originating-IP: [192.168.16.42] **
**X-Mailer: Zimbra 7.2.4_GA_2903 (ZimbraWebClient - FF3.0
(Win)/7.2.4_GA_2900) **

Regards,

Eddie
***

dazza5000 (darran-kelinske) wrote :

I am on 16.10 with all of the latest packages and get this every time I login. Is there a fix I can implement to keep this from happening? Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers