No longer able to install packages with PackageKit

Bug #1352654 reported by Justin McPherson on 2014-08-05
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Justin McPherson
Vivid
High
Unassigned
Wily
High
Justin McPherson

Bug Description

If you try to install with the cmdline tool (apt-get install packagekit-tools)

"""
justin@ubuntu:~$ pkcon install unity-webapps-reddit
Resolving [=========================]
Loading cache [=========================]
Finished [=========================]
Fatal error: The version 2.4.16+13.10.20130924.2-0ubuntu1/Ubuntu of unity-webapps-reddit isn't available.
"""

Use of the PackageKit API has the same results.

justin@ubuntu:~$ lsb_release -rd
Description: Ubuntu Utopic Unicorn (development branch)
Release: 14.10

Related branches

Justin McPherson (justinmcp) wrote :

Just a heads up; this still seems to be a problem.

affects: packagekit (Ubuntu) → aptdaemon (Ubuntu)
Changed in aptdaemon (Ubuntu):
assignee: nobody → Justin McPherson (justinmcp)
Changed in aptdaemon (Ubuntu Vivid):
status: New → Triaged
Changed in aptdaemon (Ubuntu Wily):
status: New → Triaged
importance: Undecided → High
Changed in aptdaemon (Ubuntu Vivid):
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

lp:~robert-ancell/aptdaemon/ubuntu-lp1352654 is a packaging branch with this change for wily.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.1.1+bzr982-0ubuntu9

---------------
aptdaemon (1.1.1+bzr982-0ubuntu9) wily; urgency=medium

  * Fix package installation by not considering the "data" which is bogus to
    pass to apt. (LP: #1352654)
  * Fix undefined NATIVE_ARCH by getting it from the worker.

 -- Iain Lane <email address hidden> Mon, 28 Sep 2015 18:10:56 +0100

Changed in aptdaemon (Ubuntu Wily):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers