Passwords aren't accepted anymore by PolicyKit

Bug #1090656 reported by Sebastian Heinlein on 2012-12-15
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Undecided
wwayland cullipher
policykit (Ubuntu)
Undecided
wwayland cullipher

Bug Description

Myself and plenty of others are posting pretty much the same question and no one is getting a reply. All you're saying is it must be us typing our passwords wrong but its NOT. Don't try putting the blame off because you don't know you're software or something. So, how about helping somebody out before people start removing your crap.

Sebastian Heinlein (glatzor) wrote :

Can you specify what you have done before? Did you perform an upgrade? Install a new Ubuntu version? Gets your password accepted when doing other administration tasks (e.g. adding a new user in the system preferences)? Do you use automatic login or do you login with in our password?

affects: aptdaemon → policykit (Ubuntu)
Changed in policykit (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Sebastian Heinlein (glatzor) wrote :

I changed the bug status to confirmed since there have been several questions about this.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Ken Jackson (aarius01) wrote :

I am very computer literate with any WINDOWS OS. Until last month I had never heard of UBUNTU. As but one of the growing number of very unhappy MICROSOFT/WINDOWS users In started looking for alternatives. Since my first PC in the mid 1990's I have never used a MAC or LINUX. My first impressions of UBUNTU were quite favorable. Right now I'm about ready to dump the whole idea.

After providing all requested information and more when I signed up with UBUNTU a couple of weeks ago, hand-writing all digital information as a backup, I am certain of my profile, user name and password. Just this instant I got a pop-up window indicating a problem was discovered with the question - did I want to report it? I always make every effort to make such sites as this user friendly so two-way communication is very important. I clicked on "YES", I was asked to authenticate and my CORRECTLY - as properly spelled, proper upper and lower case usage and SUBMIT - Iget a quick reply that my information was WRONG. NO - you have issues you are simply not addressing as the multiple almost identical questions are posted. How long would it take to research the BUG, write a fix for it and spend the time pounding out the lines of code then PUBLISHING it for everyone's use?

I speak, read and write Windows 7 Professional from log on to REG EDIT and back. Here, I have no idea what a"POLYCY KIT" is and an answer indicating that a "file should be written with "xxxxvvcvnsxc" looks just like that to me.

Two more days jumping through some weird to me hoops and I'm outta here! I would hang on if this well thought out posting was replied to in "1-2-3, A-B-C, so you're new to UBUNTU and LINUX, point your thinking in this direction and let's start with an everyday explanation of things you guys eat drink and sleep" and I'll gladly endure the training as I AM THE IGNORANT ONE HERE and hopefully can promote UBUNTU to a long list of friends and family who are devout and ever growing more resentful WINDOWS users.

affects: policykit (Ubuntu) → 2clickupdate
affects: aptdaemon (Ubuntu) → policykit (Ubuntu)

hey, everyone, when i said i solved my problem, thanks but i do not
want to keep wasting your time in here, i tried and tried to remove my
name from this email notice list for this one issue/event, i have
solved my password linux-update-caused password failure systemwide
linux-caused error, and i do not need any more emails about it, thank
you.

Quoting Sebastian Heinlein <email address hidden>:

> ** Also affects: aptdaemon
> Importance: Undecided
> Status: New
>
> ** Package changed: aptdaemon (Ubuntu) => policykit (Ubuntu)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1090656
>
> Title:
> Passwords aren't accepted anymore by PolicyKit
>
> Status in uCareSystem:
> Confirmed
> Status in Aptdaemon:
> New
> Status in “policykit” package in Ubuntu:
> Confirmed
>
> Bug description:
> Myself and plenty of others are posting pretty much the same question
> and no one is getting a reply. All you're saying is it must be us
> typing our passwords wrong but its NOT. Don't try putting the blame
> off because you don't know you're software or something. So, how about
> helping somebody out before people start removing your crap.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/2clickupdate/+bug/1090656/+subscriptions
>

DIET (gilou-galerne) on 2013-03-03
Changed in aptdaemon:
status: New → Confirmed
status: Confirmed → New
DIET (gilou-galerne) on 2013-03-03
Changed in aptdaemon:
status: New → Incomplete
status: Incomplete → Confirmed
Kevin Mogg (qq-kevin-mm) wrote :

  stop sending me this junk. i said to you many times i do not want
emails from this idiocy. end it. what is wrong with you?

Quoting DIET <email address hidden>:

> ** Changed in: aptdaemon
> Status: New => Incomplete
>
> ** Changed in: aptdaemon
> Status: Incomplete => Confirmed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1090656
>
> Title:
> Passwords aren't accepted anymore by PolicyKit
>
> Status in uCareSystem:
> Confirmed
> Status in Aptdaemon:
> Confirmed
> Status in “policykit” package in Ubuntu:
> Confirmed
>
> Bug description:
> Myself and plenty of others are posting pretty much the same question
> and no one is getting a reply. All you're saying is it must be us
> typing our passwords wrong but its NOT. Don't try putting the blame
> off because you don't know you're software or something. So, how about
> helping somebody out before people start removing your crap.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/2clickupdate/+bug/1090656/+subscriptions
>

Salih EMIN (salih-emin) on 2013-03-03
Changed in 2clickupdate:
status: Confirmed → Invalid
importance: High → Low
importance: Low → Undecided
no longer affects: 2clickupdate
Seth Arnold (seth-arnold) wrote :

Kevin, you are yelling at a robot. That may feel good but is not very productive. :)

You may manage your subscription preferences for this bug at http://bugs.launchpad.net/bugs/1090656 -- or using the link included in every bug email.

Brian Murray (brian-murray) wrote :

Do people who are experiencing this issue have their system configured for auto-login?

AJ (4-ah-d) wrote :

Brian
My brother was using a system with Ubuntu 11.1 on it! It wouldn't upgrade! It kept asking for a password. I went to pa and picked up the unit because he's MOVED on to a MAC (old one at that) He said he really liked Ubuntu but he could never get it to update.

I am the original guy who gave him the PC and Ubuntu 11.1 and he loved it (he's got a kid in college) he got his email and search the web, he even did reports and put them on SD card. and took them to work.

There are 196 updates waiting to be upgraded. Now he did tell me he had to down load the software and reinstall it and TOLD me he put NO PASSWORDS in. (I had configured it special for his video card-- it wouldn't work before but I went to help and they told me what to do)

aj

Brian Murray (brian-murray) wrote :

AJ - If could add the contents of the /etc/lightdm/lightdm.conf to this bug report that would help us determine what may be causing this.

James Hunt (jamesodhunt) wrote :

Can those affected by this issue confirm that:

- they are the only user logged into their system.
- they have not logged in as "guest".
- when the PolicyKit password prompt pops up that it definitely shows *their* username (it will show "password for <user>" to the left of the password box).

AJ (4-ah-d) wrote :

This is <email address hidden>
I installed Ubuntu on my brother's system a year ago... IT worked great! A few months ago he bought another computer and moved all his date to another computer and gave me back the computer. When I setup the computer I discovered that it would not update because it asked for a password. I ask my brother and he told me he never knew the password. SINCE I set it up, he thought I had the password. I NEVER setup a password! -- Since my brother was the only person to use the system, and I was the only person to set up the computer, NO passwords were ever established.

NOW when I tired to UPDATE the operating system and it kept asking for a password..... It was never updated. 196Megs --- one full year of updates--- So whatever is wrong could be ONE YEAR OLD! Now they told me that the Policy was no passwords-- and since they changed the policy sometime in 2012--- I figured I had to RE-INSTALL the entire program! I haven't done it yet! I put the computer on the shelf.

I am a website builder- I host websites -- I am retired Engineer! so I am not dumb! or stupid! I even use to build my own computers back in the 80's and 90's --- (they were too expensive)

that's it-- If you guys want me to try something-- send me instruction -- and I'll try it!
BUT if push comes to shove-- I'll just re-install the software.

AJ

Brian Murray (brian-murray) wrote :

We could use the information from the following commands:

1) The output of 'cat /etc/lsb-release'.
2) The output of the command groups
3) The contents of the file /etc/lightdm/lightdm.conf
4) The contents of the file /var/log/installer/syslog

You can add a file as an attachment to the bug report by clicking "Add attachment or patch" beneath the comment box in the web interface.

Do you happen to recall how you installed Ubuntu? The Ubuntu installer included with Ubuntu Live CDs should require you to enter a password. (I tested this with Ubuntu 11.10 and Ubuntu 12.04.1 and both of them did.)

Changed in policykit (Ubuntu):
status: Confirmed → Incomplete
Changed in aptdaemon:
status: Confirmed → New
Changed in policykit (Ubuntu):
status: Incomplete → Confirmed
Changed in aptdaemon:
status: New → Confirmed
Changed in policykit (Ubuntu):
status: Confirmed → New
christina sala (kay13464) wrote :

keeps asking for password when no passwords were put on here

Changed in aptdaemon:
status: Confirmed → New
status: New → Confirmed
Changed in policykit (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Christina can you answer my questions from comment #12?

affects: aptdaemon → ubuntu
Changed in ubuntu:
assignee: nobody → valerie (valeriecallahan36)
affects: ubuntu → aptdaemon (Ubuntu)
Changed in aptdaemon (Ubuntu):
assignee: valerie (valeriecallahan36) → nobody
Changed in aptdaemon (Ubuntu):
assignee: nobody → wwayland cullipher (cullipherw)
status: Confirmed → Fix Committed
Changed in policykit (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → wwayland cullipher (cullipherw)
Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
Changed in aptdaemon (Ubuntu):
status: Fix Released → Triaged
Changed in policykit (Ubuntu):
status: Fix Committed → Triaged
Brian Murray (brian-murray) wrote :

Sebastian, are we sure this is really about policykit and aptdaemon? The issues don't seem very well described to me and I recently discovered an issue with libgksu2-0 having its authentication mode set to su instead of sudo. This would affect gdebi which is also used to install and remove packages. Anyway, that's bug 1173013.

Anybody experiencing this bug may want to try the command 'gksu-properties', in a terminal, and see what the authentication mode is set to. If it is 'su' change it to 'sudo'. If you don't have gksu-properties installed then this isn't bug 1173013.

Sebastian Heinlein (glatzor) wrote :

Hello Brian,

Actually this bug is very mysterious to me. There are constantly popping
up questions in the Launchpad answers of aptdaemon. Since it is quite a
hurdle for new users to get from a detail in the policykit dialog that
mentions the name aptdaemon to the Launchpad answer site of the project,
I think that it could be a quite common error.

I have got no clue about the reason for this issue. I was hopping that
other projects would also get this error so that I could say that it
isn't an aptdaemon related problem :)

Cheers,

Sebastian

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers