aptd crashed with UnicodeDecodeError in _emit_acquire_item(): 'utf-8' codec can't decode byte 0x93 in position 1: invalid start byte

Bug #1060081 reported by Ivan Zelenovsky on 2012-10-02
116
This bug affects 25 people
Affects Status Importance Assigned to Milestone
apt (Debian)
Fix Released
Unknown
apt (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella
aptdaemon (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella

Bug Description

-

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: aptdaemon 0.45+bzr861-0ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Tue Oct 2 06:17:45 2012
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3.2 /usr/sbin/aptd
ProcEnviron:

PythonArgs: ['/usr/sbin/aptd']
SourcePackage: aptdaemon
Title: aptd crashed with UnicodeDecodeError in _emit_acquire_item(): 'utf-8' codec can't decode byte 0x93 in position 1: invalid start byte
UpgradeStatus: Upgraded to quantal on 2012-09-22 (9 days ago)
UserGroups:

Ivan Zelenovsky (nevem) wrote :
tags: removed: need-duplicate-check
Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-03-10
information type: Private → Public
Sebastian Heinlein (glatzor) wrote :

What language do you use?

English

On Sun, Mar 10, 2013 at 9:05 PM, Sebastian Heinlein <
<email address hidden>> wrote:

> What language do you use?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1060081
>
> Title:
> aptd crashed with UnicodeDecodeError in _emit_acquire_item(): 'utf-8'
> codec can't decode byte 0x93 in position 1: invalid start byte
>
> Status in “aptdaemon” package in Ubuntu:
> Confirmed
>
> Bug description:
> -
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.10
> Package: aptdaemon 0.45+bzr861-0ubuntu5
> ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
> Uname: Linux 3.5.0-16-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 2.6.1-0ubuntu1
> Architecture: amd64
> Date: Tue Oct 2 06:17:45 2012
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64
> (20110427.1)
> InterpreterPath: /usr/bin/python3.2mu
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python3.2 /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with UnicodeDecodeError in _emit_acquire_item():
> 'utf-8' codec can't decode byte 0x93 in position 1: invalid start byte
> UpgradeStatus: Upgraded to quantal on 2012-09-22 (9 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/1060081/+subscriptions
>
>

Sebastien Bacher (seb128) wrote :

e.u.c report on https://errors.ubuntu.com/problem/c1798b122284005da95af160f34062f4516a9e9f

trusty example
https://errors.ubuntu.com/oops/d153587c-b115-11e3-bf1a-fa163e707a72

"Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/aptdaemon/progress.py", line 185, in fetch
    self._emit_acquire_item(item)
  File "/usr/lib/python3/dist-packages/aptdaemon/progress.py", line 309, in _emit_acquire_item
    elif item.owner.mode:
UnicodeDecodeError: 'utf-8' codec can't decode bytes in position 3-4: invalid continuation byte"

LANG=C.UTF-8

Changed in aptdaemon (Ubuntu):
importance: Medium → High
tags: added: trusty

The same in Ubuntu 14.10: aptd crashes on DE(unity) start.

PSO (p-solaimani) wrote :

I had this same issue. I had at some point added Persian keyboard to my system. after going to "Language Support" -> "Install / Remove Languages..." and selecting "Persian" to install, the problem resolved. I don't remember whether I had added Persian keyboard during installation of Ubuntu or later on (I installed my system few days ago).

Vitaliy (tsvitaliy) on 2015-03-11
Changed in aptdaemon (Ubuntu):
assignee: nobody → Vitaliy (tsvitaliy)
assignee: Vitaliy (tsvitaliy) → nobody
blubber (blubber1698) wrote :

Happened to me in Ubuntu Gnome 15.04.

tags: added: vivid
Vitaliy (tsvitaliy) on 2015-03-17
Changed in aptdaemon (Ubuntu):
assignee: nobody → Vitaliy (tsvitaliy)

Happened to me in Ubuntu Gnome 15.04.

Same here upgraded today

Changed in apt (Debian):
status: Unknown → New

This crash appears to be caused by a bug in apt, see Debian bug https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=781858

Changed in apt (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Changed in apt (Ubuntu):
importance: Undecided → High

@ Vitaliy

Please, assign yourself to bugs only before starting to work on them.

Changed in aptdaemon (Ubuntu):
assignee: Vitaliy (tsvitaliy) → nobody
Changed in apt (Ubuntu):
status: Confirmed → Triaged
Changed in aptdaemon (Ubuntu):
status: Confirmed → Triaged

Somewhere during, before or after my current xorg or unity problems I am hitting this bug too according to apport.

Having read the background post from ~chris-bainbridge I can see that this will be a random crash. Unless there is any further information I can supply that will be of help, I will not add further comments or bugs in relation to this item.

I hit this today while using apt 1.0.1ubuntu2 for amd64 compiled on Aug 1 2015 19:20:48. The Debian bug says that this has been fixed in apt/1.1~exp4 and apt/1.0.9.8. Any chance of these getting pulled into Ubuntu LTS to avoid this ongoing crash?
Is there anything I could try and do on my system to avoid hitting this?

Tripped over this again today.

Eddie Losper (losper-eddie) wrote :

On 18/04/2016 15:22, Thomas A. F. Thorne wrote:
> Tripped over this again today.
>
What should I have to try to do from my side?
I know nothing about computer programs.

Eddie

Changed in apt (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.