PackageKit compatibility layer tests (tests/test_pk.py) fail if http_proxy is set

Bug #1050799 reported by Jean-Baptiste Lallement
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

The following PackageKit compatibility layer tests (tests/test_pk.py) fail if http_proxy is set whether no_proxy is set or not:
test_install_signature
test_install_signature_error
test_repo_enable_errors
test_unimplemented
test_what_provides_unsupported

Test log attached

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: aptdaemon 0.45+bzr861-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Fri Sep 14 10:01:47 2012
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: aptdaemon
SysLog:

UpgradeStatus: Upgraded to quantal on 2012-01-31 (226 days ago)

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
summary: - test_pk tests fail if http_proxy is set
+ PackageKit compatibility layer tests (tests/test_pk.py) tests fail if
+ http_proxy is set
summary: - PackageKit compatibility layer tests (tests/test_pk.py) tests fail if
+ PackageKit compatibility layer tests (tests/test_pk.py) fail if
http_proxy is set
Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
Changed in aptdaemon (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.0-0ubuntu1

---------------
aptdaemon (1.0-0ubuntu1) raring; urgency=low

  * New stable bug fix release 1.0:
    - Add PEP8 compliance and a corresponding test
    - Fix PackageKit tests if an http proxy is set (LP: #1050799)
    - Fix crash for Python GTK2 clients (LP: #1108552)
    - Fix crash if configuration file changes are only one line long -
      thanks to Barry Warsaw and Robert Collins (LP: #1120322)
    - Fix crash if the removal of a package valid candidate is simulated
    - Allow repository release names to include dots
    - Convert aptdaemon exceptions to PackageKit ones in the compat
      layer (currently only invalid input ant failed authorization are
      supported)
    - Store the default values in the PackageKit transaction interface
      statically typed
    - Fix setting the speed property in the PackageKit interface
    - Several grammar and typo fixes in user interface messages and
      documentation (LP: #1112492)
  * debian/patches:
    - fix-high-trust-pkcompat.diff: updated
    - apt-dbus-text-api.patch: updated
    - fix-gobject-io-add-watch.patch: Added. Always include the priority
      in a GLib.io_add_watch() call to not cause problems with the backwards
      compatibility

  [ Barry Warsaw ]
  * debian/control:
    - Add Build-Depend on gir1.2-gnomedesktop-3.0, gir1.2-vte-2.90, pep8,
      and xvfb.
    - Bump Standards-Version to 3.9.4.
  * debian/rules: Run the tests under xvfb-run to avoid core dumps.
  * debian/patches/pep8-fixes.patch: Fix PEP 8 violations.
  * debian/patches/lp1153725-temporary-workaround.patch: Temporarily
    disable two tests which fail during the build.
  * debian/rules:
    - Add the missing test directory and symlinks before running tests.
    - Clean up symlink directory in override_dh_auto_clean.
    - Sleep before the xvfb-run with a different Python version. Tear
      down of xvfb-run resources is apparently not immediate.
 -- Sebastian Heinlein <email address hidden> Mon, 11 Mar 2013 07:02:07 +0100

Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers