package libcap2-bin 1:2.22-1ubuntu3 failed to install/upgrade: libcap2-bin:i386 1

Bug #995225 reported by Stanley Elkins on 2012-05-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Kees Cook

Bug Description

On boot I got this error. Upgraded to the LST yesterday and wondering if all the pluggins are not ready

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libcap2-bin 1:2.22-1ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sat May 5 08:45:07 2012
DuplicateSignature:
 Unpacking libgpm2:i386 (from .../libgpm2_1.20.4-4_i386.deb) ...
 Selecting previously unselected package libcap2-bin:i386.
 dpkg: error processing /var/cache/apt/archives/libcap2-bin_1%3a2.22-1ubuntu3_i386.deb (--unpack):
  libcap2-bin:i386 1:2.22-1ubuntu3 (Multi-Arch: no) is not co-installable with libcap2-bin:amd64 1:2.22-1ubuntu3 (Multi-Arch: no) which is currently installed
ErrorMessage: libcap2-bin:i386 1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: libcap2
Title: package libcap2-bin 1:2.22-1ubuntu3 failed to install/upgrade: libcap2-bin:i386 1
UpgradeStatus: Upgraded to precise on 2012-05-04 (1 days ago)

Stanley Elkins (selk57) wrote :
tags: removed: need-duplicate-check

dpkg: error processing /var/cache/apt/archives/libcap2-bin_1%3a2.22-1ubuntu3_i386.deb (--unpack):
 libcap2-bin:i386 1:2.22-1ubuntu3 (Multi-Arch: no) is not co-installable with libcap2-bin:amd64 1:2.22-1ubuntu3 (Multi-Arch: no) which is currently installed

Serge Hallyn (serge-hallyn) wrote :

@Kees,

as the package changelog shows it has been multi-arched, why does the upgrade log show '(Multi-Arch: no)"? Confusing :)

Changed in libcap2 (Ubuntu):
assignee: nobody → Kees Cook (kees)
Steve Langasek (vorlon) wrote :

This would have been an apt bug; it never should have been trying to install libcap2-bin:i386 when the amd64 version was already installed.

affects: libcap2 (Ubuntu) → apt (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers