apt tries to unpack a Multi-Arch: no package for two architectures to satisfy the Recommends of a foreign-arch package

Bug #947639 reported by Ekoontz on 2012-03-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
APT
New
Undecided
Unassigned
apt (Ubuntu)
High
Unassigned
libvisual-plugins (Ubuntu)
High
Steve Langasek

Bug Description

Error encountered when trying to do a software update after an upgrade from 11.10(?) to 12.04

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libgudev-1.0-0 1:175-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
Date: Mon Mar 5 16:36:13 2012
DuplicateSignature:
 Setting up libselinux1:i386 (2.1.0-4.1ubuntu1) ...
 dpkg: error processing libudev0 (--configure):
  libudev0:amd64 175-0ubuntu5 cannot be configured because libudev0:i386 is in a different version (175-0ubuntu6)
ErrorMessage: libgudev-1.0-0:amd64 1
SourcePackage: udev
Title: package libgudev-1.0-0 1:175-0ubuntu5 failed to install/upgrade: libgudev-1.0-0:amd64 1
UpgradeStatus: Upgraded to precise on 2012-03-06 (0 days ago)

Ekoontz (ekoontz) wrote :
affects: ubuntu → udev (Ubuntu)
tags: removed: need-duplicate-check
Steve Langasek (vorlon) wrote :

The error here is:

dpkg: error processing libudev0 (--configure):
 libudev0:amd64 175-0ubuntu5 cannot be configured because libudev0:i386 is in a different version (175-0ubuntu6)
dpkg: error processing libudev0:i386 (--configure):
 libudev0:i386 175-0ubuntu6 cannot be configured because libudev0:amd64 is in a different version (175-0ubuntu5)
[...]
dpkg: error processing libgudev-1.0-0 (--configure):
 libgudev-1.0-0:amd64 1:175-0ubuntu5 cannot be configured because libgudev-1.0-0:i386 is in a different version (1:175-0ubuntu6)
dpkg: error processing libgudev-1.0-0:i386 (--configure):
 libgudev-1.0-0:i386 1:175-0ubuntu6 cannot be configured because libgudev-1.0-0:amd64 is in a different version (1:175-0ubuntu5)

However, this is part of a secondary run of apt attempting to clean up as many packages as possible following an earlier error; that earlier error is the root problem:

Selecting previously unselected package libvisual-0.4-plugins:i386.
dpkg: error processing /var/cache/apt/archives/libvisual-0.4-plugins_0.4.0.dfsg.1-5_i386.deb (--unpack):
 libvisual-0.4-plugins:i386 0.4.0.dfsg.1-5 (Multi-Arch: no) is not co-installable with libvisual-0.4-plugins:amd64 0.4.0.dfsg.1-5 (Multi-Arch: no) which is currently installed

Surprisingly, although libvisual-0.4-plugins installs to the multiarch path, it is not marked as Multi-Arch: same, resulting in this error when dpkg tries to unpack the package for both architectures.

What's not clear at all is why apt would try to do this when the package is not marked M-A: same.

affects: udev (Ubuntu) → libvisual-plugins (Ubuntu)
Changed in apt (Ubuntu):
importance: Undecided → High
Changed in libvisual-plugins (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Steve Langasek (vorlon)
Ekoontz (ekoontz) wrote :

Hi Steve,
Thanks for looking at it. Multiple Architecture and Packaging sounds difficult. I upgraded to 12 .04 from an ISO (fresh install), so this is not bugging me now.

Steve Langasek (vorlon) on 2012-03-10
Changed in libvisual-plugins (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvisual-plugins - 0.4.0.dfsg.1-7

---------------
libvisual-plugins (0.4.0.dfsg.1-7) unstable; urgency=low

  * QA upload.
  * Mark libvisual-0.4-plugins Multi-Arch: same, since it already ships its
    files in the right place. This lets the libvisual Recommends be
    satisfied correctly when installing for a foreign arch. LP: #947639.

 -- Steve Langasek <email address hidden> Fri, 09 Mar 2012 22:52:04 +0000

Changed in libvisual-plugins (Ubuntu):
status: In Progress → Fix Released
Steve Langasek (vorlon) on 2012-03-14
summary: - package libgudev-1.0-0 1:175-0ubuntu5 failed to install/upgrade:
- libgudev-1.0-0:amd64 1
+ apt tries to unpack a Multi-Arch: no package for two architectures to
+ satisfy the Recommends of a foreign-arch package
Rajiv Shah (compukid) on 2013-05-24
Changed in apt (Ubuntu):
status: New → Confirmed
no longer affects: apt
Rajiv Shah (compukid) on 2013-05-24
no longer affects: apt
Changed in apt:
status: Unknown → New
Daniel Hartwig (wigs) on 2013-05-26
Changed in apt:
importance: Unknown → Undecided
Axel Beckert (xtaran) on 2013-06-19
tags: added: multiarch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers