12.04 AMD64 Beta Live CD sources.list has a bad entry

Bug #945826 reported by Ben Rousch on 2012-03-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
High
Colin Watson
apt (Ubuntu)
Medium
Unassigned

Bug Description

Performing an apt-get update on the Kubuntu 12.04 AMD64 Beta live CD reports a bad entry in /etc/apt/sources.list.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: apt 0.8.16~exp12ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CasperVersion: 1.304
Date: Sat Mar 3 19:59:37 2012
LiveMediaBuild: Kubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228.1)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: apt
UpgradeStatus: No upgrade log present (probably fresh install)

Ben Rousch (brousch) wrote :
Torsten Spindler (tspindler) wrote :

This seems to be the 12.04 CD itself, can you remove it via software sources and see if the problem goes away?

Ben Rousch (brousch) wrote :

If I remove the two CD entries in /etc/apt/sources.list then apt-get update works correctly.

Torsten Spindler (tspindler) wrote :

What happens if you add them via GUI or apt-cdrom add? Does the update command work then?

Brian Murray (brian-murray) wrote :

The two entries in /etc/apt/sources.list are:

deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Beta amd64 (20120301)]/ dists/precise/main/binary-i386/
deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Beta amd64 (20120301)]/ precise main restricted

and it is scripts/casper-bottom/41apt_cdrom that generates these lines so I'm moving the bug over to casper.

summary: - Kubuntu 12.04 AMD64 Beta Live CD sources.list has a bad entry
+ 12.04 AMD64 Beta Live CD sources.list has a bad entry
Changed in apt (Ubuntu):
status: New → Triaged
Changed in casper (Ubuntu):
status: New → Triaged
Changed in apt (Ubuntu):
importance: Undecided → Medium
Changed in casper (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Brian Murray (brian-murray) wrote :

And apt-cdrom says:

Skipping nonexistent file /cdrom/dists/precise/main/binary-amd64/Packages

The file on the CD is Packages.gz.

Brian Murray (brian-murray) wrote :

Possibly related to bug 924182

Steve Langasek (vorlon) wrote :

I think the bug here is a releases file for the cdrom apt source which lists 'Packages' but doesn't include it. In fact, when I look at the CD manifest, I don't see any Packages files at all on the image...

affects: casper (Ubuntu) → ubuntu-cdimage
Steve Langasek (vorlon) wrote :

fwiw this has been broken since before precise alpha-2.

Changed in apt (Ubuntu):
status: Triaged → In Progress
status: In Progress → Invalid
Steve Langasek (vorlon) wrote :

Ah, the .list manifest doesn't show Packages.gz files for some reason, but they are present on the actual CD.

So the problem is just with resolving the Packages.gz file from the Releases.

Steve Langasek (vorlon) wrote :

The Releases file shows:

MD5Sum:
 97ecff09a695f1460177843ff5d2b3e6 103 restricted/binary-amd64/Release
 6541d021d179f71faf4c6e648bef2bac 1417 restricted/binary-amd64/Packages.gz
 6f17e84edd26488358681be526e26ca3 3347 restricted/binary-amd64/Packages
 b6aa9a96c765bbd4202dae7dbaf18cc2 96 main/binary-i386/Release
 4a4dd3598707603b3f76a2378a4504aa 20 main/binary-i386/Packages.gz
 d41d8cd98f00b204e9800998ecf8427e 0 main/binary-i386/Packages
 846e0e856bcbf9b64d9119c8727cda8c 97 main/binary-amd64/Release
 6ef398509f423f5a55ae27e814061e59 9421 main/binary-amd64/Packages.gz
 94df072b9fc141997d475f4dc1a8ad27 29664 main/binary-amd64/Packages
[etc.]

So the Releases file looks correct, it's showing the checksums for both the uncompressed Packages file that's not included, and the Packages.gz. This is consistent with how it's done in the Ubuntu archive, where we also don't ship uncompressed Packages to the mirrors but include them in the Releases. So looks like this is an apt bug only.

Changed in apt (Ubuntu):
status: Invalid → Triaged
Changed in ubuntu-cdimage:
status: Triaged → Invalid
Changed in apt (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) wrote :

I can't reproduce this with today's daily build. Anyone else?

Colin Watson (cjwatson) wrote :

Ah, the current Ubuntu desktop amd64 build fails. Never mind ...

Steve Langasek (vorlon) on 2012-03-14
Changed in apt (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

There's definitely at least one cdimage bug here - restricted/binary-i386 is missing from the CD and shouldn't be.

Changed in ubuntu-cdimage:
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Invalid → Triaged
Colin Watson (cjwatson) wrote :

revno: 1758
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Wed 2012-03-14 16:56:26 +0000
message:
  only remove empty */debian-installer/binary-*/Packages from live CDs; trying to remove other empty Packages files is fragile and not worth it (LP: #945826)

Changed in ubuntu-cdimage:
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :
Download full text (5.0 KiB)

OK, so this is better, but now I get:

Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/main/binary-i386/ InRelease
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/restricted/binary-i386/ InRelease
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) precise InRelease
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/main/binary-i386/ Release.gpg
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/restricted/binary-i386/ Release.gpg
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/main/binary-i386/ Release
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/restricted/binary-i386/ Release
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/main/binary-i386/ Packages/DiffIndex
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/restricted/binary-i386/ Packages/DiffIndex
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/main/binary-i386/ Translation-en_US
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/main/binary-i386/ Translation-en
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/restricted/binary-i386/ Translation-en_US
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) dists/precise/restricted/binary-i386/ Translation-en
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) precise/main TranslationIndex
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) precise/restricted TranslationIndex
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) precise/main Translation-en_US
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) precise/main Translation-en
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) precise/restricted Translation-en_US
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha amd64 (20120315) precise/restricted Translation-en
Ign http://security.ubuntu.com precise-security InRelease
Ign http://archive.ubuntu.com precise InRelease
Ign http://archive.ubuntu.com precise-updates InRelease
Hit http://security.ubuntu.com precise-security Release.gpg
Hit http://security.ubuntu.com precise-security Release
Hit http://archive.ubuntu.com precise Release.gpg
Hit http://archive.ubuntu.com precise-updates Release.gpg
Hit http://security.ubuntu.com precise-security/main amd64 Packages
Hit http://archive.ubuntu.com precise Release
Hit http://archive.ubuntu.com precise-updates Release
Hit http://archive.ubuntu.com precise/main amd64 Packages
Hit http://security.ubuntu.com precise-security/restricted amd64 Packages
Hit http://archive.ubuntu.com precise/restricted amd64 Packages
Hit http://archive.ubuntu.com precise/main i386 Packages
Hit http://security.ubuntu.com precise-security/main i386 Packages
Hit http://archive.ubuntu.com precise/restricted i386 Packages
Hit http://security.ubuntu.com precise-...

Read more...

Colin Watson (cjwatson) wrote :

FWIW I think Medium is correct for this now; it's just a warning rather than an error. It would certainly be good to fix this but it shouldn't block release or anything, unless somebody spots something that this actively breaks.

Changed in ubuntu-cdimage:
importance: Medium → High
Colin Watson (cjwatson) on 2014-12-18
Changed in apt (Ubuntu):
assignee: Colin Watson (cjwatson) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers