Comment 14 for bug 924079

do-release-upgrade uses python-apt, not apt. Sorry for being unclear;
try upgrading python-apt as well.