installation process can crash due to an issue with one package when choosing "install updates" as part of the install

Bug #922949 reported by lakshyavision on 2012-01-28
206
This bug affects 28 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Canonical Foundations Team
Precise
High
Canonical Foundations Team
ubiquity (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

The installation of process of Ubuntu crashed due to encountering a corrupted package when downloaiding packages from the internet. This can be due to failing memory on the system trying to install Ubuntu.

One possible workaround may be to install Ubuntu and choosing not to install 3rd party software or updates and install updates after the installation succeeds. [cjwatson: I think this is unlikely to be a possible workaround in these cases, based on the logs.]

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.5
ProcVersionSignature: Ubuntu 3.2.0-2.5-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CasperVersion: 1.292
Date: Sat Jan 28 08:47:59 2012
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111129.1)
ProcEnviron:
 LANGUAGE=en_IN
 PATH=(custom, no user)
 LANG=en_INSourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

lakshyavision (lakshyavision14) wrote :
affects: ubuntu → ubiquity (Ubuntu)

Exception during installation:
Jan 28 03:17:46 ubuntu plugininstall.py: SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Jan 28 03:17:46 ubuntu plugininstall.py:

tags: added: installer-crash

Jan 28 03:17:27 ubuntu ubiquity: dpkg-deb (subprocess): data: internal bzip2 read error: 'DATA_ERROR'
Jan 28 03:17:27 ubuntu ubiquity: dpkg-deb: error: subprocess <decompress> returned error exit status 2
Jan 28 03:17:27 ubuntu ubiquity: dpkg: error processing /target/var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu4_i386.deb (--unpack):
Jan 28 03:17:27 ubuntu ubiquity: short read on buffer copy for backend dpkg-deb during `./usr/lib/libreoffice/program/libooxlo.so'
Jan 28 03:17:27 ubuntu ubiquity: No apport report written because MaxReports is reached already

summary: - installer carshed
+ installer crashed due to a corrupted package

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
description: updated
summary: - installer crashed due to a corrupted package
+ installation process can crash due to an issue with one package when
+ choosing to install updates
Changed in ubiquity (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Steve Langasek (vorlon) on 2012-03-26
tags: added: rls-mgr-p-tracking
Changed in ubiquity (Ubuntu):
importance: Medium → High
summary: installation process can crash due to an issue with one package when
- choosing to install updates
+ choosing to install updates as part of the install
Steve Langasek (vorlon) on 2012-03-27
summary: installation process can crash due to an issue with one package when
- choosing to install updates as part of the install
+ choosing "install updates" as part of the install
tags: added: rls-p-tracking
Changed in ubiquity (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Tessa (unit3) wrote :

My bug just got marked as a dupe of this one. I'd like to note two observations:

- I'd explicitly unchecked "install updates during install". I've noticed for the past 2-3 releases that Ubiquity completely ignores what you tell it in this regard and downloads updates during the install process anyway.
- If Ubiquity sees that a package doesn't match the checksum, why doesn't it wipe it out and try to re-download it, rather than just crashing?

Colin Watson (cjwatson) wrote :

It doesn't actually have anything directly to do with "install updates during install". This isn't downloading updates, it's downloading language packs.

Checking package checksums is supposed to be apt's responsibility, not ubiquity's. apt normally *does* check the checksum, and in my tests a proxy that deliberately corrupts packages on the way through causes an exception to be raised, which at worst ought to cause ubiquity to display an error message but continue largely normally. This isn't happening in the cases in this bug and its duplicates. Rather than adding another layer of error checking which duplicates a layer of error checking that's supposed to be there already, I would like to figure out why the current layer of error checking isn't working.

Colin Watson (cjwatson) on 2012-04-10
description: updated
Colin Watson (cjwatson) wrote :

There isn't even a particularly straightforward interface for ubiquity to double-check the checksums itself. I think this can only be sensibly handled as an apt bug.

affects: ubiquity (Ubuntu Precise) → apt (Ubuntu Precise)
Changed in apt (Ubuntu Precise):
assignee: Colin Watson (cjwatson) → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) wrote :

Actually, while I do still think this is an apt bug, I've found a workaround in ubiquity which doesn't seem too unreasonable; the effect will be that any corrupted downloads will be removed and the entire set of packages currently attempting to be installed will be skipped; that will normally mean language packs don't get installed, which is not ideal but not a showstopper. I think that will be enough to let me take this off the rls-p-tracking list.

Changed in ubiquity (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.12

---------------
ubiquity (2.10.12) precise-proposed; urgency=low

  * Fix download verification to handle epochs correctly, and add a little
    more logging so that we can debug any further errors along these lines.
  * GTK frontend:
    - Disable WebKit's cache, since the slideshow doesn't have a significant
      browsing interface and the cache is memory-hungry. This may help with
      LP #979350.
 -- Colin Watson <email address hidden> Fri, 13 Apr 2012 19:49:13 +0100

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Released
Colin Watson (cjwatson) on 2012-04-13
tags: removed: rls-mgr-p-tracking rls-p-tracking
tags: added: rls-p-nottracking
Brian Murray (brian-murray) wrote :

This is the relevant changelog entry:

ubiquity (2.10.11) precise-proposed; urgency=low

  * Work around occasional undetected download errors in apt by doing our
    own verification pass before trying to install packages (LP: #922949).
  * Update translations from Launchpad.

 -- Colin Watson <email address hidden> Fri, 13 Apr 2012 17:16:33 +0100

AuriX (aurelio-giovanardi) wrote :

The installer crashed trying to reinstall previous applications, while migrating from 12.04 LTS

To post a comment you must log in.