Lucid Desktop i386 failed to calculate the upgrade to Precise

Bug #922485 reported by Jean-Baptiste Lallement on 2012-01-27
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Debian)
Fix Released
Unknown
apt (Ubuntu)
High
Colin Watson
Lucid
Medium
Colin Watson
Oneiric
Medium
Colin Watson
Precise
High
Colin Watson
release-upgrader-apt (Ubuntu)
Undecided
Unassigned
Lucid
High
Colin Watson
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
release-upgrader-python-apt (Ubuntu)
Undecided
Unassigned
Lucid
High
Colin Watson
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Automated Upgrade Test: Lucid Desktop i386
https://jenkins.qa.ubuntu.com/view/Precise%20Upgrade%20Testing%20Dashboard/job/precise-upgrade-lucid-desktop/

Since Jan. 24, Lucid Desktop i386 failed to calculate the upgrade to upgrade to Precise.

Logs attached

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.1
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
ApportVersion: 1.91-0ubuntu1
Aptdaemon:

Architecture: amd64
Date: Fri Jan 27 10:22:19 2012
EcryptfsInUse: Yes
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1325663980
 com.ubuntu.update-manager show-details true
 com.ubuntu.update-manager window-height 671
 com.ubuntu.update-manager window-width 600
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
tags: added: dist-upgrade lucid2precise qa-daily-testing
Colin Watson (cjwatson) wrote :

I believe this is an apt bug. The resolver is working on xserver-xorg-core Breaks: xserver-xorg-video-6, and runs over its loop limit before it manages to finish. This is because it's spending one iteration of the master resolver loop per provider of xserver-xorg-video-6, when it could clear them all up in a single iteration. I believe that this is an anomaly in apt's handling of Breaks vs. Conflicts, as Conflicts do appear to cause it to try multiple providers in a single iteration of the master resolver loop.

I'm working on a patch for this now.

affects: update-manager (Ubuntu) → apt (Ubuntu)
Changed in apt (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Triaged
Colin Watson (cjwatson) on 2012-01-28
Changed in apt (Ubuntu):
status: Triaged → In Progress
Changed in apt (Debian):
status: Unknown → New
Colin Watson (cjwatson) on 2012-01-29
Changed in release-upgrader-apt (Ubuntu Precise):
status: New → Invalid
Changed in apt (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Changed in release-upgrader-apt (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :
Download full text (8.0 KiB)

This bug was fixed in the package apt - 0.8.16~exp12ubuntu1

---------------
apt (0.8.16~exp12ubuntu1) precise; urgency=low

  [ Michael Vogt ]
  * merge from debian/experimental:
    - new ABI

  [ Steve Langasek ]
  * apt-pkg/algorithms.cc: iterate Breaks the same way as Conflicts, so that
    we resolve virtual package Breaks more effectively. Thanks to Colin
    Watson for the patch. Closes: #657695, LP: #922485.
  * apt-pkg/algorithms.{cc,h}: use an int to represent resolver scores, not
    a signed short, because large upgrades can result in an overflow for
    core packages. Thanks again to Colin Watson. Closes: #657732,
    LP: #917173.
  * Multi-Arch: none build-deps should be DEB_HOST_ARCH, not DEB_BUILD_ARCH.
    Closes: #646288.

apt (0.8.16~exp12) experimental; urgency=low

  [ Michael Vogt ]
  * apt-pkg/deb/dpkgpm.cc:
    - fix segfault on pkg removal

  [ David Kalnischkies ]
  * apt-pkg/cacheiterators.h:
    - return the correct version arch for all+foreign, too
  * apt-pkg/packagemanager.cc:
    - ignore breaks on not-installed versions while searching for
      breakage loops as we don't have to avoid them
  * debian/control:
    - remove APT from the short descriptions as lintian doesn't like it
      and it doesn't transport any information for a reader anyway
    - apply typofixes by Pascal De Vuyst, thanks! (Closes: #652834, #652835)
  * debian/rules:
    - apply patch to enable usage of hardning CPPFLAGS and LDFLAGS by
      Moritz Muehlenhoff, thanks! (Closes: #653504)
  * methods/https.cc:
    - use curls list append instead of appending Range and If-Range by hand
      which generates malformed requests, thanks Mel Collins for the hint!
      (Closes: #646381)
  * test/libapt/run-tests:
    - hurd doesn't have dmesg yet and we don't really need it either,
      so use with $0 a more stable data source for hashsumming

  [ Pino Toscano ]
  * test/libapt/globalerror_test.cc:
    - errno 0 has a different strerror on hurd, so generate the expected
      message dynamically instead of hardcoding 'Success' (Closes: #656530)

apt (0.8.16~exp11) experimental; urgency=low

  [ David Kalnischkies ]
  * apt-pkg/deb/dpkgpm.cc:
    - redirect out/input of dpkg --assert-multi-arch to /dev/null
    - if multi-arch is detected ensure that pkg:all is reported as pkg:all

apt (0.8.16~exp10) experimental; urgency=low

  [ David Kalnischkies ]
  * apt-pkg/depcache.cc:
    - implicit conflicts (for multiarch) are supposed to conflict
      only with real packages, not with virtual providers
  * apt-pkg/pkgcache.cc:
    - ignore implicit conflicts on providers in AllTarget, too
  * apt-pkg/deb/dpkgpm.cc:
    - check if dpkg supports multiarch with --assert-multi-arch
      and if it does be always explicit about the architecture
  * apt-pkg/contrib/fileutl.h:
    - store the offset in the internal fd before calculate size of
      the zlib-handled file to jump back to this place again

  [ Michael Vogt ]
  * apt-pkg/contrib/fileutl.h:
    - fix segfault triggered by the python-apt testsuite

apt (0.8.16~exp9) experimental; urgency=low

  [ Julian Andres Klode ]
  * apt-pkg/cdrom.cc:
    - Accept .bz2, .xz files in addition to .gz fil...

Read more...

Changed in apt (Ubuntu Precise):
status: In Progress → Fix Released
Colin Watson (cjwatson) on 2012-01-30
Changed in release-upgrader-python-apt (Ubuntu Lucid):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Triaged
Changed in release-upgrader-python-apt (Ubuntu Precise):
status: New → Invalid
Changed in release-upgrader-apt (Ubuntu Oneiric):
status: New → Invalid
Changed in release-upgrader-python-apt (Ubuntu Oneiric):
status: New → Invalid
Changed in apt (Ubuntu Oneiric):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
status: New → Triaged

Hello Jean-Baptiste, or anyone else affected,

Accepted release-upgrader-apt into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in release-upgrader-apt (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in release-upgrader-python-apt (Ubuntu Lucid):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Hello Jean-Baptiste, or anyone else affected,

Accepted release-upgrader-python-apt into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Upgrade from Lucid Desktop to Precise with the version from -updates:
https://jenkins.qa.ubuntu.com/job/precise-upgrade-lucid-desktop/9/
amd64: PASS
i386: FAIL

Upgrade from Lucid Desktop to Precise with the version from -proposed:
https://jenkins.qa.ubuntu.com/job/precise-upgrade-lucid-desktop/11/
amd64: FAIL
i386: FAIL

They both fail with the following error:
Processing triggers for man-db ...
dpkg: error processing dpkg (--configure):
 package dpkg is already installed and configured

Maybe it triggers another bug in apt but the version in -proposed doesn't improve the situation. Marking as verification-failed.

tags: added: verification-failed
removed: verification-needed

On the other side lucid main upgrades while it was failing with version of release-upgrader in -updates
https://jenkins.qa.ubuntu.com/job/precise-upgrade-lucid-main/

Colin Watson (cjwatson) wrote :

Thanks. I've reproduced this secondary failure locally; I'll work on it ASAP.

Colin Watson (cjwatson) wrote :

This appears to have something to do with the rearrangement of lzma and xz-lzma under the feet of dpkg's Pre-Depends (and possibly a separate bug that apt is trying to configure dpkg when it wasn't able to unpack it). However, 'apt-get dist-upgrade' with precise's apt works, so I'm currently trying to figure out what's different, assuming I haven't just made a silly mistake.

Martin Pitt (pitti) wrote :

Hello Jean-Baptiste, or anyone else affected,

Accepted apt into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in apt (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Hello Jean-Baptiste, or anyone else affected,

Accepted apt into lucid-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in apt (Ubuntu Lucid):
status: Triaged → Fix Committed

I verified that the versions in -proposed fixed the issue.

lucid desktop upgrade results with -proposed enabled on i386 and amd64
https://jenkins.qa.ubuntu.com/view/Precise%20Upgrade%20Testing%20Dashboard/job/precise-upgrade-lucid-desktop/ARCH=i386,LTS=lts,PROFILE=ubuntu,label=upgrade-test/18/

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package release-upgrader-apt - 0.8.16~exp12ubuntu1~upgrader1

---------------
release-upgrader-apt (0.8.16~exp12ubuntu1~upgrader1) lucid-proposed; urgency=low

  * Backport apt libraries from precise to lucid to make multiarch-enabled
    upgrades work.

apt (0.8.16~exp12ubuntu1) precise; urgency=low

  [ Michael Vogt ]
  * merge from debian/experimental:
    - new ABI

  [ Steve Langasek ]
  * apt-pkg/algorithms.cc: iterate Breaks the same way as Conflicts, so that
    we resolve virtual package Breaks more effectively. Thanks to Colin
    Watson for the patch. Closes: #657695, LP: #922485.
  * apt-pkg/algorithms.{cc,h}: use an int to represent resolver scores, not
    a signed short, because large upgrades can result in an overflow for
    core packages. Thanks again to Colin Watson. Closes: #657732,
    LP: #917173.
  * Multi-Arch: none build-deps should be DEB_HOST_ARCH, not DEB_BUILD_ARCH.
    Closes: #646288.
 -- Colin Watson <email address hidden> Mon, 30 Jan 2012 10:21:37 +0000

Changed in release-upgrader-apt (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package release-upgrader-python-apt - 0.8.0ubuntu9~upgrader3

---------------
release-upgrader-python-apt (0.8.0ubuntu9~upgrader3) lucid-proposed; urgency=low

  * Rebuild against latest release-upgrader-apt (LP: #917173, #922485).
 -- Colin Watson <email address hidden> Mon, 30 Jan 2012 13:09:09 +0000

Changed in release-upgrader-python-apt (Ubuntu Lucid):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

FWIW I think the previous problem (comments 11-13) was transient in some way. I could reproduce it locally for a while, but then it went away, presumably due to some change in precise.

There may be some latent problem here, but I think for the time being we can work on the assumption that it's independent of this change.

Martin Pitt (pitti) wrote :

Resetting verification tag for apt itself. This needs to be verified with apt-get dist-upgrade, which would also provide a nice regression test.

tags: added: verification-needed
removed: verification-done

SRU verification for Lucid:
I have reproduced the problem with apt 0.7.25.3ubuntu9.9 in lucid-updates, apt-get dist-upgrade stops on x11-common. Trying to continue the upgrade fails with an error "pkgProblemResolver::Resolve generated breaks"

I have verified that the version of apt 0.7.25.3ubuntu9.10 in -proposed fixes the issue and the system can be upgraded with a dist-upgrade.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.7.25.3ubuntu9.10

---------------
apt (0.7.25.3ubuntu9.10) lucid-proposed; urgency=low

  * apt-pkg/algorithms.cc: Iterate Breaks the same way as Conflicts, so that
    we resolve virtual package Breaks more effectively (LP: #922485).
  * apt-pkg/algorithms.{cc,h}: Use an int to represent resolver scores, not
    a signed short, because large upgrades can result in an overflow for
    core packages (LP: #917173).
 -- Colin Watson <email address hidden> Mon, 30 Jan 2012 13:35:04 +0000

Changed in apt (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in apt (Debian):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

Hello Jean-Baptiste, or anyone else affected,

Accepted apt into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.16~exp5ubuntu13.3

---------------
apt (0.8.16~exp5ubuntu13.3) oneiric-proposed; urgency=low

  [ Jean-Louis Dupond ]
  * Backport fixes from precise verison of apt, to fix multiarch upgrades
    from oneiric.
  * apt-pkg/depcache.cc:
    - prefer native providers over foreigns even if the chain is foreign.
      (LP: #850264)
  * cmdline/apt-get.cc:
    - ignore foreign architectures if we check if a provides has only one
      resolver as it's basically the same for the user, so no need to choose.
  * apt-pkg/deb/deblistparser.cc:
    - M-A: foreign packages provide for other archs, too

  [ Colin Watson ]
  * Include 0.8.16~exp5ubuntu13.1 patches.
  * apt-pkg/algorithms.cc: Iterate Breaks the same way as Conflicts, so that
    we resolve virtual package Breaks more effectively (LP: #922485).
  * apt-pkg/algorithms.{cc,h}: Use an int to represent resolver scores, not
    a signed short, because large upgrades can result in an overflow for
    core packages (LP: #917173).
 -- Jean-Louis Dupond <email address hidden> Tue, 17 Apr 2012 14:43:00 +0200

Changed in apt (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.