dependencies are not properly resolved

Bug #878020 reported by Michael Neuffer on 2011-10-19
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

root@kyle:/tmp# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  empathy empathy-common ia32-libs libgcrypt11 libgcrypt11:i386 libgcrypt11-dev
  libgnomevfs2-0 libgnutls-dev libgnutls26 libgnutls26:i386 libhttpclient-ruby1.8
  libimobiledevice2 liblockfile-dev liblockfile1 libopenal1 libwildmidi1
  nautilus-sendto-empathy sshfs winetricks
0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.

root@kyle:/tmp# apt-get -f upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  empathy empathy-common ia32-libs libgcrypt11 libgcrypt11:i386 libgcrypt11-dev
  libgnomevfs2-0 libgnutls-dev libgnutls26 libgnutls26:i386 libhttpclient-ruby1.8
  libimobiledevice2 liblockfile-dev liblockfile1 libopenal1 libwildmidi1
  nautilus-sendto-empathy sshfs winetricks
0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
root@kyle:/tmp#

dselect makes the dependency chains a bit more visible.
It doesn't show any broken packages, only some unsatisfiable dependencies.
Some of the are real package bugs (sshfs/fuse) others are incorrectly handled
cross-architecture dependencies or versioning problems (libgtk2.0-0:i386
2.8.0 vs. 2.24.6-0ubuntu6)

ia32-libs depends on ia32-libs-multiarch
ia32-libs-multiarch does not appear to be available
sshfs depends on fuse (>= 2.7)
fuse does not appear to be available
nspluginwrapper depends on nspluginviewer (= 1.4.4-0ubuntu3)
nspluginviewer does not appear to be available

root@kyle:/tmp# apt-get dselect-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have unmet dependencies:
 nspluginviewer:i386 : Depends: libgtk2.0-0:i386 (>= 2.8.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
E: Internal error, problem resolver broke stuff

root@kyle:/tmp# apt-get install libgtk2.0-0:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgtk2.0-0:i386 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.

root@kyle:/tmp# dpkg -s libgtk2.0-0:i386
Package: libgtk2.0-0
Status: install ok installed
Multi-Arch: same
Priority: optional
Section: libs
Installed-Size: 6188
Maintainer: Ubuntu Desktop Team <email address hidden>
Architecture: i386
Source: gtk+2.0
Version: 2.24.6-0ubuntu6
Provides: gtk2.0-binver-2.10.0
Depends: libgtk2.0-common, libatk1.0-0 (>= 1.12.4), libc6 (>= 2.4), libcairo2 (>= 1.6.4-6.1), libcups2 (>= 1.4.0), libfontconfig1 (>= 2.8.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.29.6), libpango1.0-0 (>= 1.28.3-2~), libx11-6, libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6, libxinerama1, libxrandr2 (>= 2:1.2.99.3), libxrender1, shared-mime-info
Pre-Depends: multiarch-support
Recommends: hicolor-icon-theme, libgtk2.0-bin
Suggests: librsvg2-common, gvfs
Conflicts: appmenu-gtk (<< 0.1.3)
Conffiles:
 /etc/gtk-2.0/im-multipress.conf c358838e1789c1d4e6da7f525fc922cf
Description: The GTK+ graphical user interface library
 The GTK+ is a multi-platform toolkit for creating graphical user
 interfaces. Offering a complete set of widgets, the GTK+ is suitable
 for projects ranging from small one-off tools to complete application
 suites.
 .
 This package contains the shared libraries.
Homepage: http://www.gtk.org/
Original-Maintainer: Sebastien Bacher <email address hidden>

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: apt 0.8.16~exp5ubuntu13
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Wed Oct 19 10:57:29 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: apt
UpgradeStatus: No upgrade log present (probably fresh install)

Michael Neuffer (neuffer) wrote :
Bowmore (bowmore) wrote :

Does the updated source package p11-kit 0.7-2 (libp11-kit0, libp11-kit0:i386) solve your dependency issue?

On 10/20/2011 10:23 AM, Bowmore wrote:
> Does the updated source package p11-kit 0.7-2 (libp11-kit0,
> libp11-kit0:i386) solve your dependency issue?
>

Actually it causes the next problem....

I had to link
neuffer@kyle:/etc/pkcs11/modules$ ls -la /usr/lib/x86_64-linux-gnu/pkcs11
total 32
drwxr-xr-x 2 root root 4096 Oct 20 07:48 .
drwxr-xr-x 31 root root 24576 Oct 20 07:47 ..
lrwxrwxrwx 1 root root 39 Oct 20 07:48 gnome-keyring-pkcs11.so ->
/usr/lib/pkcs11/gnome-keyring-pkcs11.so

In order to be able to keep on working due to this new version.

Cheers
    Mike

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
userdce (userdce) wrote :

I get following message on Precise:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  ia32-libs-multiarch:i386
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

dazza5000 (darran-kelinske) wrote :

I am getting the same thing as userdce on 12.04:

Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  ia32-libs-multiarch:i386
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  ia32-libs-multiarch:i386
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

confiq (confiq) wrote :

I'm also getting:
_________________
The following packages have been kept back:
  ia32-libs-multiarch:i386
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
________________
After upgrading to 12.04

confiq (confiq) wrote :

I can't edit messages here, so I'll write new one...
You can resolve this by installing "ia32-libs-multiarch".

sudo apt-get install ia32-libs-multiarch

More on forums: http://ubuntuforums.org/showthread.php?t=1880965

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers