Ubuntu

can't apt-get install --reinstall when foreign-arch version is present (E: Internal Error, No file name for libgl1-mesa-glx)

Reported by Tommy_CZ on 2011-09-25
184
This bug affects 37 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Michael Vogt

Bug Description

*** Current workaround ***
As per comment #10, the workaround is to --reinstall the library on all architectures for which it's installed, e g:

sudo apt-get install --reinstall libgl1-mesa-glx:amd64 libgl1-mesa-glx:i386

***

Hi, I wanted to reinstall libgl1-mesa-glx because I cannot run KDE4.7.1 and synaptic and also apt-get using konsole gives me this:
"E: Internal Error, No file name for libgl1-mesa-glx"
It seems the package is not avaliable, right?
Thanks

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: apt 0.8.16~exp5ubuntu11
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Sun Sep 25 22:44:19 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
SourcePackage: apt
UpgradeStatus: Upgraded to oneiric on 2011-09-24 (1 days ago)

Tommy_CZ (t-kijas) wrote :
Brian Murray (brian-murray) wrote :

Actually it is available:

8:53:35 - flash:[/misc/music/radio/kissfm-ua] apt-cache policy libgl1-mesa-glx
libgl1-mesa-glx:
  Installed: 7.11-0ubuntu3
  Candidate: 7.11-0ubuntu3
  Version table:
 *** 7.11-0ubuntu3 0
        500 http://ubuntu.osuosl.org/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Could you please post the full syntax of the command and its output so we can better assist you? Thanks in advance.

Changed in apt (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Brian Pitts (bpitts) wrote :

This error also occurs for me. The command I ran was

$ sudo apt-get install --reinstall libgl1-mesa-glx
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/100 kB of archives.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for libgl1-mesa-glx

If I manually remove it via dpkg I can install it via apt-get, but a subsequent reinstall still fails.

$ sudo dpkg -r --ignore-depends libgl1-mesa-glx libgl1-mesa-glx
(Reading database ... 267991 files and directories currently installed.)
Removing libgl1-mesa-glx ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

bdp@date:~$ sudo apt-get install libgl1-mesa-glx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  libgl1-mesa-glx
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/100 kB of archives.
After this operation, 524 kB of additional disk space will be used.
Selecting previously deselected package libgl1-mesa-glx.
(Reading database ... 267989 files and directories currently installed.)
Unpacking libgl1-mesa-glx (from .../libgl1-mesa-glx_7.11-0ubuntu3_amd64.deb) ...
Setting up libgl1-mesa-glx (7.11-0ubuntu3) ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

$ sudo apt-get install --reinstall libgl1-mesa-glx
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/100 kB of archives.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for libgl1-mesa-glx

I started down this path because I uninstalled fglrx and after rebooting I received the error "/usr/lib/nux/unity_support_test: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory"

Tommy_CZ (t-kijas) wrote :

My output:
tom@tom-AO722:~$ sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Následující balík byl nainstalován automaticky a již není potřeba:
  libllvm2.9:i386
Pro jejich odstranění použijte „apt-get autoremove“.
0 aktualizováno, 0 nově instalováno, 3 přeinstalováno, 0 k odstranění a 1 neaktualizováno.
Potřebuji stáhnout 2 916 kB/4 612 kB archivů.
Po této operaci bude na disku použito dalších 0 B.
Mám:1 http://cz.archive.ubuntu.com/ubuntu/ oneiric/main libgl1-mesa-dri amd64 7.11-0ubuntu3 [2 816 kB]
Mám:2 http://cz.archive.ubuntu.com/ubuntu/ oneiric/main libgl1-mesa-glx amd64 7.11-0ubuntu3 [100 kB]
Staženo 2 916 kB za 4s (597 kB/s)
E: Internal Error, No file name for libgl1-mesa-glx

Tommy_CZ (t-kijas) wrote :

I'm wondering why this has low importance... without this libgl we cannot even boot to KDE/Unity...

Changed in apt (Ubuntu):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

With the advent of multi-arch it is possible to have two versions of a package installed for example this package for i386 and adm64. When you are executing the --reinstall option it isn't clear for which architecture you want to reinstall the package. You can clarify this with the following command:

sudo apt-get install --reinstall libgl1-mesa-glx:amd64

jsubei (jsubei) wrote :

Same for me, clarify with specitiocation of the arch does not work :

uname -a
Linux norbert-Aspire-4820TG 3.0.0-12-generic #19-Ubuntu SMP Fri Sep 23 21:23:39 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

sudo apt-get install --reinstall libgl1-mesa-glx:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/100 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
E: Internal Error, No file name for libgl1-mesa-glx

jsubei (jsubei) wrote :

For me this occur after trying to install fglrx with jockey. The fglrx installation failled and after I have this problem with libgl

David Weber (wb-munzinger) wrote :

Same problem here with a lot of different packages. Shouldn't this be a blocker for release? A system isn't really usable at this state

Eugene Crosser (crosser) wrote :

Workaround that worked for me was to run

apt-get install --reinstall libgl1-mesa-glx:amd64 libgl1-mesa-glx:i386

so this is obviously a problem in the muli-arch support in apt, right?

Steve Langasek (vorlon) wrote :

Yes, this problem is specific to multiarch, and the workaround is to --reinstall the library on all architectures for which it's installed.

summary: - E: Internal Error, No file name for libgl1-mesa-glx
+ can't apt-get install --reinstall when foreign-arch version is present
+ (E: Internal Error, No file name for libgl1-mesa-glx)
tags: added: multiarch
Changed in apt (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Michael Vogt (mvo)

Unless you are unfortunate enough like me where the package affected was libc6 as it has defensive coding in the install scripts and refuses to reinstall. Ultimately you have to reinstall Ubuntu to get anywhere.

Eugene Crosser (crosser) wrote :

Does this bug have anything in common with Bug #863675? The recent fix for the latter did not fix this one, but it seems as if they could be related..

Message #10

 apt-get install --reinstall libgl1-mesa-glx:amd64 libgl1-mesa-glx:i386

did the trick for me. Gnome-shell is now working again

Alfagulf (alfagulf) wrote :

I am using a 64bit version of Ubuntu 11.10.

It did not work form me!!
It does not matter if I append :i386 or :amd64 or nothing, I keep getting the same error:
E: Internal Error, No file name for libgl1-mesa-glx

Any other ideas?

Thanks

Sal Mazzola (salmaz) wrote :

I am having the same problem. As a work around I did the following:

apt-get download libgl1-mesa-glx libgl1-mesa-dri
dpkg --install libgl1-mesa-*.deb

They both seem to have installed and are working.

Alfagulf (alfagulf) wrote :

I seem to have passed this issue by removing the :i386 version of the two application from the system.
I don't know if that was wise or not, but I was so desperate, I didn't care!!

 I did:
sudo apt-get remove libgl1-mesa-glx:i386 libgl1-mesa-dri:i386

Rocko (rockorequin) wrote :

You should only need the i386 versions if you running 32 bit applications, like wine.

The command in Message #14 fixed it for me, ie you have to specify both i386 and amd64 in the reinstall command line. But surely apt-get should do this automatically?

Florian Echtler (floe) wrote :

On amd64, same problem occurs for me with libqt4-dbus:

[1] $ sudo apt-get install --reinstall libqt4-dbus
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/171 kB of archives.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for libqt4-dbus
[100] $

None of the workarounds posted here seem to fix this. Consequently, BrokenCount is always > 0 and update-notifier displays an error.

Michael Berg (jaykaycgn) wrote :

holy shit, to find this bug i google'd for about an hour with a non working system. this bug doesnt seem to be prioritied "low".

this happend to me after uninstall fglrx from jockey. initial error message was "error while loading shared libraries: libGL.so.1" - and then i tried to reinstall the mesa driver........

Michael Berg (jaykaycgn) wrote :

ps. the workaround in #10 worked for me.
thanks :)

TBeholder (turbobeholder) wrote :

For me, some ( libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libglu1-mesa) are flagged in Synaptic as installed, but "installed files" lists are unavailable because packages are not installed, and an attempt to reinstall any of them causes "...link group x86_64-linux-gnu_gl_conf is broken" error - and nothing changes.
Others (libxrender1, libxrandr2, libxext6, libxft2, libxfixes3) give "E: Internal Error, No file name for <package name>".

Naturally, with most of its dependencies being such ghosts, fglrx works buggy (specific set depends on the version) when at all.

Britt Yazel (brittyboi) on 2011-10-29
description: updated
Stephan Diestelhorst (syon) wrote :

Same just happened for me with libqtgui4 and libstdc++6 (trying to install fglrx and trying to fix up all packages)

David Henningsson (diwic) wrote :

Raising severity due to the number of users affected.

description: updated
Changed in apt (Ubuntu):
importance: Low → High
Oren Bar (orenbaracha) wrote :

I checked and I have exact issue as TBeholder in #22.
I was just wandering, I did not do a clean install of 11.10, but upgraded all the way from 10.04.
If everyone here are on an upgraded version, then maybe its connected...

TBeholder (turbobeholder) wrote :

oh, and thx, the workaround with both arcs reinstalled from command line applied to everything in my list above seems to help - at least mostly.
No obvious GL failures.
There were rare fullscreen freezes, but i'm not sure it was this again and not an epic battle between screen composer from XFCE and Catalyst AI from fglrx or something like this.

Jstritar (jstritar) wrote :

This is really annoying, especially when you are using scripts that aren't that easy to edit. Maybe 'apt-get --reinstall' should handle all the installed architectures if not specified?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.16~exp12ubuntu2

---------------
apt (0.8.16~exp12ubuntu2) precise; urgency=low

  [ David Kalnischkies ]
  * apt-pkg/deb/dpkgpm.cc:
    - chroot if needed before dpkg --assert-multi-arch
    - ensure that dpkg binary doesn't have the chroot-directory prefixed
  * apt-pkg/depcache.cc:
    - if a M-A:same package is marked for reinstall, mark all it's installed
      silbings for reinstallation as well (LP: #859188)
  * apt-pkg/contrib/configuration.cc:
    - do not stop parent transversal in FindDir if the value is empty
  * methods/http{s,}.cc:
    - if a file without an extension is requested send an 'Accept: text/*'
      header to avoid that the server chooses unsupported compressed files
      in a content-negotation attempt (Closes: #657560)
  * apt-pkg/aptconfiguration.cc:
    - chroot if needed before calling dpkg --print-foreign-architectures

  [ Michael Vogt ]
  * apt-pkg/deb/dpkgpm.cc:
    - fix crash when a package is in removed but residual config state
      (LP: #923807)
 -- Michael Vogt <email address hidden> Mon, 30 Jan 2012 21:03:12 +0100

Changed in apt (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers