Ubuntu

aptd crashed with SIGSEGV in debListParser::LoadReleaseInfo()

Reported by tr33m4n on 2011-09-19
This bug affects 186 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Michael Vogt
Oneiric
High
Michael Vogt
aptdaemon (Ubuntu)
High
Michael Vogt
Oneiric
High
Michael Vogt
update-manager (Ubuntu)
Medium
Michael Vogt
Oneiric
Medium
Michael Vogt

Bug Description

Tried checking for new updates through the update manager and was told that the aptdaemon crashed. Upon retry it worked fine

Description: Ubuntu oneiric (development branch)
Release: 11.10

aptdaemon:
  Installed: 0.43+bzr697
  Candidate: 0.43+bzr697
  Version table:
 *** 0.43+bzr697 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: aptdaemon 0.43+bzr697
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Mon Sep 19 18:58:43 2011
DesktopFile: /usr/share/aptdaemon/aptdaemon.desktop
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/aptd
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0x7f5abedc2686 <_ZN13debListParser15LoadReleaseInfoERN8pkgCache15PkgFileIteratorER6FileFdSs+630>: mov %eax,(%r15)
 PC (0x7f5abedc2686) ok
 source "%eax" ok
 destination "(%r15)" (0x7f5ab9578b04) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: aptdaemon
StacktraceTop:
 debListParser::LoadReleaseInfo(pkgCache::PkgFileIterator&, FileFd&, std::string) () from /usr/lib/libapt-pkg.so.4.11
 debPackagesIndex::Merge(pkgCacheGenerator&, OpProgress*) const () from /usr/lib/libapt-pkg.so.4.11
 ?? () from /usr/lib/libapt-pkg.so.4.11
 pkgCacheGenerator::MakeStatusCache(pkgSourceList&, OpProgress*, MMap**, bool) () from /usr/lib/libapt-pkg.so.4.11
 pkgCacheFile::BuildCaches(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
Title: aptd crashed with SIGSEGV in debListParser::LoadReleaseInfo()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

tr33m4n (tr33m4n) wrote :
visibility: private → public

StacktraceTop:
 debListParser::LoadReleaseInfo (this=0x7fff6acb9ea0, FileI=..., File=<optimized out>, component=<optimized out>) at deb/deblistparser.cc:860
 debPackagesIndex::Merge (this=0x2bfaf20, Gen=<optimized out>, Prog=<optimized out>) at deb/debindexfile.cc:342
 BuildCache (Gen=..., Progress=0x7fff6acbafe0, CurrentSize=@0x7fff6acbaf00, TotalSize=83177485, Start=..., End=...) at pkgcachegen.cc:1067
 pkgCacheGenerator::MakeStatusCache (List=<optimized out>, Progress=0x7fff6acbafe0, OutMap=0x29bdf50, AllowMem=192) at pkgcachegen.cc:1261
 pkgCacheFile::BuildCaches (this=0x29bdf40, Progress=0x7fff6acbafe0, WithLock=<optimized out>) at cachefile.cc:80

Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Changed in apt (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Brad Needham (fishrcynic) wrote :

synaptic crashes quite regularly due to this

Robert Roth (evfool) wrote :

Raising the importance to High because of the high number of duplicates, as all packages using libapt seem to be affected.

Changed in aptdaemon (Ubuntu):
importance: Medium → High
Changed in apt (Ubuntu):
importance: Medium → High
Changed in aptdaemon (Ubuntu Oneiric):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → ubuntu-11.10
Colin Watson (cjwatson) on 2011-09-26
Changed in aptdaemon (Ubuntu Oneiric):
assignee: Canonical Foundations Team (canonical-foundations) → Michael Vogt (mvo)
Michael Vogt (mvo) wrote :

This started on 2011-09-20, that is the day when 0.8.16~exp5ubuntu10 got uploaded.

Michael Vogt (mvo) wrote :

But 0.8.16~exp5ubuntu10 got not accepted before the 22th, so that is unlikely.

Aptdaemon got update on the 19th to 0.43+bzr697 but the changes there do not look releated at all.

Michael Vogt (mvo) wrote :

Plus synaptic (e.g. bug #859355) is affected as well so its unlikely that aptd itself is the problem.

Can someone try to reproduce this problem using a terminal (e.g. gnome-terminal) please:
It would be nice to know if
$ sudo apt-cache gencaches -o Debug::pkgCacheGen=true
crashes.

Mad Maks (mad.maks) wrote :

$ sudo apt-cache gencaches -o Debug::pkgCacheGen=true

does not crash on my machine

On 26/09/11 11:14, Michael Vogt wrote:
> Plus synaptic (e.g. bug #859355) is affected as well so its unlikely
> that aptd itself is the problem.
>
> Can someone try to reproduce this problem using a terminal (e.g. gnome-terminal) please:
> It would be nice to know if
> $ sudo apt-cache gencaches -o Debug::pkgCacheGen=true
> crashes.
>
Did not crash for me. (Latest updates checked and applied imediately
before test).

sudo apt-cache gencaches -o Debug::pkgCacheGen=true

gives

...loads of lines simialr to those below...
en
(/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_natty_partner_i18n_Translation-en):
Has NO packages
Checking PkgFile http://archive.canonical.com/ubuntu/ natty/partner
Translation-en_GB
(/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_natty_partner_i18n_Translation-en%5fGB):
Has NO packages
Checking PkgFile /var/lib/dpkg/status: with ID 52 is valid
pkgcache.bin is valid - no need to build anything
Reading package lists... Done

Hope this helps

Chris

Michael Vogt (mvo) on 2011-09-26
Changed in apt (Ubuntu Oneiric):
status: Confirmed → In Progress
assignee: nobody → Michael Vogt (mvo)
Changed in aptdaemon (Ubuntu Oneiric):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.16~exp5ubuntu12

---------------
apt (0.8.16~exp5ubuntu12) oneiric; urgency=low

  [ David Kalnischkies ]
  * apt-pkg/deb/deblistparser.cc:
    - fix crash when the dynamic mmap needs to be remapped during
      LoadReleaseInfo (LP: #854090)
 -- Michael Vogt <email address hidden> Mon, 26 Sep 2011 13:31:11 +0200

Changed in apt (Ubuntu Oneiric):
status: In Progress → Fix Released
Evan Huus (eapache) wrote :

I just saw this again after updating and rebooting.

apt-cache madison reports:
apt | 0.8.16~exp5ubuntu12

So I do have the version which was supposed to contain a fix.

Michael Vogt (mvo) on 2011-09-27
Changed in update-manager (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → Medium
Changed in update-manager (Ubuntu Oneiric):
assignee: nobody → Michael Vogt (mvo)
Changed in update-manager (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
tags: removed: bugpattern-needed
tags: added: bugpattern-written
Mauricio Pretto (pretto) wrote :

just got it today after couple of hundred updates

Michael Vogt (mvo) wrote :

This is fixed in apt now, I close the update-manager task.

Changed in update-manager (Ubuntu Oneiric):
status: In Progress → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.152.20

---------------
update-manager (1:0.152.20) oneiric; urgency=low

  * DistUpgrade/DistUpgradeQuirks.py:
    - increase the default cache size on a multiarch system to
      avoid potential crash in natty apt (LP: #854090)
  * DistUpgrade/DistUpgradeController.py, UpdateManager/Core/utils.py:
    - do not leak password from sources.list entries into the logfile
      (LP: #839094)
  * UpdateManager/UpdateManager.py:
    - do not crash if a package can not be put into "install" state,
      instead, just keep the old (unmarked) state (LP: #850482)
  * UpdateManager/DistUpgradeFetcher.py:
    - fix crash for changed gtk2 -> gtk3 API (LP: #859862)
  * UpdateManager/backend/InstallBackendAptdaemon.py:
    - remove debug output (LP: #855495)
 -- Michael Vogt <email address hidden> Fri, 30 Sep 2011 16:09:55 +0200

Changed in update-manager (Ubuntu Oneiric):
status: Invalid → Fix Released
Shock (mmiron) wrote :

It happened again today. How is this fixed?

Jonathan Thomas (echidnaman) wrote :

I've gotten a report of this in 12.04: https://bugs.kde.org/show_bug.cgi?id=299800

Since it doesn't seem to be fixed, I'm re-opening the bug.

Changed in apt (Ubuntu):
status: Fix Released → Confirmed
tags: added: precise
Brian Murray (brian-murray) wrote :

We can see this still occurring regularly with later releases of Ubuntu at the Ubuntu Error Tracker.

https://errors.ubuntu.com/problem/1859029e9f0d88ba0e587718572a0d57e56f72c6

Brian Murray (brian-murray) wrote :

Bug 957231 is the most recent occurrence of this crash.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.