apt crashes on initial installation of oneiric

Bug #848907 reported by Colin Watson on 2011-09-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned
eglibc (Ubuntu)
Undecided
Unassigned

Bug Description

I attempted to install today's Kubuntu oneiric-alternate-i386.iso build, and got the attached apt crash. Unfortunately, and I'm sorry about this, I can't seem to reproduce it when I run the failing commands (basically 'apt-cdrom add' and 'apt-get update') by hand, and all I have to work with is a screenshot!

I'll see if I can drill down further. I don't think this is an isolated occurrence; the tester towards the end of bug 420080 seems to be experiencing the same symptoms.

Related branches

Colin Watson (cjwatson) wrote :
Colin Watson (cjwatson) wrote :
Colin Watson (cjwatson) wrote :
Colin Watson (cjwatson) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.16~exp5ubuntu8

---------------
apt (0.8.16~exp5ubuntu8) oneiric; urgency=low

  * cherry pick r1825 from lp:~mvo/apt/mvo:
    * apt-pkg/contrib/configuration.cc:
    - fix double delete (LP: #848907)
    - ignore only the invalid regexp instead of all options

  * cherry pick r2165 from lp:~donkult/apt/sid:
    [ David Kalnischkies ]
    * cmdline/apt-get.cc:
      - output list of virtual package providers to c1out in -q=1
        instead of /dev/null to unbreak sbuild (LP: #816155)
 -- Michael Vogt <email address hidden> Tue, 13 Sep 2011 18:23:09 +0200

Changed in apt (Ubuntu):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

This happened because regcomp fails on character ranges in the C.UTF-8 locale. See discussion at http://lists.debian.org/debian-glibc/2011/09/msg00114.html. For now I'm going to back out this eglibc change; C.UTF-8 is used during installation in various places and it's far too risky to make this kind of basic change to its semantics at this point in our release cycle.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.13-20ubuntu2

---------------
eglibc (2.13-20ubuntu2) oneiric; urgency=low

  * Back out Debian r4943 ("Don't include ISO14651 collation rules in
    C.UTF-8 locale") for now; this breaks regcomp on character ranges, which
    exposed a bug in apt, and seems likely to cause other problems, so is
    too risky a change for this point in our release cycle (LP: #848907).
 -- Colin Watson <email address hidden> Tue, 13 Sep 2011 17:37:32 +0100

Changed in eglibc (Ubuntu):
status: New → Confirmed
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers