cannot handle b-d [!linux-any]

Bug #787500 reported by Matthias Klose on 2011-05-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: germinate

see gvfs, b-d on hal:

   libhal-dev (>= 0.5.10) [!linux-any]

but hal shows up in component-mismatches

Related branches

Colin Watson (cjwatson) wrote :

apt (0.7.26~exp8) experimental; urgency=low

[...]
  [ Julian Andres Klode ]
[...]
  * apt-pkg/deb/deblistparser.cc:
    - Handle architecture wildcards (Closes: #547724).
[...]

 -- Michael Vogt <email address hidden> Fri, 09 Jul 2010 19:16:20 +0200

Backporting apt to cocoplum is probably a non-starter. I'm not sure exactly what to do here. Perhaps we need to work around it in germinate somehow.

Colin Watson (cjwatson) wrote :

>>> import apt_pkg
>>> apt_pkg.init_config()
>>> apt_pkg.config.set("APT::Architecture", "i386")
>>> apt_pkg.init_system()
>>> apt_pkg.parse_src_depends("hal [!linux-any]")
[[('hal', '', '')]]

(Succeeds on Natty.)

Colin Watson (cjwatson) wrote :

Actually, the apt patch isn't that enormous. Maybe it would be best to backport it.

Colin Watson (cjwatson) on 2011-05-24
affects: germinate (Ubuntu) → apt (Ubuntu)
Changed in apt (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in apt (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
Changed in apt (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

The attached patch backports what look like the relevant commits from current apt:

        revno: 1327.24.434
        fixes bug(s): http://bugs.debian.org/547724
        committer: Julian Andres Klode <email address hidden>
        branch nick: debian-experimental-ma
        timestamp: Sat 2010-06-26 20:56:44 +0200
        message:
          * apt-pkg/deb/deblistparser.cc:
            - Handle architecture wildcards (Closes: #547724).

        revno: 1327.24.436
        committer: Julian Andres Klode <email address hidden>
        branch nick: debian-experimental-ma
        timestamp: Sat 2010-06-26 23:01:49 +0200
        message:
          apt-pkg/deb/deblistparser.cc: Fix bug in architecture wildcard support.

          Previously, linux-any was always matched, because the code simply
          appended linux- to the APT::Architecture value. Now, it does this
          only if the APT::Architecture value does not contain "-".

        revno: 1327.24.437
        committer: Julian Andres Klode <email address hidden>
        branch nick: debian-experimental-ma
        timestamp: Sun 2010-06-27 21:04:53 +0200
        message:
          deblistparser: Special-case *-armel, lpia and powerpcspe architectures.

        revno: 1327.76.1
        author: Sebastian Andrzej Siewior <email address hidden>
        committer: David Kalnischkies <email address hidden>
        branch nick: apt-sid
        timestamp: Thu 2010-10-07 14:50:25 +0200
        message:
          * apt-pkg/deb/deblistparser.cc:
            - support ArmHardFloat port in CompleteArch, thanks to Sebastian
              Andrzej Siewior for the patch!

Michael, does this seem reasonable? Do you think we might be able to backport this to lucid-proposed?

Colin Watson (cjwatson) wrote :

With this patch, in a python session:

>>> import apt_pkg
>>> apt_pkg.init_config()
>>> apt_pkg.config.set("APT::Architecture", "i386")
>>> apt_pkg.init_system()
>>> apt_pkg.parse_src_depends("hal [!linux-any]")
[]

Of course, apt's general behaviour would need to be regression-tested.

Accepted apt into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in apt (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

I have used the proposed apt in my lucid chroot for 1.5 weeks now, and haven't noticed any regressions. apt-cache, apt-get install/purge etc. work fine.

Martin Pitt (pitti) wrote :

I also confirm that the test case now succeeds with the proposed version.

Colin Watson (cjwatson) wrote :

With apt 0.7.25.3ubuntu9.5:

>>> import apt_pkg
>>> apt_pkg.init_config()
>>> apt_pkg.config.set("APT::Architecture", "i386")
>>> apt_pkg.init_system()
>>> apt_pkg.parse_src_depends("hal [!linux-any]")
[]
>>> apt_pkg.parse_src_depends("hal [i386]")
[[('hal', '', '')]]
>>> apt_pkg.parse_src_depends("hal [powerpc]")
[]
>>> apt_pkg.parse_src_depends("hal [linux-i386]")
[[('hal', '', '')]]
>>> apt_pkg.parse_src_depends("hal [linux-any]")
[[('hal', '', '')]]
>>> apt_pkg.parse_src_depends("hal [any-i386]")
[[('hal', '', '')]]
>>> apt_pkg.parse_src_depends("hal [linux-any], foo [any-powerpc], bar [hurd-any]")
[[('hal', '', '')]]
>>> apt_pkg.parse_src_depends("hal [linux-any], foo [any-powerpc], bar [!hurd-any]")
[[('hal', '', '')], [('bar', '', '')]]

This all looks correct. I also did an upgrade of my lucid chroot to a bunch of batched-up stuff from lucid-updates:

The following packages will be upgraded:
  dhcp3-client dhcp3-common initscripts libdbus-1-3 libgssapi-krb5-2
  libk5crypto3 libkrb5-3 libkrb5support0 libldap-2.4-2 libpam-modules
  libpam-runtime libpam0g libtiff4 libtiff4-dev libtiffxx0c2 linux-libc-dev
  logrotate ntpdate openssh-client perl perl-base perl-modules sysv-rc
  sysvinit-utils tzdata x11-xserver-utils
26 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

... and that succeeded. I'm happy to call this good.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.7.25.3ubuntu9.5

---------------
apt (0.7.25.3ubuntu9.5) lucid-proposed; urgency=low

  [ Michael Vogt ]
  * debian/apt.cron.daily:
    - source /etc/default/locale (if available) so that the
      apt-get update cron job fetches the right translated package
      descriptions (LP: #652951)

  [ Loïc Minier ]
  * Backport r2014.1.2 (see below); fixes bug in APT when running the
    linaro-image-tools testsuite; LP: #709895.

    [ David Kalnischkies ]
    * apt-pkg/acquire-item.cc:
      - use also unsigned Release files again (Closes: #596189)

  [ Colin Watson ]
  * Backport r1327.24.434, 1327.24.437, 1327.76.1 (LP: #787500)
 -- Michael Vogt <email address hidden> Tue, 24 May 2011 18:23:29 +0200

Changed in apt (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.