upgrade from kubuntu 10.10 to 11.04 fails with "invalid package information"

Bug #772355 reported by Geoff Williams on 2011-04-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Hi,

I tried to upgrade an amd64 install of kubuntu 10.10 to kubuntu 11.04 this evening using kpackagekit. The upgrade fails with the message:

Invalid Package Information
After your package information was updated the essential package 'ubuntu-minimal' can not be found anymore.
This indicates a serious error, please report the bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.

(K)Ubuntu release ('lsb_release -rd'):
Description: Ubuntu 10.10
Release: 10.10

software version information (apt-cache policy ...)

update-manager:
  Installed: 1:0.142.23
  Candidate: 1:0.142.23
  Version table:
 *** 1:0.142.23 0
        100 /var/lib/dpkg/status

kpackagekit:
  Installed: 0.6.2-0ubuntu1
  Candidate: 0.6.2-0ubuntu1
  Version table:
 *** 0.6.2-0ubuntu1 0
        100 /var/lib/dpkg/status

Expected outcome:
I expected the installation to proceed beyond the "Setting new software channels" stage to complete the installation.

What happened instead:
The message above was generated. Clicking the close button exits the installer.

Alk (allank-bluebottle) wrote :

I can confirm this bug on 32 bit kubuntu 10.10. It used to be ubuntu but installed the kubuntu-desktop package.

KDE 4.6.2 from kubuntu ppa backports.

Alk (allank-bluebottle) wrote :

Fixed it by choosing the dk.archive.ubuntu.com mirror instead of mirrors.sunsite.dk. I guess some mirrors cannot do upgrades or they are not fully up to date.

Alk thanks for your fix, I changed my mirror from ftp.iinet.com.au to mirror.optus.net and now the upgrade proceeds.

How about if the installer could detect the problem was with the mirror and display a less serious sounding error or prompt the user to switch to a suggested mirror?

RedSingularity (redsingularity) wrote :

Since the update-manager uses the 'apt' system for its operations, and reading mirrors, I am switching the package assignment.

affects: update-manager (Ubuntu) → apt (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers