apport report blocking of dpkg I/O errors is incomplete

Bug #767776 reported by Brian Murray on 2011-04-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Brian Murray
Lucid
Low
Unassigned
Maverick
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Brian Murray

Bug Description

TEST CASE:
- the dpkg bugs are really hard to trigger so a regression test should be enough

Binary package hint: apt

apt currently prevents reporting of dpkg I/O errors in apt-pkg/deb/dpkgpm.cc by looking for the string 'short read in buffer_copy' from dpkg. However, this string has changed to 'short read on buffer copy for %s' and there are now more than one error messages used by dpkg (see lib/dpkg/buffer.c).

This incomplete blocking is leading to unnecessary bug reports in Launchpad.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: apt 0.8.13.2ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CheckboxSubmission: fee5e196cb921cbd36888f428b38b488
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Wed Apr 20 14:48:23 2011
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: apt
UpgradeStatus: Upgraded to natty on 2011-04-10 (10 days ago)

Brian Murray (brian-murray) wrote :
Changed in apt (Ubuntu Natty):
assignee: nobody → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

The Lucid version of dpkg has the following:

        if (bytesread < 0 || byteswritten < 0)
                ohshite(_("failed in buffer_copy (%s)"), desc);
        if (limit > 0)
                ohshit(_("short read in buffer_copy (%s)"), desc);

While apt looks for:

   if(strstr(errormsg, "short read in buffer_copy (")) {
      std::clog << _("No apport report written because the error message indicates a dpkg I/O error") << std::endl;
      return;
   }

So depending on the volume of apport-package bug reports regarding Lucid with 'failed in buffer_copy' this may be worth SRUing.

summary: - apport report blocking of dpkg I/O errors is incompletely
+ apport report blocking of dpkg I/O errors is incomplete
Brian Murray (brian-murray) wrote :

The Maverick version of dpkg uses the following:

        if (bytesread < 0)
                ohshite(_("failed to read on buffer copy for %s"), desc);
        if (byteswritten < 0)
                ohshite(_("failed in write on buffer copy for %s"), desc);
        if (limit > 0)
                ohshit(_("short read on buffer copy for %s"), desc);

Which is the same as Natty.

Brian Murray (brian-murray) wrote :

mvo - I found the reason for some of the additional apport package bug reports and I've attached a branch for Natty that should fix it. I haven't had a chance to test it yet though.

Changed in apt (Ubuntu Natty):
status: New → In Progress
Changed in apt (Ubuntu Lucid):
importance: Undecided → Low
Changed in apt (Ubuntu Maverick):
importance: Undecided → High
Changed in apt (Ubuntu Natty):
importance: Undecided → High
Changed in apt (Ubuntu Maverick):
milestone: none → maverick-updates
Michael Vogt (mvo) on 2011-04-21
description: updated
Changed in apt (Ubuntu Maverick):
status: New → In Progress
Changed in apt (Ubuntu Lucid):
status: New → Won't Fix
Michael Vogt (mvo) wrote :

Uploaded to both natty-propposed and maverick-proposed now

Accepted apt into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in apt (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted apt into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in apt (Ubuntu Maverick):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

I've been running apt version 0.8.13.2ubuntu3 from a local build since I reported this bug and haven't had any issues upgrading packages.

Martin Pitt (pitti) wrote :

Sorry, I misread it as "apport", but apt is a binary package. Setting back to v-needed for confirming with the actual package in the archive, and also for maverick.

tags: added: verification-done
removed: verification-needed
tags: added: verification-needed
removed: verification-done
Pedro Villavicencio (pedro) wrote :

I've testing the Maverick proposed package and did not encounter any regression with it (did a lot of installs, removals, etc). Also i've been using the one for Natty for a few days already and everything works fine as well, setting this as verification done.

tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

I also installed an Ubuntu desktop from a Maverick ISO, then installed the version of apt in maverick-proposed and installed all the packages in -updates and -proposed without any issues.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.13.2ubuntu3

---------------
apt (0.8.13.2ubuntu3) natty-proposed; urgency=low

  * apt-pkg/deb/dpkgpm.cc:
    - stop reporting of apport-package bug reports regarding
      dpkg I/O errors (LP: #767776)
 -- Brian Murray <email address hidden> Wed, 20 Apr 2011 15:05:12 -0700

Changed in apt (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.3ubuntu7.1

---------------
apt (0.8.3ubuntu7.1) maverick-proposed; urgency=low

  [ Brian Murray ]
  * apt-pkg/deb/dpkgpm.cc:
    - stop reporting of apport-package bug reports regarding
      dpkg I/O errors (LP: #767776)

  [ Michael Vogt ]
  * apt-pkg/deb/dpkgpm.cc:
    - backport improved dpkg I/O error detection
 -- Michael Vogt <email address hidden> Thu, 21 Apr 2011 15:41:29 +0200

Changed in apt (Ubuntu Maverick):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

This fix is included in Oneiric's version of apt.

Changed in apt (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Ryan Rawdon (flieslikeabrick) wrote :

Can someone explain the decision to mark this Won'tFix in Lucid? This bug seems to block the installation of linux-image-2.6.32-33-generic on one of our lucid machines, and being that it is an LTS release I find it surprising that this will not be fixed or even backported.

Brian Murray (brian-murray) wrote :

@Ryan - this bug report is about modifying apt to prevent specific types of package installation failures from being reported to Launchpad by apport. If you happen to be having a problem installing linux-image on a Lucid machine and have found this bug report I'd guess its because you are seeing 'short read in buffer_copy' error message when trying to install the package. This is likely due to a hardware or memory failure on your system which is corrupting the package. You should try investigating the system to see if it is failing. Thanks and good luck.

Changed in apt (Ubuntu Natty):
assignee: Brian Murray (brian-murray) → adam sikora (adam23sikora)
Changed in apt (Ubuntu Natty):
assignee: adam sikora (adam23sikora) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers