lucid unattended-upgrade requires successful apt-get update

Bug #676295 reported by Nikolaus Rath on 2010-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: unattended-upgrades

On all of my 4 lucid systems, unattended-upgrades stopped working on October 25th. The configuration has not been touched, but the script is apparently not being called anymore:

$ grep Starting /var/log/unattended-upgrades/unattended-upgrades.log | tail
2010-10-16 03:40:43,900 INFO Starting unattended upgrades script
2010-10-17 03:28:03,142 INFO Starting unattended upgrades script
2010-10-18 03:35:04,438 INFO Starting unattended upgrades script
2010-10-19 03:55:01,835 INFO Starting unattended upgrades script
2010-10-20 03:42:09,436 INFO Starting unattended upgrades script
2010-10-21 03:38:40,548 INFO Starting unattended upgrades script
2010-10-22 03:52:39,209 INFO Starting unattended upgrades script
2010-10-23 03:53:47,431 INFO Starting unattended upgrades script
2010-10-24 03:38:35,435 INFO Starting unattended upgrades script
2010-10-25 03:44:05,561 INFO Starting unattended upgrades script
$

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: unattended-upgrades 0.55ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-25.45-server 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-server x86_64
Architecture: amd64
Date: Tue Nov 16 18:22:19 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unattended-upgrades

Related branches

Nikolaus Rath (nikratio) wrote :
Nikolaus Rath (nikratio) wrote :

The source of the problem is that the /etc/cron.daily/apt aborts if it cannot find a repositories at one of the URLs in /etc/apt/sources.list (in this case a ppa). Is that intended behaviour? It seems to me that system upgrades should still happen even if some ppas are not available.

Nikolaus Rath (nikratio) wrote :
Download full text (14.5 KiB)

Here's the output of /etc/cron.daily/apt with VERBOSE=3 for an invalid URL:

# /etc/cron.daily/apt
verbose level 3
+ which on_ac_power
+ on_ac_power
+ POWER=255
+ [ 255 -eq 1 ]
+ [ 255 -ne 0 ]
+ debug_echo power status (255) undetermined, continuing
+ [ 3 -ge 1 ]
+ echo power status (255) undetermined, continuing
power status (255) undetermined, continuing
+ debug_echo system is on main power.
+ [ 3 -ge 1 ]
+ echo system is on main power.
system is on main power.
+ which apt-get
+ eval apt-get check -f
+ apt-get check -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
+ date +%s
+ now=1291217505
+ UpdateInterval=0
+ DownloadUpgradeableInterval=0
+ apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists DownloadUpgradeableInterval APT::Periodic::Download-Upgradeable-Packages
+ eval UpdateInterval='1' DownloadUpgradeableInterval='1'
+ UpdateInterval=1 DownloadUpgradeableInterval=1
+ AutocleanInterval=1
+ apt-config shell AutocleanInterval APT::Periodic::AutocleanInterval
+ eval AutocleanInterval='1'
+ AutocleanInterval=1
+ UnattendedUpgradeInterval=0
+ apt-config shell UnattendedUpgradeInterval APT::Periodic::Unattended-Upgrade
+ eval UnattendedUpgradeInterval='1'
+ UnattendedUpgradeInterval=1
+ AutocleanInterval=0
+ apt-config shell AutocleanInterval APT::Periodic::AutocleanInterval
+ eval AutocleanInterval='1'
+ AutocleanInterval=1
+ BackupArchiveInterval=0
+ apt-config shell BackupArchiveInterval APT::Periodic::BackupArchiveInterval
+ eval
+ Debdelta=1
+ apt-config shell Debdelta APT::Periodic::Download-Upgradeable-Packages-Debdelta
+ eval
+ [ 1 -eq 0 ]
+ do_cache_backup 0
+ BackupArchiveInterval=0
+ [ 0 -eq 0 ]
+ return
+ random_sleep
+ RandomSleep=1800
+ apt-config shell RandomSleep APT::Periodic::RandomSleep
+ eval
+ [ 1800 -eq 0 ]
+ [ -z ]
+ dd if=/dev/urandom count=1
+ cksum
+ cut -c1-5
+ RANDOM=92853
+ TIME=1053
+ debug_echo sleeping for 1053 seconds
+ [ 3 -ge 1 ]
+ echo sleeping for 1053 seconds
sleeping for 1053 seconds
+ sleep 1053
Terminated
+ UPDATED=0
+ UPDATE_STAMP=/var/lib/apt/periodic/update-stamp
+ check_stamp /var/lib/apt/periodic/update-stamp 1
+ stamp=/var/lib/apt/periodic/update-stamp
+ interval=1
+ [ 1 -eq 0 ]
+ [ ! -f /var/lib/apt/periodic/update-stamp ]
+ debug_echo check_stamp: missing time stamp file: /var/lib/apt/periodic/update-stamp.
+ [ 3 -ge 1 ]
+ echo check_stamp: missing time stamp file: /var/lib/apt/periodic/update-stamp.
check_stamp: missing time stamp file: /var/lib/apt/periodic/update-stamp.
+ return 0
+ eval apt-key net-update
+ apt-key net-update
+ debug_echo apt-key net-update (success)
+ [ 3 -ge 1 ]
+ echo apt-key net-update (success)
apt-key net-update (success)
+ eval apt-get -y update -o APT::Update::Auth-Failure::="cp /usr/share/apt/apt-auth-failure.note /var/lib/update-notifier/user.d/"
+ apt-get -y update -o APT::Update::Auth-Failure::=cp /usr/share/apt/apt-auth-failure.note /var/lib/update-notifier/user.d/
Hit http://ubuntu.media.mit.edu lucid Release.gpg
Ign http://ubuntu.media.mit.edu/ubuntu/ lucid/main Translation-en_US
Ign http://ubuntu.media.mit.edu/ubuntu/ lucid/restricted Translation-en_US ...

Michael Vogt (mvo) wrote :

The problem is the following line:

Err http://ppa.launchpad.net lucid/main Packages
  404 Not Found
W: Failed to fetch http://ppa.launchpad.net/mercurial/releases/ubuntu/dists/lucid/main/binary-amd64/Packages.gz 404 Not Found

The cron job runs unattended-upgrade only if [ $UPDATED -eq 1 ]

Changed in unattended-upgrades (Ubuntu):
status: New → Confirmed
importance: Undecided → High
summary: - lucid unattended-upgrades stopped working on 2010-10-25
+ lucid unattended-upgrade requires successful apt-get update
Michael Vogt (mvo) wrote :

I fixed this now in the most recent apt upload.

affects: unattended-upgrades (Ubuntu) → apt (Ubuntu)
Changed in apt (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers