Can't update system after uninstall

Bug #654393 reported by First on 2010-10-04
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Fabián Rodríguez

Bug Description

Binary package hint: squid-deb-proxy-client

I was trying to find out what's the problem on my network and decided to remove the following packages on my Ubuntu Lucid (client):
squid-deb-proxy-client 0.3.1
avahi-utils 0.6.25-1ubuntu6.1

A while ago, I tried to update and install the removed packages and I get this:
"Failed to exec method /usr/share/squid-deb-proxy-client/apt-avahi-discover"

Related branches

David L (toxicdav3) wrote :

The package does not clean up all its changes.

Removing the line:
Acquire::http::ProxyAutoDetect "/usr/share/squid-deb-proxy-client/apt-avahi-discover";

from:
/etc/apt/apt.conf.d/30autoproxy

Cheers.

Michael Vogt (mvo) on 2010-11-10
Changed in squid-deb-proxy (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Michael Vogt (mvo) on 2010-11-10
Changed in squid-deb-proxy (Ubuntu):
status: In Progress → Fix Committed
Michael Vogt (mvo) on 2010-11-22
affects: squid-deb-proxy (Ubuntu) → apt (Ubuntu)
Changed in apt (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.9ubuntu3

---------------
apt (0.8.9ubuntu3) natty; urgency=low

  * methods/http.cc:
    - do not hang if Acquire::http::ProxyAutoDetect can not be
      executed or returns no data (LP: #654393)
 -- Michael Vogt <email address hidden> Mon, 22 Nov 2010 10:42:50 +0100

Changed in apt (Ubuntu):
status: In Progress → Fix Released
Fabián Rodríguez (magicfab) wrote :

I just had this problem on a 10.04 LTS system. I believe this would be a good SRU candidate.

Jorge Castro (jorge) on 2010-11-29
Changed in apt (Ubuntu):
milestone: none → ubuntu-10.04.2
Saji Nediyanchath (saji89) wrote :

Same error seems to be occuring again in Ubuntu 12.04.2 LTS

Martin Albisetti (beuno) wrote :

This bug seems to have indeed cropped up again.

Changed in apt (Ubuntu):
status: Fix Released → Confirmed
assignee: Michael Vogt (mvo) → nobody
Michael Vogt (mvo) wrote :

@Martin: What do I need to do to reproduce this problem?

Dan Watkins (daniel-thewatkins) wrote :

I can confirm that an uninstall of squid-deb-proxy-client (but not the server on the same machine) has left me with:

Acquire::http::ProxyAutoDetect "/usr/share/squid-deb-proxy-client/apt-avahi-discover";

in /etc/apt/apt.conf.d/30autoproxy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers