apt-get warnings on upgrade

Bug #631770 reported by Anders on 2010-09-06
126
This bug affects 81 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: apt

After running a dist-upgrade, a ton of informational error messages are shown for my 'old' PPAs/repositories (removed automatically when I upgraded to Maverick, yet they seem to have left behind a '.save' file that apt-get doesn't like:

N: Ignoring file '20archive.save' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
N: Ignoring file '25adept-archive-limits.save' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
N: Ignoring file 'medibuntu.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ubuntuone-beta-sources.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'medibuntu.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ubuntuone-beta-sources.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'telepathy-ppa-karmic.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'team-xbmc-ppa-karmic.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'nvidia-vdpau-ppa-karmic.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'google-chrome.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'banshee-team-ppa-karmic.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'telepathy-ppa-karmic.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'team-xbmc-ppa-karmic.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'nvidia-vdpau-ppa-karmic.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'google-chrome.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'banshee-team-ppa-karmic.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'google-talkplugin.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'team-xbmc-ppa-maverick.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: apt 0.8.0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CheckboxSubmission: afab8a4a6bea108b46a135d1f7175049
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Mon Sep 6 18:09:43 2010
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: apt

Anders (andersja+launchpad-net) wrote :
Anders (andersja+launchpad-net) wrote :

Online, people are posting what seems like rather 'hacky' workarounds - I am sure something cleaner can be done centrally / automatically?

http://www.absolutelytech.com/2010/08/27/solved-ignoring-file-distupgrade-save-in-directory-etcaptsources-list-d-as-it-has-an-invalid-filename-extension-on-ubuntu-10-10/

Michael Vogt (mvo) on 2010-09-07
Changed in apt (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
milestone: none → ubuntu-10.10
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package apt - 0.8.3ubuntu1

---------------
apt (0.8.3ubuntu1) maverick; urgency=low

  * merged fixes from debian-sid
  * debian/rules:
    - put ubuntu-archive.gpg back into the package (LP: #620576)
  * apt-pkg/init.cc:
    - ignore ".distUpgrade" and ".save" files in sources.list.d
      (LP: #631770)

apt (0.8.3) unstable; urgency=low

  [ Manpages translations ]
  * Japanese (KURASAWA Nozomu). Closes: #595862

  [ Michael Vogt ]
  * apt-pkg/indexcopy.cc:
    - only use trusted.gpg.d directory if it exists
    - do not replace /dev/null when running in APT::CDROM::NoAct
      mode (LP: #612666), thanks to Colin Watson

  [ David Kalnischkies ]
  * ftparchive/apt-ftparchive.cc:
    - ensure that BinDirectory as well as Tree settings get
      the correct default FileMode setting (Closes: #595922)

apt (0.8.2) unstable; urgency=low

  [ Manpages translations ]
  * Spanish (Omar Campagne). Closes: #595557

  [ David Kalnischkies ]
  * apt-pkg/versionmatch.cc:
    - do not accept 'Pin: origin "' (missing closing ") as a valid
      way to pin a local archive: either "" or none…
  * apt-pkg/deb/dpkgpm.cc:
    - create Dir::Log if needed to support /var/log as tmpfs or similar,
      inspired by Thomas Bechtold, thanks! (Closes: #523919, LP: #220239)
  * apt-pkg/indexcopy.cc:
    - support really still the APT::GPGV::TrustedKeyring setting,
      as it breaks d-i badly otherwise (Closes: #595428)
  * cmdline/apt-key:
    - support also Dir::Etc::Trusted so that apt-key works in the same
      way as the library part which works with the trusted files
  * methods/{gzip,bzip2}.cc:
    - empty files can never be valid archives (Closes: #595691)

apt (0.8.1) unstable; urgency=low

  [ Programs translations ]
  * Thai (Theppitak Karoonboonyanan). Closes: #592695
  * Russian (Yuri Kozlov). Closes: #594232
  * Slovak (Ivan Masár). Closes: #594255
  * Swedish (Daniel Nylander). Closes: #594241
  * Japanese (Kenshi Muto, Osamu Aoki). Closes: #594265
  * Italian (Milo Casagrande). Closes: #594238
  * Asturian (maacub). Closes: #594303
  * Simplified Chinese (Aron Xu). Closes: #594458
  * Bulgarian (Damyan Ivanov). Closes: #594627
  * Portuguese (Miguel Figueiredo). Closes: #594668
  * Korean (Changwoo Ryu). Closes: #594809
  * Norwegian Bokmål (Hans Nordhaug). Closes: #595182
  * Danish (Joe Hansen). Closes: #595176
  * Catalan (Agustí Grau). Closes: #595234

  [ Christian Perrier ]
  * Fix spelling error in cmdline/apt-get.cc. Thanks to Osamu Aoki
    Closes: #594211

  [ Manpages translations ]
  * Portuguese (Américo Monteiro)

  [ David Kalnischkies ]
  * cmdline/apt-cache.cc:
    - show in madison command again also source packages (LP: #614589)
    - remove useless GetInitialize method
  * cmdline/apt-get.cc:
    - remove direct calls of ReadMainList and use the wrapper instead
      to protect us from useless re-reads and two-times notice display
    - remove death code by removing unused GetInitialize
  * apt-pkg/depcache.cc:
    - now that apt-get purge works on 'rc' packages let the MarkDelete
      pass this purge forward to the non-pseudo package for pseudos
  * apt-pkg/contrib/fileutl.cc:
    - apply SilentlyIgnore...

Read more...

Changed in apt (Ubuntu):
status: In Progress → Fix Released
Cengiz Can (cengizcan) wrote :

That fix seems to be not working.

Getting invalid extension warnings at apt after reloading the cache in synaptic gui.

10.10 x86 installed with Wubi on x64 CPU, apt package version 0.8.3ubuntu7

Volkan Gezer (volkangezer) wrote :

This still exists using Ubuntu 15.04 Dev.

heartsmagic (heartsmagic) wrote :

And still exists on 16.04 beta.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers