Ubuntu

Apt is ignoring the Apt::Get::AllowUnauthenticated option

Reported by Wookey on 2010-08-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: apt

sudo apt-get -o Apt::Architecture=armel -o Apt::Get::AllowUnauthenticated=true -o Apt::Get::Download-Only=true -o Apt::Install-Recommends=false -o Dir=/tmp/rootstrap/ -o Dir::Etc=/tmp/rootstrap/etc/apt/ -o Dir::State=/tmp/rootstrap/var/lib/apt/ -o Dir::State::Status=/tmp/rootstrap/var/lib/dpkg/status -o Dir::Cache=/tmp/rootstrap/var/cache/apt/ update

fails with: GPG error: http://archive.ubuntu.com maverick Release: Unable to read /tmp/rootstrap/etc/apt/trusted.gpg.d/ - opendir (2: No such file or directory)

With Apt::Get::AllowUnauthenticated=true it shouldn't be looking there.

Reverting to apt_0.7.26~exp12ubuntu3 makes the problem go away (the apt updates completes as expected)

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: apt 0.8.0ubuntu1
Uname: Linux 2.6.32-trunk-amd64 x86_64
NonfreeKernelModules: snd_seq_dummy iwlagn nfs lockd fscache nfs_acl auth_rpcgss sunrpc sco parport_pc ppdev bridge lp parport stp bnep rfcomm l2cap input_polldev binfmt_misc uinput fuse ext3 jbd loop snd_hda_codec_conexant arc4 ecb btusb bluetooth pl2303 snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_midi snd_rawmidi iwlcore snd_seq_midi_event snd_seq usbserial snd_timer i915 mac80211 snd_seq_device drm_kms_helper drm snd cfg80211 thinkpad_acpi soundcore led_class snd_page_alloc rfkill intel_agp psmouse i2c_i801 i2c_algo_bit nvram agpgart serio_raw pcspkr evdev i2c_core video output wmi button battery ac processor ext4 mbcache jbd2 crc16 sha256_generic cryptd aes_x86_64 aes_generic cbc dm_crypt dm_mod sd_mod crc_t10dif uhci_hcd ahci libata thermal ehci_hcd scsi_mod usbcore thermal_sys e1000e nls_base
Architecture: amd64
Date: Fri Aug 27 00:58:24 2010
ProcEnviron: PATH=(custom, no user)
SourcePackage: apt

Wookey (wookey) wrote :
summary: - Apt is ignoring the -o Apt::Get::AllowUnauthenticated option
+ Apt is ignoring the Apt::Get::AllowUnauthenticated option
Wookey (wookey) wrote :

This means that it is impossible to install packages from unauthenticated archives.

This prevent pdebuild-cross from working, because it makes a minimal build environment from plain maverick plus toolchains from Marcin's repository at http://people.canonical.com/~hrw/ubuntu-maverick-armel-cross-compilers/ and those packages are not signed

At some point during the release everything needed will come from maverick directly and this will cease to be a direct issue, but it's definately a serious bug that should be fixed

Michael Vogt (mvo) on 2010-09-03
Changed in apt (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
milestone: none → maverick-updates
milestone: maverick-updates → ubuntu-10.10
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Is apt failing with a exitcode != 0 ? Could you please give the full output? Those should only be warnings (but misleading ones).
Could you please paste the full command output? I fixed parts of this in the my lp:~mvo/apt/mvo branch

Thanks,
 Michael

Wookey (wookey) wrote :

I cannot reproduce this issue any more. I'm not entirely convinced that it has actually been fixed but it no longer appears to be a problem at least.

Changed in apt (Ubuntu):
status: In Progress → Invalid
Moisa Doru (moisadoru) wrote :

I can reproduce this bug. We have an internal deb repo, and I don't have the pub key.
I tried

sudo apt-get -o Apt::Get::AllowUnauthenticated=true update
sudo apt-get -o Apt::Get::AllowUnauthenticated=1 update
sudo apt-get --allow-unauthenticated=true update
sudo apt-get --allow-unauthenticated=1 update

and the result was apt-get complaining:

W: GPG error: http://[local repo] Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY [KEY]

Info:
 - kernel 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:24:00 UTC 2010 i686 GNU/Linux
 - apt version: apt 0.8.3ubuntu7 for i386 compiled on Oct 5 2010 14:07:36

Changed in apt (Ubuntu):
status: Invalid → Confirmed
Changed in apt (Ubuntu):
milestone: ubuntu-10.10 → maverick-updates
Julian Andres Klode (juliank) wrote :

It's a warning, not an error.

Changed in apt (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers