mirror: method should try the next mirror on 404

Bug #601916 reported by Colin Watson on 2010-07-05
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: apt

My maverick dist-upgrade attempt failed with:

  Failed to fetch mirror://mirrors.ubuntu.com/mirrors.txt/pool/universe/l/lilypond/lilypond-data_2.12.3-6_all.deb 404 Not Found
  Failed to fetch mirror://mirrors.ubuntu.com/mirrors.txt/pool/universe/q/qemu-kvm/qemu-kvm-extras_0.12.4+noroms-0ubuntu4_i386.deb 404 Not Found
  Failed to fetch mirror://mirrors.ubuntu.com/mirrors.txt/pool/universe/t/ttf-baekmuk/ttf-baekmuk_2.2-3_all.deb 404 Not Found
  Failed to fetch mirror://mirrors.ubuntu.com/mirrors.txt/pool/universe/t/ttf-kochi/ttf-kochi-mincho_20030809-9_all.deb 404 Not Found
  Failed to fetch mirror://mirrors.ubuntu.com/mirrors.txt/pool/universe/w/wireshark/wireshark-common_1.2.9-1_i386.deb 404 Not Found
  Failed to fetch mirror://mirrors.ubuntu.com/mirrors.txt/pool/universe/g/gcc-mingw32/gcc-mingw32_4.4.4-0.1_i386.deb 404 Not Found
  E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I'm pretty certain that at least some of those files were available on at least one mirror; if nothing else, http://mirrors.ubuntu.com/mirrors.txt shows http://archive.ubuntu.com/ubuntu/ as its first entry, and that definitely has that version of lilypond-data. Shouldn't mirror: try other mirrors if one of them 404s? Otherwise it seems that it is likely to fail if any of the mirrors is unreliable, rather than giving me increased reliability which I think should be achievable.

Here's what http://mirrors.ubuntu.com/mirrors.txt looks like from here:

  http://archive.ubuntu.com/ubuntu/
  http://mirror.ox.ac.uk/sites/archive.ubuntu.com/ubuntu/
  http://www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu/
  http://ubuntu.retrosnub.co.uk/ubuntu/
  http://mirrors.melbourne.co.uk/ubuntu/
  http://ubuntu.datahop.net/ubuntu/
  http://mirror01.th.ifl.net/ubuntu/
  http://mirror.as29550.net/archive.ubuntu.com/
  http://mirror.sov.uk.goscomb.net/ubuntu/
  http://ubuntu.positive-internet.com/ubuntu/
  http://ubuntu.virginmedia.com/archive/
  http://mirror.bytemark.co.uk/ubuntu/

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: apt 0.7.25.3ubuntu9
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Mon Jul 5 15:15:04 2010
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_GB:en
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: apt

Colin Watson (cjwatson) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Support for this version has ended

Changed in apt (Ubuntu):
status: Confirmed → Invalid
n0PxN0p (n0pxn0p) wrote :

confirming for 16.04

E: Failed to fetch mirror://mirrors.ubuntu.com/mirrors.txt/dists/xenial-security/main/i18n/Translation-en 404 Not Found [Mirror: http://linux.psu.ru/ubuntu/]
E: Some index files failed to download. They have been ignored, or old ones used instead.

However it would be sane to try to cycle for next one in ~my~ http://mirrors.ubuntu.com/mirrors.txt
---
http://mirror.yandex.ru/ubuntu/
http://linux.psu.ru/ubuntu/
http://mirror.logol.ru/ubuntu/
http://mirror.timeweb.ru/ubuntu/
http://linux.nsu.ru/ubuntu/
http://mirror.corbina.net/ubuntu/
http://mirror.rol.ru/ubuntu/
http://archive.ubuntu.com/ubuntu/
---

Package: apt
Essential: yes
State: installed
Automatically installed: no
Version: 1.2.12~ubuntu16.04.1
Priority: important
Section: admin
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Uncompressed Size: 3 384 k
Depends: libapt-pkg5.0 (>= 1.2.2), libc6 (>= 2.15), libgcc1 (>= 1:3.0), libstdc++6 (>= 5.2), init-system-helpers (>= 1.18~), ubuntu-keyring, gpgv | gpgv2, gnupg | gnupg2, adduser
Suggests: aptitude | synaptic | wajig, dpkg-dev (>= 1.17.2), apt-doc, python-apt
Conflicts: apt:i386
Breaks: apt-utils (< 1.1.3), apt-utils:i386 (< 1.1.3), manpages-it (< 2.80-4~), manpages-pl (< 20060617-3~), openjdk-6-jdk (< 6b24-1.11-0ubuntu1~), sun-java5-jdk (> 0), sun-java6-jdk (> 0)
Replaces: bash-completion (< 1:2.1-4.2+fakesync1), bash-completion:i386 (< 1:2.1-4.2+fakesync1), manpages-it (< 2.80-4~), manpages-pl (< 20060617-3~), openjdk-6-jdk (< 6b24-1.11-0ubuntu1~), sun-java5-jdk (> 0), sun-java6-jdk (> 0)
Description: commandline package manager
 This package provides commandline tools for searching and managing as well as querying information about packages as a low-level access to all features of the libapt-pkg library.

 These include:
 * apt-get for retrieval of packages and information about them from authenticated sources and for installation, upgrade and removal of packages together with their dependencies
 * apt-cache for querying available information about installed as well as installable packages
 * apt-cdrom to use removable media as a source for packages
 * apt-config as an interface to the configuration settings
 * apt-key as an interface to manage authentication keys

Changed in apt (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers