apt-get --help conflicts with both man page and reality

Bug #57487 reported by Rocco Stanzione on 2006-08-23
2
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Michael Vogt

Bug Description

apt-get --help says, among other things:

  -f Attempt to continue if the integrity check fails

under Options. The man page differs significantly:

       -f, --fix-broken
              Fix; attempt to correct a system with broken dependencies in place. This option, when
              used with install/remove, can omit any packages to permit APT to deduce a likely so
              lution. Any Package that are specified must completely correct the problem. The op
              tion is sometimes necessary when running APT for the first time; APT itself does not
              allow broken package dependencies to exist on a system. It is possible that a sys
              tems dependency structure can be so corrupt as to require manual intervention (which
              usually means using dselect(8) or dpkg --remove to eliminate some of the offending
              packages). Use of this option together with -m may produce an error in some situa
              tions. Configuration Item: APT::Get::Fix-Broken.

The man page is correct.

Related branches

Rocco Stanzione (trappist) wrote :

I've given up trying to make a debdiff with this package. When I recover from this frustration I'll try a good-old-fashioned diff.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

It seems like the --help output needs a better wording. I'm open for suggestions.

In fact, it is not that wrong because apt-get will indeed not continue if it detects broken dependencies on the system (the integrity check).

Cheers,
 Michael

Rocco Stanzione (trappist) wrote :

When the integrity check is referred to in the man page, and what I understood it to mean in the --help output, it is clarified to mean corrupted packages. At any rate, continuing in spite of brokenness isn't the purpose of -f. I still plan to get around to making a diff. Meanwhile, are you "mzo"? If so, I was advised to ask you why it's so difficult to make a debdiff on the apt package. Debuild -s runs a configure script and makes tens of thousands of lines of changes, making it practically impossible to produce a useful debdiff.

Rocco Stanzione (trappist) wrote :

Here's that patch.

Michael Vogt (mvo) on 2006-09-05
Changed in apt:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Michael Vogt (mvo) on 2008-03-11
Changed in apt:
assignee: nobody → mvo
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.7.9ubuntu14

---------------
apt (0.7.9ubuntu14) hardy; urgency=low

  * cmdline/apt-get.cc:
    - fix incorrect help output for -f (LP: #57487)
    - run the problemResolver after a task was installed
      so that it can correct any missing dependencies
  * typo fixes (LP: #107960)

 -- Michael Vogt <email address hidden> Tue, 11 Mar 2008 21:46:07 +0100

Changed in apt:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers