failure on karmic->lucid distribution upgrade when openoffice.org-report-builder is installed

Bug #571030 reported by Bret Fledderjohn on 2010-04-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: update-manager

Crashed during the upgrade (about 60%)

Michael Vogt (mvo) wrote :

Here is the error:

dpkg: dependency problems prevent configuration of libcurl3-gnutls:^M
 libcurl3-gnutls depends on libldap-2.4-2 (>= 2.4.7); however:^M
  Package libldap-2.4-2 is not configured yet.^M
dpkg: error processing libcurl3-gnutls (--configure):^M
 dependency problems - leaving unconfigured^M

this looks like the ordering is incorrect, I try to reproduce now.

Do you have /var/log/dist-upgrade/system_state.tar.gz ? That would help me reproducing.

Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High
summary: - update-manager crashes for Lucid distribution upgrade
+ update-manager crashes for Lucid distribution upgrade (ordering
+ problem?)
Michael Vogt (mvo) wrote :

With the system_state data I get:
$ apt-get -o Dir=/tmp/broken-apt2 -o Dir::state::status=./var/lib/dpkg/status dist-upgrade -s
in line 1766
Conf libcurl3-gnutls (7.19.7-1ubuntu1 de.archive.ubuntu.com [amd64]) []
but in line 2556
Conf libldap-2.4-2 (2.4.21-0ubuntu5.3 de.archive.ubuntu.com [amd64])

The empty [] behind libcurl3-gnutls is also a bit odd. I run it now with -o Debug::pkgDpkgPM=1

Michael Vogt (mvo) wrote :

With
$ DEBIAN_FRONTEND=noninteractive apt-get -o Dir=/tmp/broken-apt2 -o Dir::state::status=./var/lib/dpkg/status dist-upgrade -o Debug::pkgDpkgPM=1 2>&1 | egrep '(libcurl3-gnutls|libldap-2.4-2)'
/usr/bin/dpkg --status-fd 260 --unpack .. /var/cache/apt/archives/libldap-2.4-2_2.4.21-0ubuntu5.3_amd64.deb /tmp/broken-apt2/var/cache/apt/archives/libcurl3-gnutls_7.19.7-1ubuntu1_amd64.deb ...
/usr/bin/dpkg --status-fd 434 --configure .. libcurl3-gnutls ..
/usr/bin/dpkg --status-fd 448 --configure .. libldap-2.4-2 ..

But this should have happend in the same configure run!

Michael Vogt (mvo) wrote :

There is a interessting observation here. If I remove openoffice.org-report-builder from the installed system the upgrade works corretly:
...
/usr/bin/dpkg --status-fd 260 --unpack /var/cache/apt/archives/libldap-2.4-2_2.4.21-0ubuntu5.3_amd64.deb /var/cache/apt/archives/libcurl3-gnutls_7.19.7-1ubuntu1_amd64.deb
/usr/bin/dpkg --status-fd 444 --configure libldap-2.4-2 ... libcurl3-gnutls
....

Michael Vogt (mvo) wrote :

When running the original (buggy) upgrade, I see with Debug::pkgPackageManager=true:
PreDepends order for openoffice.org-report-builder
Trying to SmartConfigure openoffice.org-common
SmartConfigure openoffice.org-common
  DepAdd: openoffice.org-common
    DepAdd: openoffice.org-style-oxygen
      DepAdd: openoffice.org-core
        DepAdd: libcairo2
          DepAdd: libdirectfb-1.2-0
            DepAdd: libsysfs2
            DepAdd: libts-0.0-0
              DepAdd: tsconf
          DepAdd: libfontconfig1
            DepAdd: libexpat1
            DepAdd: libfreetype6
            DepAdd: fontconfig-config
              DepAdd: ucf
              DepAdd: ttf-dejavu-core
          DepAdd: libpixman-1-0
          DepAdd: libpng12-0
          DepAdd: libx11-6
            DepAdd: libxcb1
              DepAdd: libxau6
              DepAdd: libxdmcp6
            DepAdd: libx11-data
          DepAdd: libxcb-render-util0
            DepAdd: libxcb-render0
          DepAdd: libxrender1
        DepAdd: libcurl3-gnutls
          DepAdd: libgcrypt11
            DepAdd: libgpg-error0
          DepAdd: libgnutls26
            DepAdd: libtasn1-3
          DepAdd: libgssapi-krb5-2
            DepAdd: libk5crypto3
              DepAdd: libkeyutils1
              DepAdd: libkrb5support0
            DepAdd: libkrb5-3
          DepAdd: libidn11
          DepAdd: libldap-2.4-2
            DepAdd: libsasl2-2
        DepAdd FAILS on: openoffice.org-core
      DepAdd FAILS on: openoffice.org-style-oxygen
    DepAdd: openoffice.org-style-human
    DepAdd: ure
      DepAdd: uno-libs3
      DepAdd: libxml2

Michael Vogt (mvo) on 2011-03-17
affects: update-manager (Ubuntu) → apt (Ubuntu)
Michael Vogt (mvo) on 2011-03-17
summary: - update-manager crashes for Lucid distribution upgrade (ordering
- problem?)
+ update-manager crashes on karmic->lucid distribution upgrade when
+ openoffice.org-report-writer is installed
Michael Vogt (mvo) on 2011-03-17
summary: update-manager crashes on karmic->lucid distribution upgrade when
- openoffice.org-report-writer is installed
+ openoffice.org-report-builder is installed
summary: - update-manager crashes on karmic->lucid distribution upgrade when
- openoffice.org-report-builder is installed
+ failure on karmic->lucid distribution upgrade when openoffice.org-
+ report-builder is installed
Julian Andres Klode (juliank) wrote :

Likely fixed in 1.3 or newer, as we just hand large batches to dpkg and let it do its magic.

Changed in apt (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions