Software Store Forbids Installation After apt-get Update cannot directly access Internet

Bug #487682 reported by jhfhlkjlj on 2009-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

I'm on a university connection that requires a log in every twelve hours before I may access the internet. When apt-get update is automatically run, it can't download the information, which is fine. Once I'm logged in again, though, and try to install something through the software-store, it tells me that my package is an untrusted source.

I never had this problem with gnome-app-install or synaptic, this has only happened with software-center, so I'm filing the bug against that package. Synaptic/apt-get will warn you that the package sources cannot be authenticated but will still allow you to install. The Software Center/update manager will flat-out refuse to until the sources are updated.

Please see the screenshot for a visual or the video demonstrating the bug process in post 6.

ProblemType: Bug
Architecture: i386
Date: Tue Nov 24 11:38:10 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: software-center 1.0.2
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: software-center
Uname: Linux 2.6.31-15-generic i686

description: updated

Naturally, the workaround for this is to manually run 'sudo apt-get update'

Omer Akram (om26er) wrote :

Chauncellor is this happening in Ubuntu 10.10?

Changed in software-center (Ubuntu):
status: New → Incomplete

Yep, still does. Same error message.

Changed in software-center (Ubuntu):
status: Incomplete → New

I have made a little video demonstrating how it works as merely a screenshot may not be enough information.

description: updated
description: updated
summary: - Software Store Forbids Installation After apt-get Update Can Not Access
- The Internet
+ Software Store Forbids Installation After apt-get Update cannot directly
+ access Internet
Michael Vogt (mvo) wrote :

This is a bug in apt-get and the auto update then, does your uni server a nonstandard page (instead of 404, 403 a 200 ok with custom message)? Could you attach the content of /var/lib/apt/lists/partial please ?

Michael Vogt (mvo) wrote :

Btw, I *think* this is fixed in oneiric now and also in a SRU to 11.04. It was a apt bug.

Matthew Paul Thomas (mpt) wrote :

I won't disagree with Michael that if what apt-get update receives is not a package list, it should be discarded rather than overwriting the known-good package list. However, that wouldn't solve the problem of trying to install packages, because whenever apt tried to download a package, it would still get a copy of the sign-on page instead of the package data.

The same problem will occur for when you connect to an open wi-fi network that requires sign-in or payment, and try installing software before going through the sign-in process. Feel free to copy the rest of this comment elsewhere if the bug is already reported.

Here's how I imagine this working:

1. apt (or Empathy, or Thunderbird...) retrieves something over the Internet that is very different from the kind of data it was expecting.

2. apt says to Network Manager (since it's running), "Hey, I think we might not have a proper Internet connection here. Can you deal with it? I'll wait."

3. Network Manager sends off a request for a very simple ubuntu.com Web page of known contents, but receives something very different. "Yep, we're in sign-on land all right."

4. Since a GUI is running, and a sign-on window isn't open already, Network Manager opens one to display the response it received. It's a minimal browser-like window, with the title something like "Connect to {wi-fi network name}" if it's a wi-fi network, or "Connect to the Internet" otherwise.

5. You click "Register as a new user" in the Web page. Network Manager detects that you've gone from one page to another in the sign-on window, so for all it knows, you might be finished. Just in case you are, it tries retrieving that tiny test Web page again. Again the response is wrong, so NM knows you aren't finished.

6. Finally you complete the sign-on process. Again Network Manager detects that you've gone from one page to another (or that you closed the sign-on window), so it tests again to see whether you have a Web connection. This time, success. Network Manager broadcasts a D-Bus message, "okay, we're online now".

7. apt hears the message, and tries the original request again. This time, it works.

affects: software-center (Ubuntu) → apt (Ubuntu)
Changed in apt (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Oneiric's software center has actually lost error messages entirely: The same behavior will make a progress bar flip out then act like I never touched the 'install' button. No error message. Apt-get will do the same thing as before: Ask if I'm sure I want to install an unauthenticated package.

@mvo: my 'partial' directory contains about nine blank files with titles dealing with my for-paid apps, e.g.

"private-ppa.launchpad.net_commercial-ppa-uploaders_world-of-goo_ubuntu_dists_natty_main_i18n_Translation-en%5fUS"

Michael Vogt (mvo) wrote :

Thanks for this updated info! This is actually progress (but still a bug). It seems that now the package information is correct, so s-c tries to download the package but that fails. Obviously this should result in a error. Anything on the terminal or in ~/.xsession-errors when this happens?

Sorry, I'm away from the university until Sunday. I'll put the logs in my to-do list; for now I cannot access them.

update-manager contains the same "requires installation of untrusted packages" message. No terminal output was useful for either update-manager or software-center.

I'm attaching two xsession-errors files: One when running update-manager's "check" functionality and one trying to install software via the software-center.

For the record, I have since left the university. I'll be unable to give any more information. Should I invalidate this bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers